Results 1 to 9 of 9

Thread: pure-ftpd won't start as a service

  1. #1

    Default pure-ftpd won't start as a service

    Hi,

    I just upgraded from 11.4 to 13.1 (fresh install) and now my pure-ftpd won't start via the init script. There is nothing in the logs, I can query the status and that is what I get:

    pure-ftpd.service - Pure-FTPd FTP server
    Loaded: loaded (/usr/lib/systemd/system/pure-ftpd.service; disabled)
    Active: inactive (dead)

    Dec 02 17:31:43 hawkeye systemd[1]: Starting Pure-FTPd FTP server...
    Dec 02 17:31:43 hawkeye systemd[1]: Started Pure-FTPd FTP server.
    Dec 02 17:31:43 hawkeye pure-config.pl[27071]: Running: /usr/sbin/pure-ftpd -A -c10 -B -C3 -d -z -D -E -fftp -F/usr/share/fortune/zippy -H -I15 -lpuredb:...-Z -Y0 -4
    Hint: Some lines were ellipsized, use -l to show in full.
    When I look at the journal there is not really more information:

    Dec 02 17:31:43 hawkeye systemd[1]: Starting Pure-FTPd FTP server...
    Dec 02 17:31:43 hawkeye systemd[1]: Started Pure-FTPd FTP server.Dec 02 17:31:43 hawkeye pure-config.pl[27071]: Running: /usr/sbin/pure-ftpd -A -c10 -B -C3 -d -z -D -E -fftp -F/usr/share/fortune/zippy -H -I15 -lpuredb:/etc/pure-ftpd/pureftpd.pdb -lpam -L10000:8 -m4 -p30000:30100 -s -u40 -x -r -i -Oclf:/var/log/pureftpd.log -k99 -G -Z -Y0 -4
    When I run the command manually it works

    ??

  2. #2
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: pure-ftpd won't start as a service

    On 12/2/2013 10:46 AM, tobimat80 wrote:
    >
    > Hi,
    >
    > I just upgraded from 12.3 to 13.1 (fresh install) and now my pure-ftpd
    > won't start via the init script. There is nothing in the logs, I can
    > query the status and that is what I get:
    >
    >> pure-ftpd.service - Pure-FTPd FTP server
    >> Loaded: loaded (/usr/lib/systemd/system/pure-ftpd.service; disabled)
    >> Active: inactive (dead)
    >>
    >> Dec 02 17:31:43 hawkeye systemd[1]: Starting Pure-FTPd FTP server...
    >> Dec 02 17:31:43 hawkeye systemd[1]: Started Pure-FTPd FTP server.
    >> Dec 02 17:31:43 hawkeye pure-config.pl[27071]: Running:
    >> /usr/sbin/pure-ftpd -A -c10 -B -C3 -d -z -D -E -fftp
    >> -F/usr/share/fortune/zippy -H -I15 -lpuredb:...-Z -Y0 -4
    >> Hint: Some lines were ellipsized, use -l to show in full.

    >
    > When I look at the journal there is not really more information:
    >
    >> Dec 02 17:31:43 hawkeye systemd[1]: Starting Pure-FTPd FTP server...
    >> Dec 02 17:31:43 hawkeye systemd[1]: Started Pure-FTPd FTP server.Dec 02
    >> 17:31:43 hawkeye pure-config.pl[27071]: Running: /usr/sbin/pure-ftpd -A
    >> -c10 -B -C3 -d -z -D -E -fftp -F/usr/share/fortune/zippy -H -I15
    >> -lpuredb:/etc/pure-ftpd/pureftpd.pdb -lpam -L10000:8 -m4 -p30000:30100
    >> -s -u40 -x -r -i -Oclf:/var/log/pureftpd.log -k99 -G -Z -Y0 -4

    >
    > When I run the command manually it works
    >
    > ??
    >
    >

    tobimat80;

    AS Pure-FTP starts after the machine is booted, it may be the network is not up when Pure-FTP is started. Try using
    "Traditional Method with ifup" and setting the network to start at boot ( YaST > Network Devices > Network Settings).

    If your heart is set on Network Manager, try setting the connection as a "System Connection". See:
    http://activedoc.opensuse.org/book/o...c.nm.configure

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  3. #3

    Default Re: pure-ftpd won't start as a service

    Hi,

    I am already using ifup. The problem is not only when booting - even later when I try to start the service manually (via the init-script) it doesn't come up. If I take the command from the script and execute it, it works immediately...

  4. #4

    Default Re: pure-ftpd won't start as a service

    I found the solution:

    After looking at the config file more closely I found this option:

    # Fork in background
    ## systemd users: you shall not change the value to yes unless you modify the
    ## appropriate pure-ftpd.service
    Daemonize YES
    That was the problem - without this option the service is running now I did copy the config from my non-systemd 11.4 openSUSE...

    Thx!

  5. #5

    Default Re: pure-ftpd won't start as a service

    Quote Originally Posted by tobimat80 View Post
    I found the solution:After looking at the config file more closely I found this option:That was the problem - without this option the service is running now I did copy the config from my non-systemd 11.4 openSUSE...Thx!
    The more consistent solution is to add

    Type=forking

    to the [Service] section of the /usr/lib/systemd/system/pure-ftpd.service file and then reloading the systemd configs with

    systemctl daemon-reload
    rcpure-ftpd restart

    Matthew

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: pure-ftpd won't start as a service

    When an FTP application like PureFTP is supported by YAST FTP,

    Probably the <preferred> way to do all this is to simply install YAST-FTP to install the FTP management applet in YAST.

    From that, with a few clicks you can stop/start as a service, do some basic (not too advanced) common configuration.

    Much better to do it that way because the underlying functionality will likely be consistent with openSUSE subsystems.
    So, for instance if you configure using "old" sysVinit, YMMV and <may> be deprecated at some point. If your commands and methods implement systemd commands, your system is more likely to remain functional into the future.

    TSU

  7. #7

    Default Re: pure-ftpd won't start as a service

    Quote Originally Posted by tsu2 View Post
    When an FTP application like PureFTP is supported by YAST FTP,

    Probably the <preferred> way to do all this is to simply install YAST-FTP to install the FTP management applet in YAST.
    Only it seem not to work using YAST-FTP. After setup there is no server running and when I re-enter YAST-FTP startup is reset to manual.

    To me it looks like YAST-FTPis not yet systemd compatible.

    --
    Klaus

  8. #8

    Default Re: pure-ftpd won't start as a service

    Quote Originally Posted by MatthewWild View Post
    The more consistent solution is to add

    Type=forking
    Even better (I think) edit /etc/pure-ftpd/pure-ftpd.conf and change Daemonize to NO. Actually that is suggested in the conf file

    Code:
    # Fork in background
    ## systemd users: you shall not change the value to yes unless you modify the
    ## appropriate pure-ftpd.service
    Daemonize NO

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: pure-ftpd won't start as a service

    On 2014-04-20 17:56, MrManor wrote:
    >
    > MatthewWild;2628741 Wrote:
    >> The more consistent solution is to add
    >>
    >> Type=forking

    >
    > Even better (I think) edit /etc/pure-ftpd/pure-ftpd.conf and change
    > Daemonize to NO. Actually that is suggested in the conf file
    >
    >
    > Code:
    > --------------------
    >
    > # Fork in background
    > ## systemd users: you shall not change the value to yes unless you modify the
    > ## appropriate pure-ftpd.service
    > Daemonize NO
    >
    > --------------------



    Well, it seems you found a bug in YaST, so please report in Bugzilla.

    openSUSE:Submitting bug
    reports



    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •