Well, I just wanted to change the default Windows workgroup name for my Asus Laptop running brand new opensuse 13.1 (KDE).

Changing I did, using YAST's "Windows Domain Membership" Tool. I just switched from "Workgroup" to "LAN", which is my home's default workgroup
(my NAS Server is configured this way, samba shares available on the local network).

And well, it did not work well : workgroup "WORKGROUP" machines were detected ok, but not "LAN" machines. Couldn't get a list of available shares.
Even after OS full restart.

Then I realized nmb server process was not started. So I started it (from command line).

Then I guessed nmb was not enough, so I started smb process : miracle, it worked : "LAN" workgroup and shares were detected all right !

Then i launched YAST's Service Manager to enable/activate these services at boot time.

I restarted the PC. And then, big disappointment : could not discover any samba shares at all !!! (dolphin, smbtree).

Both services (nmb, smb) were up from what command line "service *** status" could tell me. So what ???!!!



I've been thru a lot of thinking and experimenting.

And here is my conclusion : If i disable/deactivate smb from YAST Service Manager, and if then I launch smb service from command line, then it works fine !
Checking logs is clear : YAST boot-time smb start generates tons of errors (and core dumps) ; manual start from command line is all right.


So, what do i need to do to get my Samba configuration up & running fine automatically at boot time ?!
Just wasting hours here for something that should have been done only in a few seconds (this was the case in Linux Mint ...) ...


Any help welcome.


thanks/

carrouf