Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Frequent disk sleep

  1. #11

    Default Re: Frequent disk sleep

    I now tested an older kernel, no change. Tested the RAM to make sure, and it's good. So neither is the problem. I guess I should test how a clean user works in this regard.

    robin_listas, that still doesn't make much sense. Why would scrolling a webpage in firefox cause memory to be allocated, especially exactly a bit over the amount of memory that is unused? And by far it should not cause any big files to be read (firefox doesn't deal with any big files like that at all). It seems to me that there is something that eats all the memory you have as if to use for caching (no matter if you have 1 GiB or 128 GiB), until the demand is so high swapping occurs. Once that happens programs go to disk sleep and no longer try to cache anything, which in turn makes whatever program is doing that to snap out of it for a while.

    consused:
    Code:
    Label: openSUSE  uuid: d87a9c63-6f0f-4061-b4dd-3cd4c7d204f2
            Total devices 1 FS bytes used 107.97GiB
            devid    1 size 500.00GiB used 179.04GiB path /dev/sda3
    
    Btrfs v3.12+20131125
    
    Data, single: total=167.01GiB, used=104.26GiB
    System, DUP: total=8.00MiB, used=24.00KiB
    System, single: total=4.00MiB, used=0.00
    Metadata, DUP: total=6.00GiB, used=3.71GiB
    Metadata, single: total=8.00MiB, used=0.00
    /home is integral and set as a separate subvolume.
    I did a scrub and tested the disk for errors, and everything is seemingly fine.

  2. #12
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Frequent disk sleep

    Quote Originally Posted by GreatEmerald View Post
    consused:
    Code:
    Label: openSUSE  uuid: d87a9c63-6f0f-4061-b4dd-3cd4c7d204f2
            Total devices 1 FS bytes used 107.97GiB
            devid    1 size 500.00GiB used 179.04GiB path /dev/sda3
    
    Btrfs v3.12+20131125
    
    Data, single: total=167.01GiB, used=104.26GiB
    System, DUP: total=8.00MiB, used=24.00KiB
    System, single: total=4.00MiB, used=0.00
    Metadata, DUP: total=6.00GiB, used=3.71GiB
    Metadata, single: total=8.00MiB, used=0.00
    /home is integral and set as a separate subvolume.
    I did a scrub and tested the disk for errors, and everything is seemingly fine.
    Thank you for that. Wow, I'm only running a 35GB root partition for 13.1/Tumbleweed and it's allocated 28GB for the btrfs storage pool so far, of which about 18GB is actually now used for Data + Metadata, it was more, although rather small compared to yours.

    Are you still running with Snapper's defaults? They are not aggressive enough for cleaning up a desktop system. I recently halved snapper's default setting (100) snapshots retained for YaST/zypper activity and reduced (halved) the hourly snapshot retention to pull it back to 18GB used, but I kept 10 days for keeping the daily first snapshot (hourly).

    I do not keep my data in /home (integral and excluded by sub-volume from snapshots). It's on separate partition (ext4 btw). I think you might need to do something to tune down your btrfs usage as it could just be high I/O loading giving you the problems, but I have no actual experience at your size of storage used!

  3. #13

    Default Re: Frequent disk sleep

    Eh, I've been using this setup for around two openSUSE releases so far without issues, and nothing changed lately to impact that. As I mentioned, it doesn't seem to have much to do with Btrfs, but rather with the memory and swapping (swap has no relation to Btrfs, of course). As for Snapper, I have it on defaults, but it's not that bad. Quite useful for such time trips as I want to take to see what exactly broke the system like that. And btrfs itself is nice for that, since I can take a snapshot of the disk, save it on an external drive, and even if something goes horribly wrong, all my data is still intact.

  4. #14
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Frequent disk sleep

    Quote Originally Posted by GreatEmerald View Post
    Eh, I've been using this setup for around two openSUSE releases so far without issues, and nothing changed lately to impact that. As I mentioned, it doesn't seem to have much to do with Btrfs, but rather with the memory and swapping (swap has no relation to Btrfs, of course).
    I'm not sure where you mentioned about previous releases, I don't recall. I used btrfs on 12.3 and never experienced the problem either. I have on 13.1, only once but the effect on my system was extremely frustrating none the less. So far it hasn't returned.

    As for Snapper, I have it on defaults, but it's not that bad. Quite useful for such time trips as I want to take to see what exactly broke the system like that. And btrfs itself is nice for that, since I can take a snapshot of the disk, save it on an external drive, and even if something goes horribly wrong, all my data is still intact.
    Nobody said it was bad, but the defaults are not so good for average desktop users who typically run openSUSE within 15 - 20GB for root partition. There have already been complaints to the devs about Snapper defaults being too aggressive with hourly snapshots but not enough on cleanup, given openSUSE installer defaults to using it with btrfs selected on a root partition. I agree it is useful.

    Just a thought, do you host any virtual machines on your 13.1 system?

  5. #15

    Default Re: Frequent disk sleep

    Tried a clean user, and it has the same problem. It seems to trigger it less often, but the issue is definitely there. Looks like I should check out my old snapshots to see if I can bisect the problem.

    Quote Originally Posted by consused View Post
    I'm not sure where you mentioned about previous releases, I don't recall. I used btrfs on 12.3 and never experienced the problem either. I have on 13.1, only once but the effect on my system was extremely frustrating none the less. So far it hasn't returned.
    That was a reply to your "I think you might need to do something to tune down your btrfs usage as it could just be high I/O loading giving you the problems, but I have no actual experience at your size of storage used!" – nothing changed that would cause high I/O compared to 12.3 or even earlier 13.1.

    Quote Originally Posted by consused View Post
    Just a thought, do you host any virtual machines on your 13.1 system?
    Yes, but I had the same ones before that, and I rarely start them.

  6. #16

    Default Re: Frequent disk sleep

    I found the trigger for the issue: it's KWin's OpenGL rendering. With XRender, there are no issues. So this must be some issue with the graphics stack somewhere, maybe Mesa, maybe KWin itself, maybe the Intel driver (which I'm using right now, Ivy Bridge).

  7. #17
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Frequent disk sleep

    Quote Originally Posted by GreatEmerald View Post
    I found the trigger for the issue: it's KWin's OpenGL rendering. With XRender, there are no issues. So this must be some issue with the graphics stack somewhere, maybe Mesa, maybe KWin itself, maybe the Intel driver (which I'm using right now, Ivy Bridge).
    BTW, I'm also using KDE with desktop effects enabled, the intel driver (not Ivy Bridge), and 13.1's pre-release version of X server (1.14.4 RC 1). The problem still hasn't returned here.

  8. #18

    Default Re: Frequent disk sleep

    Hmm, after some more testing, it seems turning the effects to XRender only solves the particular test case I used (scrolling the screen very quickly). It still fails another test case (minimising and restoring several different windows at once).

  9. #19
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Frequent disk sleep

    Quote Originally Posted by GreatEmerald View Post
    Hmm, after some more testing, it seems turning the effects to XRender only solves the particular test case I used (scrolling the screen very quickly). It still fails another test case (minimising and restoring several different windows at once).
    All my previous comments applied to XRender (sytem default here). So, I selected openGL 3.1 and KWin immediately crashed. Clicked on restart, warning that two effects (btw both are selected by default) required openGL, so restart obviously used XRender.

    Tried openGL 2.0 with no crash, but jerky in operation with some intermittent rendering issues . Then tried openGL 3.1 again with no crash this time, but also not as smooth as Xrender in operation here.

    I couldn't reproduce results re sticking cursor etc, in any tests. However my 13.1 recently returned to Tumbleweed having installed newer 3.12.3 kernel. Will repeat tests with a reboot of retained 3.11.6 kernel later today.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •