Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Unable to Hibernate

  1. #1

    Default Unable to Hibernate

    Whenever I try to hibernate it just locks the screen.

    My /var/log/pm-suspend.log says ERROR: no resume parameter on kernel commandline, can not suspend

    How do I fix this

    Code:
    Initial commandline parameters: --quirk-vbestate-restore
    Thu Oct  7 13:05:58 CDT 2010: Running hooks for hibernate.
    /usr/lib/pm-utils/sleep.d/00logging hibernate hibernate:hibernate initiated: Thu Oct  7 13:05:58 CDT 2010
    
    Linux linux-b1wc 2.6.34.7-0.3-desktop #1 SMP PREEMPT 2010-09-20 15:27:38 +0200 x86_64 x86_64 x86_64 GNU/Linux
    kernel command line: 'root=/dev/disk/by-id/ata-TOSHIBA_MK3252GSX_X8IQT4H2T-part1 splash=silent quiet vga=0x317'
    Module                  Size  Used by
    cryptd                  9531  0 
    aes_x86_64              8104  2 
    aes_generic            27607  1 aes_x86_64
    autofs4                30185  1 
    af_packet              23229  4 
    snd_pcm_oss            53701  0 
    snd_mixer_oss          19415  1 snd_pcm_oss
    snd_seq                68137  0 
    snd_seq_device          7834  1 snd_seq
    edd                    10208  0 
    cpufreq_conservative    12628  0 
    cpufreq_userspace       3264  0 
    cpufreq_powersave       1258  0 
    acpi_cpufreq            8399  0 
    mperf                   1523  1 acpi_cpufreq
    fuse                   75897  1 
    loop                   18524  0 
    dm_mod                 86873  0 
    snd_hda_codec_atihdmi     3375  1 
    arc4                    1601  2 
    snd_hda_codec_realtek   324511  1 
    ecb                     2495  2 
    firewire_ohci          26938  0 
    firewire_core          60890  1 firewire_ohci
    crc_itu_t               1747  1 firewire_core
    snd_hda_intel          28557  8 
    snd_hda_codec         113249  3 snd_hda_codec_atihdmi,snd_hda_codec_realtek,snd_hda_intel
    iwlagn                239568  0 
    uvcvideo               68119  0 
    snd_hwdep               7922  1 snd_hda_codec
    sdhci_pci               8700  0 
    sdhci                  22806  1 sdhci_pci
    iwlcore               302209  1 iwlagn
    sr_mod                 16684  1 
    ohci1394               33702  0 
    snd_pcm               105589  5 snd_pcm_oss,snd_hda_intel,snd_hda_codec
    mac80211              290644  2 iwlagn,iwlcore
    video                  25256  0 
    cdrom                  43440  1 sr_mod
    videodev               43828  1 uvcvideo
    v4l1_compat            17249  2 uvcvideo,videodev
    snd_timer              26828  4 snd_seq,snd_pcm
    v4l2_compat_ioctl32    11193  1 videodev
    sg                     33348  0 
    ieee1394              104868  1 ohci1394
    battery                12302  0 
    mmc_core               83746  1 sdhci
    snd                    84412  22 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
    cfg80211              182851  3 iwlagn,iwlcore,mac80211
    rfkill                 21863  1 cfg80211
    ac                      4055  0 
    pcspkr                  2222  0 
    button                  6989  0 
    joydev                 11942  0 
    i2c_i801               11881  0 
    iTCO_wdt               12170  0 
    iTCO_vendor_support     3150  1 iTCO_wdt
    r8169                  44332  0 
    soundcore               9003  1 snd
    snd_page_alloc          9569  2 snd_hda_intel,snd_pcm
    ext4                  401916  2 
    jbd2                  100410  1 ext4
    crc16                   1715  1 ext4
    radeon                870885  2 
    ttm                    65938  1 radeon
    drm_kms_helper         33008  1 radeon
    intel_agp              34008  0 
    sd_mod                 41436  4 
    drm                   223234  4 radeon,ttm,drm_kms_helper
    i2c_algo_bit            6728  1 radeon
    fan                     4559  0 
    processor              45747  3 acpi_cpufreq
    ata_generic             3739  0 
    ata_piix               23945  1 
    thermal                20625  0 
    thermal_sys            18230  4 video,fan,processor,thermal
    ahci                   42680  3 
    libata                211449  3 ata_generic,ata_piix,ahci
    scsi_mod              191748  4 sr_mod,sg,sd_mod,libata
    
                 total       used       free     shared    buffers     cached
    Mem:       4057124    1625948    2431176          0      40844    1045348
    -/+ buffers/cache:     539756    3517368
    Swap:      4195324          0    4195324
    
    success.
    /usr/lib/pm-utils/sleep.d/00powersave hibernate hibernate:success.
    /usr/lib/pm-utils/sleep.d/02rtcwake hibernate hibernate:rtcwake alarm not enabled in /etc/pm/config.d/rtcwake.config, doing nothing...
    not applicable.
    /usr/lib/pm-utils/sleep.d/06autofs hibernate hibernate:Shutting down automount ..done
    success.
    /usr/lib/pm-utils/sleep.d/30s2disk-check hibernate hibernate:INFO: checking for suspend-to-disk prerequisites...
    ERROR: no resume parameter on kernel commandline, can not suspend
    WARNING: /var/run/pm-utils/pm-suspend/storage/inhibit will be created to prevent suspending!
    Returned exit code 1.
    Thu Oct  7 13:05:58 CDT 2010: Inhibit found, will not perform hibernate
    Thu Oct  7 13:05:58 CDT 2010: Running hooks for thaw
    /usr/lib/pm-utils/sleep.d/06autofs thaw hibernate:Shutting down automount ..done
    Starting automount ..done
    success.
    /usr/lib/pm-utils/sleep.d/02rtcwake thaw hibernate:not applicable.
    /usr/lib/pm-utils/sleep.d/00powersave thaw hibernate:success.
    /usr/lib/pm-utils/sleep.d/00logging thaw hibernate:success.

  2. #2
    Carlos E. R. NNTP User

    Default Re: Unable to Hibernate

    On 2010-10-07 20:36, LethalGoat wrote:
    >
    > Whenever I try to hibernate it just locks the screen.
    >
    > My /var/log/pm-suspend.log says ERROR: no resume parameter on kernel
    > commandline, can not suspend


    Paste the kernel command line.

    >
    > How do I fix this
    >
    >
    > Code:
    > --------------------
    > Initial commandline parameters: --quirk-vbestate-restore
    > Thu Oct 7 13:05:58 CDT 2010: Running hooks for hibernate.
    > /usr/lib/pm-utils/sleep.d/00logging hibernate hibernate:hibernate initiated: Thu Oct 7 13:05:58 CDT 2010
    >
    > Linux linux-b1wc 2.6.34.7-0.3-desktop #1 SMP PREEMPT 2010-09-20 15:27:38 +0200 x86_64 x86_64 x86_64 GNU/Linux
    > kernel command line: 'root=/dev/disk/by-id/ata-TOSHIBA_MK3252GSX_X8IQT4H2T-part1 splash=silent quiet vga=0x317'


    Ah, here it is. You do not have a resume parameter, hybernation to disk is impossible.
    Do you have a swap partition? You need one, of at least the memory size or a bit more.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: Unable to Hibernate

    I do have a swap partition.

  4. #4
    Carlos E. R. NNTP User

    Default Re: Unable to Hibernate

    On 2010-10-07 22:06, LethalGoat wrote:
    >
    > I do have a swap partition.
    >
    >


    Ok, check that it is active with "swapon -s". If it is not, find out why. You need an entry in fstab.

    Once that is correct, edit the /boot/grub/menu.lst file.

    Copy the kernel paragraph to a new one (new title), and add an entry similar to
    "resume=/dev/disk/by-label/b_swap". Example:


    Code:
    
    > title Desktop -- openSUSE 11.2 - 2.6.31.14-0.1
    >     root (hd0,1)
    >     kernel /vmlinuz-2.6.31.14-0.1-desktop root=/dev/disk/by-label/a_main resume=/dev/disk/by-label/b_swap splash=verbose quiet showopts vga=0x31a
    >     initrd /initrd-2.6.31.14-0.1-desktop


    Make sure this entry is the default one, reboot, and test hibernation.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5

    Default Re: Unable to Hibernate

    Thank you very much! Adding that to my grub fixed my problem.

  6. #6
    Carlos E. R. NNTP User

    Default Re: Unable to Hibernate

    On 2010-10-08 00:06, LethalGoat wrote:
    >
    > Thank you very much! Adding that to my grub fixed my problem.


    Welcome :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7

    Default Re: Unable to Hibernate

    I hope nobody minds me posting a variation of the answer to this question.
    If using grub2-efi (menu.lst does not exist), I got it to work by doing the following:

    I determined the uuid of my swap partition /dev/sda3 by running

    Code:
    blkid
    I then added

    Code:
    resume=/dev/disk/by-uuid/<omitted>
    (filling in the uuid instead of <omitted>) to the optional kernel command line parameter for grub2-efi using yast. I can see this goes into /boot/grub2-efi/grub.cfg .

    After a reboot hibernation would work. (However, eth0 would disappear, but the solution to that can be found here if you encounter it: https://forums.opensuse.org/english/...spend-ram.html)

  8. #8

    Default Re: Unable to Hibernate

    Quote Originally Posted by nsandersen View Post
    (However, eth0 would disappear...
    By that I meant eth0 would disappear after resuming from hibernation.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,895
    Blog Entries
    1

    Default Re: Unable to Hibernate

    Quote Originally Posted by nsandersen View Post
    I hope nobody minds me posting a variation of the answer to this question.
    If using grub2-efi (menu.lst does not exist), I got it to work by doing the following:

    I determined the uuid of my swap partition /dev/sda3 by running

    Code:
    blkid
    I then added

    Code:
    resume=/dev/disk/by-uuid/<omitted>
    (filling in the uuid instead of <omitted>) to the optional kernel command line parameter for grub2-efi using yast. I can see this goes into /boot/grub2-efi/grub.cfg .

    After a reboot hibernation would work. (However, eth0 would disappear, but the solution to that can be found here if you encounter it: https://forums.opensuse.org/english/...spend-ram.html)
    You should not edit grub.cfg directly. (A kernel update will overwrite for example). Instead, make your changes to /etc/default/grub, then run

    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    openSUSE 12.3: Chapter 10. The Boot Loader GRUB2

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to Hibernate

    On 2013-10-25 05:06, nsandersen wrote:
    >
    > nsandersen;2593399 Wrote:
    >> (However, eth0 would disappear...By that I meant eth0 would disappear after resuming from hibernation.


    Unrelated to the grub change.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •