Results 1 to 6 of 6

Thread: CMake Unable to find Qt4 libraries

  1. #1

    Default CMake Unable to find Qt4 libraries

    I am try to compile amarok. Following the instructions here, I get stuck when trying to run Cmake.

    Code:
    cmake .. -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`                                                               
    -- /home/mani/Downloads/clones-amarok-laitl-amarok/cmake/modules                                                                                                                    
    -- Taglib found: -L/usr/lib64 -ltag                                                                                                                                                 
    -- Could NOT find Taglib-Extras (missing:  TAGLIB-EXTRAS_INCLUDES TAGLIB-EXTRAS_LIBRARIES)                                                                                          
    CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:97 (message):                                                                                           
      Could NOT find Qt4 (missing: QT_QTWEBKIT_INCLUDE_DIR QT_QTWEBKIT_LIBRARY)                                                                                                         
      (found suitable version "4.8.4", minimum required is "4.8.3")
    Call Stack (most recent call first):
      /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:291 (_FPHSA_FAILURE_MESSAGE)
      /usr/share/cmake/Modules/FindQt4.cmake:1223 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
      CMakeLists.txt:87 (find_package)
    
    
    -- Configuring incomplete, errors occurred!
    I checked YAST and it tells me I have libtag-devel, libtag-extras1, taglib, taglibsharp, libWTWebKit4, and libWTWebKit4-32bit installed with the latest versions.
    It seems that Cmake is having trouble locating the libraries. Is there anyway to direct CMake to these libraries?

    I am running 12.3 64bit.

    Thanks

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: CMake Unable to find Qt4 libraries

    You'll need the development files for the packages, packagename-devel. Any particular reason for building amarok from source? It's installed by default in KDE, and is in the official repository.

  3. #3

    Default Re: CMake Unable to find Qt4 libraries

    Thanks for the reply. I need to compile, because I am trying to install an amarok test build which includes better mtp support.

    I installed the libqtwebkit-devel and taglib-extras-devel and it does not give me any missing library errors. However I get this CMake error now.

    Code:
    cmake .. -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
    -- /home/mani/Downloads/clones-amarok-laitl-amarok/cmake/modules
    -- Taglib found: -L/usr/lib64 -ltag
    -- Taglib-Extras found: -L/usr/lib64 -ltag-extras
    CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:98 (message):
      ERROR: cmake/modules/FindKDE4Internal.cmake not found in
      /root/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
    Call Stack (most recent call first):
      CMakeLists.txt:88 (find_package)
    
    
    -- Configuring incomplete, errors occurred!
    Not quite sure what this means.

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: CMake Unable to find Qt4 libraries

    FindKDE4Internal.cmake is in the libkde4-devel package. Do you have this installed?

  5. #5

    Default Re: CMake Unable to find Qt4 libraries

    Quote Originally Posted by chief_sealth View Post
    FindKDE4Internal.cmake is in the libkde4-devel package. Do you have this installed?
    Run this and you should get all things installed that are needed to build Amarok:
    Code:
    sudo zypper si -d amarok

  6. #6
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: CMake Unable to find Qt4 libraries

    Quote Originally Posted by wolfi323 View Post
    Run this and you should get all things installed that are needed to build Amarok:
    Code:
    sudo zypper si -d amarok
    Sweet. I'm making a note of that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •