Results 1 to 8 of 8

Thread: GRUB Startup Options With v. 13.1

  1. #1

    Default GRUB Startup Options With v. 13.1

    I just upgraded my desktop PC from v. 12.3 to v. 13.1 (64-bit).
    The upgrade was done via the DVD method by selecting to upgrade an existing version.

    Everything seems to have gone very well, except for a minor problem: When booting up GRUB presents the following choice:
    Desktop -- openSUSE 12.3 - 3.7.10-1.16

    How do I get GRUB to let me boot up v. 13.1 (and whatever kernel comes with it!) instead?

    I thought that by executing
    Code:
    update-grub
    (as Root) I would solve this little problem but the OS informs me that it does not recognize the command...

  2. #2

    Default Re: GRUB Startup Options With v. 13.1

    Quote Originally Posted by tb75252 View Post
    I just upgraded my desktop PC from v. 12.3 to v. 13.1 (64-bit).
    The upgrade was done via the DVD method by selecting to upgrade an existing version.

    Everything seems to have gone very well, except for a minor problem: When booting up GRUB presents the following choice:
    Desktop -- openSUSE 12.3 - 3.7.10-1.16

    How do I get GRUB to let me boot up v. 13.1 (and whatever kernel comes with it!) instead?
    Are you using grub2?
    There's a known "problem" that the "Distributor" string will not get changed on upgrade, because it is user editable.
    Enter YaST->System->Boot Loader->Boot Loader Options and change it to what you like.

    Then the kernel. Since a while now, multiversion is enabled by default for kernel packages. It is configured to keep at least 2 kernels. Since you upgraded from 12.3 and there's only 1 kernel yet for 13.1 (there has been no kernel update yet), and the latest 12.3 kernel is still installed therefore.
    You should have an entry with kernel 3.11.6 as well in the menu, just boot that. (maybe have a look in "Advanced Options")
    If you want to, you can of course uninstall the old kernel in YaST->Software Management f.e. Just select the kernel package and click on "Versions" in the bottom-right area to uninstall just the old version.

    I thought that by executing
    Code:
    update-grub
    (as Root) I would solve this little problem but the OS informs me that it does not recognize the command...
    For grub2 the command is called grub2-mkconfig. But this called automatically by YaST.

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: GRUB Startup Options With v. 13.1

    Quote Originally Posted by tb75252 View Post
    I just upgraded my desktop PC from v. 12.3 to v. 13.1 (64-bit).
    The upgrade was done via the DVD method by selecting to upgrade an existing version.

    Everything seems to have gone very well, except for a minor problem: When booting up GRUB presents the following choice:
    Desktop -- openSUSE 12.3 - 3.7.10-1.16

    How do I get GRUB to let me boot up v. 13.1 (and whatever kernel comes with it!) instead?

    I thought that by executing
    Code:
    update-grub
    (as Root) I would solve this little problem but the OS informs me that it does not recognize the command...
    You can change the name by selecting:

    YaST / System / Boot Loader / Boot Loader Options / Distributer

    I also have a nice Grub 2 bash script you can find here: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: GRUB Startup Options With v. 13.1

    Thank you wolfi323 and jdmcdaniel3. It turns out that I had GRUB instead of GRUB2 installed. I switched to GRUB2 and my problem seems to be solved.
    I'll be now creating a new post for another problem...

  5. #5

    Default Re: GRUB Startup Options With v. 13.1

    Quote Originally Posted by tb75252 View Post
    Thank you wolfi323 and jdmcdaniel3. It turns out that I had GRUB instead of GRUB2 installed. I switched to GRUB2 and my problem seems to be solved.
    Well, you can of course still use grub legacy on openSUSE.
    It should work as well. If you change to GRUB in YaST->Boot Loader, its menu should get automatically updated when necessary.
    But it will show _all_ installed kernels, so the menu can get a bit crowded. You can of course edit it manually: /boot/grub/menu.cfg or also in YaST->Boot Loader.

    And in openSUSE the command to update the boot loader is "update-bootloader" (applies to all supported boot loaders) or "grub-install" (specific to grub legacy). There is no "update-grub".

  6. #6
    Join Date
    Jun 2009
    Location
    Florida, USA
    Posts
    236

    Default Re: GRUB Startup Options With v. 13.1

    tb75252 wrote:

    >
    > I just upgraded my desktop PC from v. 12.3 to v. 13.1 (64-bit).
    > The upgrade was done via the DVD method by selecting to upgrade an
    > existing version.
    >
    > Everything seems to have gone very well, except for a minor problem:
    > When booting up GRUB presents the following choice:
    > DESKTOP -- OPENSUSE 12.3 - 3.7.10-1.16
    > How do I get GRUB to let me boot up v. 13.1 (and whatever kernel comes
    > with it!) instead?
    >
    > I thought that by executing
    > Code:
    > --------------------
    > update-grub
    > --------------------
    > (as Root) I would solve this little problem but the OS informs me that
    > it does not recognize the command...
    >
    >


    I had the same problem after updating 12.3->13.1 (DVD image on USB).
    Looking at the log, I saw there was an error during the installation of the
    new kernel (plymouth related). 13.1 booted OK with the old kernel.

    Afterwards I re-installed the 3.11.6 kernel (with YaST) and the grub menu
    was updated.


  7. #7

    Default Re: GRUB Startup Options With v. 13.1

    Quote Originally Posted by GeoBaltz View Post
    tb75252 wrote:

    >
    > I just upgraded my desktop PC from v. 12.3 to v. 13.1 (64-bit).
    > The upgrade was done via the DVD method by selecting to upgrade an
    > existing version.
    >
    > Everything seems to have gone very well, except for a minor problem:
    > When booting up GRUB presents the following choice:
    > DESKTOP -- OPENSUSE 12.3 - 3.7.10-1.16
    > How do I get GRUB to let me boot up v. 13.1 (and whatever kernel comes
    > with it!) instead?
    >
    > I thought that by executing
    > Code:
    > --------------------
    > update-grub
    > --------------------
    > (as Root) I would solve this little problem but the OS informs me that
    > it does not recognize the command...
    >
    >


    I had the same problem after updating 12.3->13.1 (DVD image on USB).
    Looking at the log, I saw there was an error during the installation of the
    new kernel (plymouth related). 13.1 booted OK with the old kernel.

    Afterwards I re-installed the 3.11.6 kernel (with YaST) and the grub menu
    was updated.
    The kernel that you re-installed is called "kernel-desktop"? Is that the only kernel-related package that you reinstalled?

  8. #8
    Join Date
    Jun 2009
    Location
    Florida, USA
    Posts
    236

    Default Re: GRUB Startup Options With v. 13.1

    tb75252 wrote:

    > The kernel that you re-installed is called "kernel-desktop"? Is that
    > the only kernel-related package that you reinstalled?
    >
    >


    Yes. After that finishes, reboot. If all goes well, you can remove the
    old(3.7.10) kernel (or not).


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •