Results 1 to 10 of 10

Thread: How to stop HPLIP printer driver from loading at startup

  1. #1
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default How to stop HPLIP printer driver from loading at startup

    Hello,
    Since my upgrade from 12.3 to 13.1 I have an HP printer setup/monitor that starts and sits in the system tray.
    How do I totally disable this from starting up?
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  2. #2

    Default Re: How to stop HPLIP printer driver from loading at startup

    Quote Originally Posted by anika200 View Post
    Hello,
    Since my upgrade from 12.3 to 13.1 I have an HP printer setup/monitor that starts and sits in the system tray.
    How do I totally disable this from starting up?
    Uninstall the package "hplip".

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: How to stop HPLIP printer driver from loading at startup

    Quote Originally Posted by anika200 View Post
    Hello,
    Since my upgrade from 12.3 to 13.1 I have an HP printer setup/monitor that starts and sits in the system tray.
    How do I totally disable this from starting up?
    do you mean the blue / white hp printer icon in systray?

    Couple of options (if KDE)

    menu > applications > system > configuration > HP Device Manager > configure preferences > system tray > Always Hide

    or as I have it set up "hide when inactive"

    or if you don't have an hp printer then uninstall hplip as suggested by wolfi323

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How to stop HPLIP printer driver from loading at startup

    Quote Originally Posted by anika200 View Post
    Hello,
    Since my upgrade from 12.3 to 13.1 I have an HP printer setup/monitor that starts and sits in the system tray.
    How do I totally disable this from starting up?
    Do you still have an HP printer? If not, you could uninstall hplip or just remove all HP printers. Any System Tray icon can be set to be hidden if you have an HP printer, but you just don't want to see this icon.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: How to stop HPLIP printer driver from loading at startup

    Quote Originally Posted by farcusnz View Post
    do you mean the blue / white hp printer icon in systray?

    Couple of options (if KDE)

    menu > applications > system > configuration > HP Device Manager > configure preferences > system tray > Always Hide

    or as I have it set up "hide when inactive"

    or if you don't have an hp printer then uninstall hplip as suggested by wolfi323

    Do one of these. (Works in Gnome, as well. Lives in the message tray.). Only remove the package if you aren't using an HP printer. It's nice to have the HP gizmo around on occasion. I set it to "hide when inactive" so it's only visible when I print something.

  6. #6
    Join Date
    Jun 2008
    Location
    Rural Australia
    Posts
    289

    Default Re: How to stop HPLIP printer driver from loading at startup

    Wonder IF uninstall ALL printer and the HP Printer related software, might doing this prevent users from printing to ps and PDF ?

    User ability to print to ps or PDF have found to be very useful :-)

  7. #7

    Default Re: How to stop HPLIP printer driver from loading at startup

    Quote Originally Posted by paulparker View Post
    Wonder IF uninstall ALL printer and the HP Printer related software, might doing this prevent users from printing to ps and PDF ?

    User ability to print to ps or PDF have found to be very useful :-)
    Depends on what you mean with "ALL printer and the HP Printer related software".

    If you uninstall cups f.e., no user will of course be able to print anything anymore.

    But as I said, just uninstall hplip and that icon will not be there anymore. If you don't have any HP printer you have no use for it anyway. (although you should be able to use HP printers even without it, since the drivers are in a different package)

  8. #8
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: How to stop HPLIP printer driver from loading at startup

    Just remove hplip using YaST or Zypper and the hp printer programs should all go away. Keep in mind that if you manually downloaded them outside of the package manager you will have to remove it from there too. I am not familiar with how the install works for the manual download but if it uses make then you should be able to
    Code:
    make uninstall
    for the removal of the programs.

    See http://www.linuxquestions.org/questi...-howto-230225/

  9. #9

    Default Re: How to stop HPLIP printer driver from loading at startup

    In /etc/xdg/autostart are files that configure programs for start up. In our case we are looking for hplip-systray.desktop. You can delete that file or change the line
    Code:
    Exec=hp-systray -x
    by this one that disables the command
    Code:
    Exec=echo hp-systray -x
    Quote Originally Posted by anika200 View Post
    Hello,
    Since my upgrade from 12.3 to 13.1 I have an HP printer setup/monitor that starts and sits in the system tray.
    How do I totally disable this from starting up?

  10. #10

    Default Re: How to stop HPLIP printer driver from loading at startup

    Quote Originally Posted by jepbonet View Post
    In /etc/xdg/autostart are files that configure programs for start up. In our case we are looking for hplip-systray.desktop. You can delete that file or change the line
    Code:
    Exec=hp-systray -x
    by this one that disables the command
    Code:
    Exec=echo hp-systray -x
    Just a note, though:
    If you change that file directly, your changes will get lost whenever there is an update to hplip.
    So better copy it to ~/.config/autostart/ and edit it there (you won't even need root rights for this then ).
    .desktop files in ~/.config/autostart/ override the ones from /etc/xdg/autostart/ (and /usr/share/autostart/).

    And I wouldn't change the Exec line like that as this prints the string "hp-systray -x" into the log file on each log in.
    You could add the following line instead to disable it:
    Code:
    Hidden=true
    From http://standards.freedesktop.org/aut...ec-latest.html :
    Hidden Key


    When the .desktop file has the Hidden key set to true, the .desktop file MUST be ignored. When multiple .desktop files with the same name exists in multiple directories then only the Hidden key in the most important .desktop file must be considered: If it is set to true all .desktop files with the same name in the other directories MUST be ignored as well.




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •