Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: no sound with skype

  1. #1

    Default no sound with skype

    On my laptop I had always skype and it worked without problems. After the upgrade (13.1 i586 KDE) I had first a constant humming sound (only in skype). All other multimedia is working - sound and video. First I upgraded from version 4.0 to 4.2 but the sound was still there. For a start I turned the sound for skype in KDE Mixer (tab Playback Streams) down. After some searching I changed in /home/uli/.local/share/applications/skype.destop the Exec=skype
    to
    Exec=env PULSE_LATENCY_MSEC=60 skype %U
    as in the forum on skype here. The effect was that the sound went completely. Even after I changed it back the sound for skype was gone. In KDE Mixer it is on full power but there is no sound for skype. In Yast there is a test sound and the sound is working in MM applications. The skype options only tell me to use the desktop manager to set the volume on pulse audio. I don't find any other setting in KDE Mixer, Yast or Multimedia -> Volume control.
    lspci -vv shows: [CODE]
    [00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    Subsystem: Gateway, Inc. Device 016d
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 45
    Region 0: Memory at 96700000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel/CODE]
    How can I get skype working again?
    Thanks
    Uli

  2. #2

    Default Re: no sound with skype

    Now after a reboot it suddenly all works again with the change in skype.destop to Exec=env PULSE_LATENCY_MSEC=60 skype %U without white noise or any other background noise. I don't know why - just a reboot but I rebooted before I wrote the first part. Hopefully it will still work after the next reboot.
    Thanks

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: no sound with skype

    fuerstu wrote:
    >
    > Now after a reboot it suddenly all works again with the change in
    > skype.destop to Exec=env PULSE_LATENCY_MSEC=60 skype %U without white
    > noise or any other background noise. I don't know why - just a reboot
    > but I rebooted before I wrote the first part. Hopefully it will still
    > work after the next reboot.
    > Thanks
    >
    >

    I think the pulse server got restarted and hence it is working.
    I have noticed hat sometimes pulse just dies and restarting machine will
    bring sound back. I should probably search for pulse.service or
    something so that i can restart it from terminal/konsole

    --
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop

  4. #4

    Default Re: no sound with skype

    Yesterday it worked - I started up the computer this morning and again skype has no sound at all. Interesting - from Yast - Sound Sonfiguration I click bottom right PulseAudio Configuration and the dialogue box comes up with "Enable PulseAudio Support. I click OK but nothing happens. If I try again - same thing. How do I turn on PulseAudio? Where do I set Volume for PulseAudio?
    I presume that the other sound (E.g. Amarok, VLC etc.) does not use PulseAudio since there the sound is working? As I wrote before everything worked without problems before I upgraded.
    Cheers
    uli

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: no sound with skype

    I have found that Skype seldom connects to the sound system by itself. When Skype starts try going to Options and sound devices and test sound. For me that connects the system and I'll have sound until next Skype start. Note a very few times Skype connected as it should have no idea why.

  6. #6

    Default Re: no sound with skype

    Maybe you hit this bug?
    https://bugzilla.novell.com/show_bug.cgi?id=852015

    In short:
    If you run programs as root through xdg-su (e.g. YaST) the directory /run/user/1000/pulse will be owned by root, causing user applications using pulseaudio to not give any sound anymore.

    You can check with:
    Code:
    ls -ld /run/user/1000/pulse
    If it is owned by root, change it back and sound should work again:
    Code:
    sudo chown $USER: /run/user/1000/pulse

  7. #7

    Default Re: no sound with skype

    Thanks, wolfi323, but that does not seem to be the problem
    Code:
    ls -ld /run/user/1000/pulse
    drwx------ 2 uli users 80 Nov 30 12:36 /run/user/1000/pulse
    At the moment sound is working again - don't know why and what is happening here. But I certainly won't upgrade the other computers before that is sorted. In the /etc/sysconfig I have for PULSEAUDIO_ENABLE=yes and PULSEAUDIO_SYSTEM=no, is that correct?
    Cheers
    Uli

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: no sound with skype

    You should not have both is perhaps one remarked out?

  9. #9

    Default Re: no sound with skype

    Quote Originally Posted by fuerstu View Post
    Thanks, wolfi323, but that does not seem to be the problem
    Code:
    ls -ld /run/user/1000/pulse
    drwx------ 2 uli users 80 Nov 30 12:36 /run/user/1000/pulse
    At the moment sound is working again - don't know why and what is happening here.
    Well, /run is a tmpfs, so its content is lost when you reboot. So that problem fixes itself by a reboot.

    Check again when the sound is _not_ working the next time.

    In the /etc/sysconfig I have for PULSEAUDIO_ENABLE=yes and PULSEAUDIO_SYSTEM=no, is that correct?
    Yes.
    "PULSEAUDIO_SYSTEM" means whether pulseaudio should run as system daemon.
    If set to "no" it runs as user, that's the standard.

  10. #10

    Default Re: no sound with skype

    Thanks everyone. This morning the sound is again not working and the output of the command ls -ld /run/user/1000/pulse is the same as yesterday.
    So the bug listed previously doesn't seem to be the problem. Something else I have noticed today.
    Amarok is still working, however when I go to Yast - Sound - Volume setting the test sound is not working even all sliders are at maximum. Same if I don't go to volume settings and just click test sound (all from the drop down under Other at bottom right) I hear no sound. So it seems I have 2 sound systems - PulseAudio which is used for Skype and another which drives Amarok. Now I don't need PulsAudio if another sound is working properly. I have asked previously how I can turn on PulseAudio but didn't get any reply. Now - can I turn it off and run everything else with the working sound?
    Cheers
    Uli

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •