Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: The system goes up without my password

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    590

    Default The system goes up without my password

    I am using OpenSuse 12.3 and KDE

    In "System Settings", I Keep unchecked the option "enable authentication without password"

    But in the login screen, if I type enter, without my password (blank), the system goes up.

    Thus anyone comes into my pc.

    What should I do to prevent this?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,720

    Default Re: The system goes up without my password

    To me it looks as if you have no password for that user. Didn'you provide one at installation?

    Try from a terminal (as the user involved):
    Code:
    passwd
    It will first ask you for the old password, because it seems to be empty hit the return key. Then it will ask you twice for your new password. That should give you a password.
    Henk van Velden

  3. #3

    Default : The system goes up without my password

    Have a look at this setting in /etc/sysconfig/displaymanager:
    Code:
    ## Type:        yesno
    ## Default:     no
    #
    # Allow all users to login without password, but ask for the user, if
    # DISPLAYMANAGER_AUTOLOGIN is empty.
    #
    DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"

  4. #4
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    590

    Default Re: The system goes up without my password

    Quote Originally Posted by hcvv View Post
    To me it looks as if you have no password for that user. Didn'you provide one at installation?

    Try from a terminal (as the user involved):
    Code:
    passwd
    It will first ask you for the old password, because it seems to be empty hit the return key. Then it will ask you twice for your new password. That should give you a password.
    My password is not empty, look below (## my translation)
    First time, I just pressed enter
    Second time I typed my password
    sergio@linux-l78t:~> passwd
    Mudando senha para sergio. ## Changing password for sergio
    Senha UNIX (atual): ##UNIX password (current):
    passwd : Falha de autenticação ## Authentication failed
    passwd: senha inalterada ##password unchanged
    sergio@linux-l78t:~> passwd
    Mudando senha para sergio. ##Changing password for sergio.
    Senha UNIX (atual): ##UNIX password (current):
    Nova senha: ## New password:
    UNIX password (current):

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,720

    Default Re: The system goes up without my password

    Ok, so sergio has a pssword and you know it. Then my asumption was wrong.

    Did you check what wolfi 323 suggested?
    Henk van Velden

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: The system goes up without my password

    On 2013-11-29 12:46, sergelli wrote:
    > My password is not empty, look below (## my translation)


    Just a comment. When the system language is not English, you should do,
    in order to post here, like this:

    Code:
    minas-tirith:~ # LANG=en_US.UTF-8 zypper info kvm
    Loading repository data...
    Warning: Repository 'openSUSE-11.4-Update' appears to outdated. Consider
    using a different mirror or server.
    Reading installed packages...

    or this:

    Code:
    minas-tirith:~ # LANG=C zypper info kvm
    Loading repository data...
    Warning: Repository 'openSUSE-11.4-Update' appears to outdated. Consider
    using a different mirror or server.
    Reading installed packages...
    ^C

    That way we can all read it, regardless of local languages of sender and
    reader. It is not a permanent change, it only applies to one command.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    590

    Default Re: : The system goes up without my password

    Quote Originally Posted by wolfi323 View Post
    Have a look at this setting in /etc/sysconfig/displaymanager:
    Code:
    ## Type:        yesno
    ## Default:     no
    #
    # Allow all users to login without password, but ask for the user, if
    # DISPLAYMANAGER_AUTOLOGIN is empty.
    #
    DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"
    Thank you very much, Wolf323.

    I followed your advice and now the system only goes up if you use the correct password.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,720

    Default Re: : The system goes up without my password

    Quote Originally Posted by sergelli View Post
    Thank you very much, Wolf323.

    I followed your advice and now the system only goes up if you use the correct password.
    Nice it works. But your system was already up. This is only about the login. Try to understand the difference.
    Henk van Velden

  9. #9
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    590

    Default Re: : The system goes up without my password

    Quote Originally Posted by hcvv View Post
    Nice it works. But your system was already up. This is only about the login. Try to understand the difference.
    You mean that if I get the login window, then the system is already up?

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: The system goes up without my password

    On 2013-11-29 16:16, sergelli wrote:
    >
    > hcvv;2603469 Wrote:
    >> Nice it works. But your system was already up. This is only about the
    >> login. Try to understand the difference.

    >
    > You mean that if I get the login window, then the system is already up?


    Of course.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •