Results 1 to 3 of 3

Thread: KDE - How to set the Phonon for permanent Headphones?

  1. #1

    Default KDE - How to set the Phonon for permanent Headphones?

    Right click on the volume control -> Audio Setup -> Audio Hardware Setup Tab -> Device Configuration -> Connector -> Headphones

    http://userbase.kde.org/images.userbase/0/0e/Phonon-Audio-Hardware.png

    Phonon/Handbook - KDE UserBase Wiki

    "The connector should default to speakers and automatically change to headphones if it is plugged in. However, you may adjust it to play through the speakers with headphones plugged in. ".


    In OpenSUSE 12.2 when set to Headphones -> Headphones permanent. Even without the P2 connector plugged. Even restarting the system.

    In OpenSUSE 12.3 and 13.1 when set to Headphones -> configuration remains yet to take out headphone plug. Then go to Speakers configuration.

    How to disable this "hotplug" the P2 connector on OpenSUSE 13.1 to make it permanent in Headphones?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE - How to set the Phonon for permanent Headphones?

    Quote Originally Posted by noisegroundbr View Post
    Right click on the volume control -> Audio Setup -> Audio Hardware Setup Tab -> Device Configuration -> Connector -> Headphones

    http://userbase.kde.org/images.userbase/0/0e/Phonon-Audio-Hardware.png

    Phonon/Handbook - KDE UserBase Wiki

    "The connector should default to speakers and automatically change to headphones if it is plugged in. However, you may adjust it to play through the speakers with headphones plugged in. ".


    In OpenSUSE 12.2 when set to Headphones -> Headphones permanent. Even without the P2 connector plugged. Even restarting the system.

    In OpenSUSE 12.3 and 13.1 when set to Headphones -> configuration remains yet to take out headphone plug. Then go to Speakers configuration.

    How to disable this "hotplug" the P2 connector on OpenSUSE 13.1 to make it permanent in Headphones?
    I guess I thought if you select headphones, it would just stick? This is menu / Configure Desktop / Multimedia / Audio - Video Settings / Audio Hardware Setup...

    See here on my Laptop:



    I have a blog on the subject here: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: KDE - How to set the Phonon for permanent Headphones?

    jdmcdaniel3

    This is menu / Configure Desktop / Multimedia / Audio - Video Settings / Audio Hardware Setup

    equal

    Right click on the volume control -> Audio Setup -> Audio Hardware Setup Tab -> Device Configuration -> Connector -> Headphones


    Unfortunately the problem is not solved this way. Configuration of pavucontrol also not solved.


    Searching the web I found a clue for a not very elegant solution. But solved.


    I edited the file (as root): /etc/pulse/default.pa

    I commented the line (#):

    # load-module module-switch-on-port-available

    I saved the file and then killed pulseaudio (normal user):

    pulseaudio -k

    After restarted pulseaudio (normal user):

    pulseaudio -D


    PulseAudio

    2.0

    Jack detection

    With PulseAudio 1.0, we added infrastructure to loosely support the concept of "ports", which are meant to be mapped to actual supported audio paths (read: physical outputs like your speaker or 3.5mm jack). These needed to be dealt with manually, and thus were not too interesting to users. With PulseAudio 2.0 and a recent Linux kernel (3.3.0 or higher), we now automatically detect whether a jack is plugged in to your device or not, and act accordingly. Currently, this buys us the ability to manage volumes for different outputs separately, and future work will allow more advanced features like easing the set up of multichannel output, etc.



    Thank you for your attention.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •