Results 1 to 2 of 2

Thread: OpenSUSE 13.1 - Firefox does not enable WebGL with nouveau

  1. #1

    Default OpenSUSE 13.1 - Firefox does not enable WebGL with nouveau

    Hi,

    I'm using the nouveau video driver with Firefox. According to https://wiki.mozilla.org/Blocklistin...Drivers#On_X11 , WebGL should be enabled by default, since the Mesa version is above 8.0:

    $ rpm -q Mesa
    Mesa-9.2.2-61.6.1.x86_64

    However, I need to force-enable ( webgl.force-enabled=true ), which is annoying and I think there's a glitch somewhere. Once enabled, WebGL applications work fine:



    Any idea why I need to force webgl to be enabled?

    Thanks,

    Robert

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: OpenSUSE 13.1 - Firefox does not enable WebGL with nouveau

    Quote Originally Posted by robert_munteanu View Post
    Hi,

    I'm using the nouveau video driver with Firefox. According to https://wiki.mozilla.org/Blocklistin...Drivers#On_X11 , WebGL should be enabled by default, since the Mesa version is above 8.0:

    $ rpm -q Mesa
    Mesa-9.2.2-61.6.1.x86_64

    However, I need to force-enable ( webgl.force-enabled=true ), which is annoying and I think there's a glitch somewhere. Once enabled, WebGL applications work fine:



    Any idea why I need to force webgl to be enabled?

    Thanks,

    Robert
    This comes up working for me. Where are you placing this "webgl.force-enabled=true" string? What version of openSUSE do you use? Have you enabled your Multimedia Codecs for your openSUSE version?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •