Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

  1. #1

    Default openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    I have installed codec with 1 click install and having problem with VLC/video to play AVI and MP4 files containing codecs h264 mpga mp4v mp4a:


    No suitable decoder module:
    VLC does not support the audio or video format "mp4v". Unfortunately there is no way for you to fix this.
    No suitable decoder module:
    VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.


    No suitable decoder module:
    VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.
    No suitable decoder module:
    VLC does not support the audio or video format "mp4a". Unfortunately there is no way for you to fix this.


    please help me to solve this issue. how to install suitable required codec to play this file?

    thanks in advance

  2. #2

    Default AW: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    Install the package "vlc-codecs".
    Either with YaST->Software Management, or:
    Code:
    sudo zypper in vlc-codecs

  3. #3

    Default Re: AW: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    Quote Originally Posted by wolfi323 View Post
    Install the package "vlc-codecs".
    Either with YaST->Software Management, or:
    Code:
    sudo zypper in vlc-codecs

    its not working...

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: AW: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    Quote Originally Posted by poision_heart View Post
    its not working...
    Did you follow exactly the guide for installing multimedia in the HowTO forum? It will take you to here: https://forums.opensuse.org/blogs/ca...ion-guide-149/

  5. #5

    Default Re: AW: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    Quote Originally Posted by poision_heart View Post
    its not working...
    _What_ is not working?

    VLC or that zypper command?

    Do you have the Packman repo added to your system? (should be, if you used the 1-click multimedia install)

    Maybe you have an incompatible mixture of vlc packages?
    Code:
    rpm -qa | grep vlc

  6. #6
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    poision heart wrote:
    >
    > I have installed codec with 1 click install and having problem with
    > VLC/video to play AVI and MP4 files containing codecs h264 mpga mp4v
    > mp4a:
    >
    >
    > No suitable decoder module:
    > VLC does not support the audio or video format "mp4v". Unfortunately
    > there is no way for you to fix this.
    > No suitable decoder module:
    > VLC does not support the audio or video format "mpga". Unfortunately
    > there is no way for you to fix this.
    >
    >
    > No suitable decoder module:
    > VLC does not support the audio or video format "h264". Unfortunately
    > there is no way for you to fix this.
    > No suitable decoder module:
    > VLC does not support the audio or video format "mp4a". Unfortunately
    > there is no way for you to fix this.
    >
    >
    > please help me to solve this issue. how to install suitable required
    > codec to play this file?
    >
    > thanks in advance
    >
    >

    Do go through
    http://forums.opensuse.org/blogs/caf...ion-guide-149/

    --
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop

  7. #7

    Default Re: AW: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    Quote Originally Posted by wolfi323 View Post
    _What_ is not working?

    VLC or that zypper command?

    Do you have the Packman repo added to your system? (should be, if you used the 1-click multimedia install)

    Maybe you have an incompatible mixture of vlc packages?
    Code:
    rpm -qa | grep vlc

    I have installed codec and VLC from 1-click install. when now i tried this zypper command it says " nothing to do here"

  8. #8

    Default Re: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    Quote Originally Posted by poision_heart View Post
    I have installed codec and VLC from 1-click install. when now i tried this zypper command it says " nothing to do here"
    Then try:
    Code:
    sudo zypper in -f vlc-codecs
    This will force the installation.

    And please post the output of that rpm command I gave you.

  9. #9

    Default Re: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    @wolfi323 @consused thanks alot guys its working now...

  10. #10

    Angry Re: openSUSE 13.1(GNOME) codec problem mp4v mpga h264 mp4a

    I have the same problem. I've tried the one click install and I've tried the command-line suggestions on this page, to no avail. VLC says there's nothing to do it doesn't have the codecs. Totem tries to install gstreamer codecs but install is aborted because it misses dependencies.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •