Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: xneur crash Gimp ??

  1. #1

    Question xneur crash Gimp ??

    Strange bug ...
    xneur crash Gimp?
    OpenSuse 13.1, Fedora 19. Result is the same.


    Code:
    aleksej@linux-jgnw:~> gimp
    
    (gimp:31610): Pango-CRITICAL **: pango_layout_move_cursor_visually: assertion 'old_index >= 0 && old_index <= layout->length' failed
    
    (script-fu:31653): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
    Ошибка сегментирования





    Ideas ?

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: xneur crash Gimp ??

    aleksejsmir wrote:
    >
    > Strange bug ...
    > xneur crash Gimp?
    > OpenSuse 13.1, Fedora 19. Result is the same.
    >
    >
    >
    > Code:
    > --------------------
    > aleksej@linux-jgnw:~> gimp
    >
    > (gimp:31610): Pango-CRITICAL **: pango_layout_move_cursor_visually: assertion 'old_index >= 0 && old_index <= layout->length' failed
    >
    > (script-fu:31653): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
    > Ошибка сегментирования
    >
    >
    > --------------------
    >
    >
    >
    >
    >
    > http://youtu.be/Vb8ysUsNsks
    >
    >
    > Ideas ?
    >
    >

    GIMP 2.8.6 doesn't crash on my machine

    --
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop

  3. #3

    Default Re: xneur crash Gimp ??

    Quote Originally Posted by vazhavandan View Post
    GIMP 2.8.6 doesn't crash on my machine
    It is good argument.

  4. #4
    Join Date
    Oct 2012
    Location
    Norway
    Posts
    8

    Default Re: xneur crash Gimp ??

    As soon as I try to select the text tool of Gimp 2.8.6 or 2.8.10 (openSUSE 13.1 on a 3TB) it crashes without warning. This may not be relevant to this thread, however, the error message it leaves behind when I start Gimp from Konsole, is partly the same:

    gimp: symbol lookup error: /usr/lib64/libcairo.so.2: undefined symbol: pixman_glyph_cache_create
    (script-fu:7169): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error

    The Windows version of Gimp 2.8.10, under Wine or Windows 8.1, apparently runs without a hitch.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,580

    Default Re: xneur crash Gimp ??

    Check the version of ths lib

    libcairo.so.2


    Se if there is a newer one

  6. #6
    Join Date
    Oct 2012
    Location
    Norway
    Posts
    8

    Default Re: xneur crash Gimp ??

    Quote Originally Posted by gogalthorp View Post
    Check the version of ths lib

    libcairo.so.2


    Se if there is a newer one
    I can't find any newer version than the one supplied with the openSUSE-13.1-Oss repo.
    Maybe there is a newer one that I can't find ...

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,582
    Blog Entries
    14

    Default Re: xneur crash Gimp ??

    Wondering: how did you install? Clean install, upgrade of??? ?
    Tested on three machines, 2 clean install, 1 upgrade from 12.3, I don't see the error messages, so it looks like something's wrong in your install.

    Please post output of command below
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Oct 2012
    Location
    Norway
    Posts
    8

    Default Re: xneur crash Gimp ??

    Quote Originally Posted by Knurpht View Post
    Wondering: how did you install? Clean install, upgrade of??? ?
    Tested on three machines, 2 clean install, 1 upgrade from 12.3, I don't see the error messages, so it looks like something's wrong in your install.

    Please post output of command below
    Code:
    zypper lr -d
    I did a clean install of openSUSE 13.1 on my computer (i7, Asus P8Z77-V LX, Nvidia 9600GT, 3TB hd), repeated installs giving the same result. However, when installing oS 13.1 on a smaller hd (500GB) Gimp did not produce this error.

    My previous OS was openSUSE 12.3, where Gimp did not expose this problematic behaviour. After a few erratic upgrades I prefer making a clean install. Keeping a few essential files limits the time and labour it takes to set up a new version of openSUSE.

    Repos:
    Code:
    #  | Alias                                | Navn                                                | aktivert | Oppdater | Prioritet | Type   | URI                                                                                 | Tjeneste
    ---+--------------------------------------+-----------------------------------------------------+----------+----------+-----------+--------+-------------------------------------------------------------------------------------+---------
     1 | Subpixel                             | Subpixel                                            | Ja       | Ja       |   99      | rpm-md | http://repos.opensuse-community.org/subpixel/Factory/                               |         
     2 | download.nvidia.com-opensuse         | nVidia Graphics Drivers                             | Ja       | Ja       |   99      | rpm-md | http://download.nvidia.com/opensuse/13.1/                                           |         
     3 | download.opensuse.org-Apps           | openSUSE BuildService - GNOME:Apps                  | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_13.1/                |         
     4 | download.opensuse.org-Extra          | openSUSE BuildService - KDE:Extra                   | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1/                 |         
     5 | download.opensuse.org-Stable         | openSUSE BuildService - LibreOffice                 | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_13.1/        |         
     6 | download.opensuse.org-Virtualization | openSUSE BuildService - Virtualisering (VirtualBox) | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_13.1/             |         
     7 | download.opensuse.org-Wine           | openSUSE BuildService - Wine CVS-pakker             | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_13.1/            |         
     8 | download.opensuse.org-filesystems    | openSUSE BuildService - filsystemers                | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/repositories/filesystems/openSUSE_13.1/                |         
     9 | download.opensuse.org-mozilla        | openSUSE BuildService - Mozilla                     | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.1/                    |         
    10 | ftp.gwdg.de-suse                     | Packman Repository                                  | Ja       | Ja       |   99      | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                            |         
    11 | openSUSE-13.1-1.10                   | openSUSE-13.1-1.10                                  | Nei      | Nei      |   99      | yast2  | hd:///?device=/dev/disk/by-id/scsi-1SanDisk_Cruzer_Blade_4C532000040423112241-part2 |         
    12 | opensuse-guide.org-repo              | libdvdcss repository                                | Ja       | Ja       |   99      | rpm-md | http://opensuse-guide.org/repo/13.1/                                                |         
    13 | repo-debug                           | openSUSE-13.1-Debug                                 | Nei      | Ja       |   99      | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                      |         
    14 | repo-debug-update                    | openSUSE-13.1-Update-Debug                          | Nei      | Ja       |   99      | NONE   | http://download.opensuse.org/debug/update/13.1/                                     |         
    15 | repo-debug-update-non-oss            | openSUSE-13.1-Update-Debug-Non-Oss                  | Nei      | Ja       |   99      | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                             |         
    16 | repo-non-oss                         | openSUSE-13.1-Non-Oss                               | Ja       | Ja       |   99      | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                        |         
    17 | repo-oss                             | openSUSE-13.1-Oss                                   | Ja       | Ja       |   99      | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                            |         
    18 | repo-source                          | openSUSE-13.1-Source                                | Nei      | Ja       |   99      | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/                     |         
    19 | repo-update                          | openSUSE-13.1-Update                                | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/update/13.1/                                           |         
    20 | repo-update-non-oss                  | openSUSE-13.1-Update-Non-Oss                        | Ja       | Ja       |   99      | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                   |         

  9. #9
    Join Date
    Oct 2012
    Location
    Norway
    Posts
    8

    Default Re: xneur crash Gimp ??

    It seems that libcairo2 is what causes my problem.
    I installed the Muzlocker version of freetype, for enhanced subpixel hinting, as an alternative to what is in the opensuse-community repo. Incidentally, the Muzlocker repo also includes a different version of libcairo2, which is installed along with the different freetype libraries.
    As far as I can see, after some brief testing, the installation has apparently solved my problem.

  10. #10
    Join Date
    Oct 2012
    Location
    Norway
    Posts
    8

    Default Re: xneur crash Gimp ??

    Switching between repos seems to reveal that the devil is in the opensuse-community repo.
    Switching back to the openSUSE-13.1-Oss repo for libcairo2, triggered no crashes.
    Switching back to the openSUSE-13.1-Oss repo for the freetype libraries as well, also caused no crash.
    Switching to the opensuse-community.org/subpixel repo, however, made Gimp crash.
    Obviously, one should take into account that both "subpixel repos" are Factory repos.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •