Results 1 to 3 of 3

Thread: opensuse 13.1 und bind

  1. #1

    Default opensuse 13.1 und bind

    Hallo,

    unter der Version 12.3 konnte ich mittels "systemctl enable named.service" den DNS-Dienst aktivieren. Mit Version 13.1 funktioniert das scheinbar nicht mehr. Ich bekomme dabei die Meldungen:

    The unit files have no [Install] section. They are not meant to be enabled
    using systemctl.
    Possible reasons for having this kind of units are:
    1) A unit may be statically enabled by being symlinked from another unit's
    .wants/ or .requires/ directory.
    2) A unit's purpose may be to act as a helper for some other unit which has
    a requirement dependency on it.
    3) A unit may be started when needed via activation (socket, path, timer,
    D-Bus, udev, scripted systemctl call, ...).

    Habt Ihr vielleicht eine Idee, was sich hier geändert hat?

    Gruß

  2. #2

    Default Re: opensuse 13.1 und bind

    Quote Originally Posted by JoeDBA View Post
    Hallo,

    unter der Version 12.3 konnte ich mittels "systemctl enable named.service" den DNS-Dienst aktivieren. Mit Version 13.1 funktioniert das scheinbar nicht mehr. Ich bekomme dabei die Meldungen:
    Soweit ich sehen kann, beinhaltet bind gar kein systemd unit file.
    Da läuft also evtl. was bei systemd's sysvinit support schief.

    Probier mal das altmodische "/usr/sbin/rcnamed start" oder "/etc/init.d/named start", funktioniert das?

    Edit: Sehe gerade, dass du es ja enabled willst, nicht starten.
    Probiere also "chkconfig named on".
    Oder vielleicht klappts ja mit dem neuen YaST->System->Service Manager?

  3. #3

    Default Re: opensuse 13.1 und bind

    Quote Originally Posted by wolfi323 View Post
    Soweit ich sehen kann, beinhaltet bind gar kein systemd unit file. Da läuft also evtl. was bei systemd's sysvinit support schief. Probier mal das altmodische "/usr/sbin/rcnamed start" oder "/etc/init.d/named start", funktioniert das? Edit: Sehe gerade, dass du es ja enabled willst, nicht starten. Probiere also "chkconfig named on". Oder vielleicht klappts ja mit dem neuen YaST->System->Service Manager?
    vielen Dank für die schnelle Antwort. Sowohl der Befehl "chkconfig named on" als auch der Weg über den YaST funktionieren ohne lästige Fehlermeldungen. Allerdings ist mir bei meinen Versuchen aufgefallen, dass scheinbar auch der ursprüngliche Weg über systemctl trotz der anderslautenden Ausgaben das tut, was er soll. Hier ist wohl der sysvinit Legacy Support vom systemd etwas strubbelig. Danke nochmals für die Unterstützung und viele Grüße!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •