Results 1 to 2 of 2

Thread: OpenSuse 13.1 64bit VPN funktioniert nicht richtig .....

  1. #1

    Default OpenSuse 13.1 64bit VPN funktioniert nicht richtig .....

    System :
    Linux Acer.site 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux


    Wenn ich die VPN Verbindung aufbaue mit KVpnc, schaut im Logfenster erst einmal alles normal aus.
    Bisher ( in den Versionen < 13.x) wurde der gesamte Netzwerksverkehr automatisch durch den Tunnel geroutet - sprich K-Mail, Netzscape etc... brachten z.T. ihre Fehlermeldungen, weil der Update nicht mehr funktionierte ( war so gewollt, da ich nicht meine privaten Daten durch das Netzwerk der Firma routen möchte // daher den IN Proxy und DNS etc. nicht für die VPN eingetragen).
    Via KRDC baue ich unter Angabe der IP-Adresse im Regelfall die Verbindung zum Rechner im Firmennetzwerk auf.

    Unter 13.1 läuft jedoch K-Mail, Firefox etc neben Tunnel fleissig weiter. Ein ping aus der Shell auf den Firmenrechner schlägt fehl. Am Anfang bekomme ich unter KRDC z.T. noch das Fenster um den Domänen/User einzugeben und seltener das Passwort. Danach ist jedoch absolut Schluß

    Meines Erachten funktioniert das Rerouting hier noch nicht richtig.
    Es bleibt gleich, ob ich die WLAN Verbindung hier am Notebook mittels ifup oder mit dem Networkmanager betreibe. Die intere IP-Adresse, DNS, Routing sind fest eingerichtet ( kein DHCP) / IPV6 ist deaktiviert.

    Hat jemand das gleiche Problem schon gehabt und gelöst?
    Anscheinend fehlt mir hier eine Route

    Acer:/home/M07 # route
    Kernel IP Routentabelle
    Ziel Router Genmask Flags Metric Ref Use Iface
    default 192.168.0.254 0.0.0.0 UG 0 0 0 wlp3s0
    62-134-46-2.de. 192.168.0.254 255.255.255.255 UGH 0 0 0 wlp3s0
    loopback * 255.0.0.0 U 0 0 0 lo
    172.28.12.19 * 255.255.255.255 UH 0 0 0 tun0
    172.28.12.20 * 255.255.255.255 UH 0 0 0 tun0
    192.168.0.0 * 255.255.255.0 U 0 0 0 wlp3s0

    Acer:/home/Mad07 # traceroute 172.29.143.188
    traceroute to 172.29.143.188 (172.29.143.188), 30 hops max, 60 byte packets
    1 192.168.0.254 (192.168.0.254) 1.168 ms 1.074 ms 1.531 ms
    2 lo1.br01.muc.de.hansenet.net (213.191.89.8) 27.773 ms 29.348 ms 31.604 ms^C
    Acer:/home/M07 #

  2. #2

    Default AW: OpenSuse 13.1 64bit VPN funktioniert nicht richtig .....

    Wenn ich in der Shell die fehlende Route hinzufüge, funktioniert es wieder :

    route add -net 172.29.0.0 netmask 255.255.0.0 tun0

    ? Wie bzw. wo KVpnc kann ich sehen, was vom Netzwerk zurückkommt ... zumal es früher ja ohne man. Modifikation funktioniert hat.
    Oder
    War früher der Fehler, daß alles durch den Tunnel ging? (Sprich ich muss diese Route nun handisch anlegen)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •