Results 1 to 8 of 8

Thread: Privoxy won't connect to the internet

  1. #1

    Default Privoxy won't connect to the internet

    I applied the fix in this bug
    https://bugzilla.novell.com/show_bug.cgi?id=849923

    Privoxy is running. Configured in Firefox. Default privoxy config.
    When I try to access a webpage I get a privoxy error, such as:

    Your request for http://www.theguardian.com/uk could not be fulfilled, because the domain name ... could not be resolved.

    I was using privoxy in SUSE 10.2 until yesterday when I upgraded to 13.1. I don't remember having to configure the internet connection. in privoxy itself.

    Firewall makes no difference. resolv.conf is OK. Internet access is OK without privoxy. Same in another browser.

    Is privoxy working for anybody?

  2. #2

    Default Re: Privoxy won't connect to the internet

    same problem here, I did a clean install to move from 12.1 to 13.1.
    privoxy has always been a bit flaky for me, sometimes the service not starting etc. These problems were normally fixed with online updates.
    Also now the privoxy logfile is empty (even after the fix in the bugreport), making it that much harder to debug. Does yours contain anything?

  3. #3
    Join Date
    Nov 2013
    Posts
    19

    Default Re: Privoxy won't connect to the internet

    Same here.

    From what I gathered, applying the fix will help if you upgrade from a recent version, but fail if it is a new install, or an upgrade from a very old version

    Somehow the install script doesn't set up the chroot environment correctly. Adding the usual suspects /var/lib/privoxy/lib/, i.e.,

    libnss_dns-2.18.so libnss_dns.so libnss_dns.so.2 libresolv-2.18.so libresolv.so libresolv.so.2

    does not help either. I guess the above list is missing some libraries

    However, you can run without the chroot environment i.e.,

    /usr/sbin/privoxy --pidfile /run/privoxy.pid /etc/privoxy/config

    but this poses a certain security risk

    Cheers

    Uli

  4. #4

    Default Re: Privoxy won't connect to the internet

    /usr/sbin/privoxy --pidfile /run/privoxy.pid /etc/privoxy/config

    doesn't work for me - privoxy won't start
    Code:
    privoxy.service - Privoxy Web Proxy With Advanced Filtering Capabilities
       Loaded: loaded (/usr/lib/systemd/system/privoxy.service; enabled)
       Active: failed (Result: exit-code) since Wed 2013-11-27 16:56:54 GMT; 3min 3s ago
      Process: 1394 ExecStart=/usr/sbin/privoxy --pidfile /run/privoxy.pid /etc/privoxy/config (code=exited, status=1/FAILURE)
    
    Nov 27 16:56:53 PIP systemd[1]: Starting Privoxy Web Proxy With Advanced Filtering Capabilities...
    Nov 27 16:56:54 PIP systemd[1]: privoxy.service: control process exited, code=exited status=1
    Nov 27 16:56:54 PIP systemd[1]: Failed to start Privoxy Web Proxy With Advanced Filtering Capabilities.
    Nov 27 16:56:54 PIP systemd[1]: Unit privoxy.service entered failed state.
    I also tried several variations of this - e.g /etc/config as in the bugfix - I couldn't get privoxy to start.

  5. #5

    Default Re: Privoxy won't connect to the internet

    I have a clean install and the fix was required for privoxy to start. The --chroot option *is* required. I also had to change the path supplied from /etc/privoxy/config to /etc/config (even though that does not exist, is it inside the chroot?)
    Also note, I'm on i586, not x86_64 as in the bugreport.

  6. #6

    Default Re: Privoxy won't connect to the internet

    Quote Originally Posted by vespas View Post
    I have a clean install and the fix was required for privoxy to start. The --chroot option *is* required. I also had to change the path supplied from /etc/privoxy/config to /etc/config (even though that does not exist, is it inside the chroot?)
    Also note, I'm on i586, not x86_64 as in the bugreport.
    And does privoxy work for you?

  7. #7

    Default Re: Privoxy won't connect to the internet

    no it doesn't.

  8. #8

    Default Re: Privoxy won't connect to the internet

    Fixes here work for me
    https://bugzilla.novell.com/show_bug.cgi?id=852941
    (omit '64' if like me you have a 32-bit OS)
    Thank you, Manfred.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •