Results 1 to 9 of 9

Thread: Sound stutters / skips in opensuse 12.3 snd-hda-intel

  1. #1
    Join Date
    Sep 2012
    Location
    Colorado, US
    Posts
    21

    Question Sound stutters / skips in opensuse 12.3 snd-hda-intel

    I've had issues with mp3 files stuttering, and otherwise skipping, scratching, popping, and playing choppy on my 586 opensuse 12.3 laptop. Sound worked in about the Ubuntu 9.04 time frame, but in some upgrade pulseaudio or alsa must have changed and broke the configuration. That gave me the excuse to move distributions, but I had the same problem in Fedora and now opensuse. Sound has worked fine on this same laptop in windows xp (32 bit) and 7 (64 bit).

    I've done quite a bit of troubleshooting but haven't hit the magic combination yet. Modifying /etc/pulse/default.pa to have tsched=0 makes sound in flash sound like a machine gun, and doesn't stop the regular mp3 stuttering.
    Code:
    load-module module-udev-detect tsched=0
    Regular speaker tests like "speaker-test -c2 -l5 -twav" run fine.

    I've tried many options in /etc/modprobe.d/50-sound.conf, both with options at the top and the bottom of the file. (I'm not sure if that matters.) These are a few I've tried one at a time, with reboots:
    Code:
    options snd-hda-intel enable_msi=1 bdl_pos_adj=0,48
    options snd-hda-intel position_fix=2
    options snd-hda-intel position_fix=1
    options snd-hda-intel model=auto enable_msi=0
    options snd-hda-intel model=auto enable_msi=0
    I've gone through the steps in SDB:Intel-HDA sound problems - openSUSE and SDB:Audio troubleshooting - openSUSE. Previously I've tried various "remove all of pulseaudio" steps but that didn't work, either. I did try setting in /etc/pulse/daemon.conf
    Code:
    default_sample_rate = 48000
    but that didn't help.

    From http://en.opensuse.org/SDBulseaudio I found the hint in /etc/pulse/daemon.conf to uncomment the default-fragments and default-fragment-size-msec, and change values from the default 4 and 25 to 16 and 21, but that didn't fix it.

    Code:
    head -n 1 /proc/asound/card0/codec#*
    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC268
    
    ==> /proc/asound/card0/codec#1 <==
    Codec: Motorola Si3054
    "sudo lspci -v | grep -A 10 Audio" tells me I have an Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03). As I type this MSI: is Enable-, but I've had it Enable+ before, too. (That flips depending on enable_msi.)

    The laptop itself is a Compal JFL92 I got from system76 as a SERP4 (serval performance). https://bbs.archlinux.org/viewtopic.php?id=170855 describes an archlinux problem that looks the same as mine, but the "enable_msi=0" workaround didn't fix me.

    I'm out of ideas. If anyone has any ideas to try or needs more specific information I'd love the help.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,284

    Default Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Try turning pulse off in Yast-sound

  3. #3
    Join Date
    Sep 2012
    Location
    Colorado, US
    Posts
    21

    Default Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Quote Originally Posted by gogalthorp View Post
    Try turning pulse off in Yast-sound
    It still skips playing mp3s. I opened up yast, Went to sound > Other > PulseAudio Configuration... > and unchecked Enable PulseAudio Support, then rebooted. KDE noticed I had controllers missing (the pulseaudio bits), but I had it leave them in place.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Quote Originally Posted by andrewdied View Post
    It still skips playing mp3s. I opened up yast, Went to sound > Other > PulseAudio Configuration... > and unchecked Enable PulseAudio Support, then rebooted. KDE noticed I had controllers missing (the pulseaudio bits), but I had it leave them in place.
    I have a blog on using PulseAudio you can find here: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Sep 2012
    Location
    Colorado, US
    Posts
    21

    Default Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Quote Originally Posted by jdmcdaniel3 View Post
    Thanks for the tip. I've now installed pavucontrol (and re-enabled pulseaudio since disabling it didn't help) but it doesn't fix the choppy stuttering skipping problem.

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Quote Originally Posted by andrewdied View Post
    Thanks for the tip. I've now installed pavucontrol (and re-enabled pulseaudio since disabling it didn't help) but it doesn't fix the choppy stuttering skipping problem.
    And did you follow our Multimedia codec guide?

    https://forums.opensuse.org/blogs/ca...ion-guide-149/

    Normally, that Intel chipset should work OK I would think.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Sep 2012
    Location
    Colorado, US
    Posts
    21

    Default Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Quote Originally Posted by jdmcdaniel3 View Post
    And did you follow our Multimedia codec guide?

    https://forums.opensuse.org/blogs/ca...ion-guide-149/

    Normally, that Intel chipset should work OK I would think.
    I used that (or an earlier version) when I installed so I could get all the right codecs. I suspect it's non-destructive so I'll try it again later.

    I've downloaded the drivers direct from realtek, but I'm hesitant to install it in case I can't back it out if it makes the problem worse.

  8. #8
    Join Date
    Sep 2012
    Location
    Colorado, US
    Posts
    21

    Default Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Quote Originally Posted by jdmcdaniel3 View Post
    And did you follow our Multimedia codec guide?

    https://forums.opensuse.org/blogs/ca...ion-guide-149/
    It looks like I hadn't, since I had to add the repos and install a bunch of packages. I wonder if I'd followed a similar Ubuntu method that had similar names. Aside: The 12.3 version is at https://forums.opensuse.org/english/...ion-guide.html.

    In any event, I installed all the kde packages, rebooted, and still have the skipping.

  9. #9
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Sound stutters / skips in opensuse 12.3 snd-hda-intel

    Quote Originally Posted by andrewdied View Post
    It looks like I hadn't, since I had to add the repos and install a bunch of packages. I wonder if I'd followed a similar Ubuntu method that had similar names. Aside: The 12.3 version is at https://forums.opensuse.org/english/...ion-guide.html.

    In any event, I installed all the kde packages, rebooted, and still have the skipping.
    Have I suggested a new kernel upgrade? Have a look here: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

    The kernel is where the base hardware driver is stored.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •