Results 1 to 10 of 10

Thread: help with multifunction printer

  1. #1

    Default help with multifunction printer

    hi ,
    i've got a canon pixma mg5350 printer and installed drivers from canon, i can print without problem but i'm
    able to scan only with the utility provides with the (scangeamp).i've tried with skanlite, xsane, and vuescan and none work.
    Comming from arch linux where scanning work from all apps, there is a PKGBUILD that install driver from source and i need a help to
    adapt it for opensuse.i dont have scripting skills and help will be greatly appreciate.
    the PKGBUILD is locate at:
    https://aur.archlinux.org/packages/s...g5300/PKGBUILD
    thanks in advance.


    PS:sorry for bad english

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: help with multifunction printer

    Quote Originally Posted by brice83 View Post
    hi ,
    i've got a canon pixma mg5350 printer and installed drivers from canon, i can print without problem but i'm
    able to scan only with the utility provides with the (scangeamp).i've tried with skanlite, xsane, and vuescan and none work.
    Comming from arch linux where scanning work from all apps, there is a PKGBUILD that install driver from source and i need a help to
    adapt it for opensuse.i dont have scripting skills and help will be greatly appreciate.
    the PKGBUILD is locate at:
    https://aur.archlinux.org/packages/s...g5300/PKGBUILD
    thanks in advance.


    PS:sorry for bad english
    From what I've read (and I've assisted a few with similar Canon hardware), the proprietary driver only works with scangearmp, and I'm not familiar with any workaround that permits using other scasnning apps (unless the scanner is supported by open source SANE drirvers as well). Can you point to other references which demonstrate otherwise?

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: help with multifunction printer

    Admittedly using 12.3 (haven't yet tried on 13.1, I won't have a chance for another week or so to connect so an "MPL-"something or another"),

    But my previous scanning apps have been setup successfully <without> the proprietary Canon drivers, protocol and software.

    Recommend:
    Uninstall the Canon proprietary stuff.
    From within YAST (or zipper) search for and install everything related to scanning (probably unnecessary, but this worked for me).
    Go into YAST, open and run the "scanner" applet.

    Now, test in any scanner capable app.

    HTH,
    TSU

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: help with multifunction printer

    Models supported by sane backends are listed here:

    SANE: Supported Devices

    For many Canon devices, the only choices are to use the proprietary drivers.

  5. #5

    Default Re: help with multifunction printer

    Quote Originally Posted by deano_ferrari View Post
    From what I've read (and I've assisted a few with similar Canon hardware), the proprietary driver only works with scangearmp, and I'm not familiar with any workaround that permits using other scasnning apps (unless the scanner is supported by open source SANE drirvers as well). Can you point to other references which demonstrate otherwise?
    i've also read that somewhere, but i was surprising to see that all scanning apps in archlinux recognise the scanner.i supposed that it is the modify install script.

  6. #6

    Default Re: help with multifunction printer

    Quote Originally Posted by tsu2 View Post
    Admittedly using 12.3 (haven't yet tried on 13.1, I won't have a chance for another week or so to connect so an "MPL-"something or another"),

    But my previous scanning apps have been setup successfully <without> the proprietary Canon drivers, protocol and software.

    Recommend:
    Uninstall the Canon proprietary stuff.
    From within YAST (or zipper) search for and install everything related to scanning (probably unnecessary, but this worked for me).
    Go into YAST, open and run the "scanner" applet.

    Now, test in any scanner capable app.

    HTH,
    TSU
    try that and it don't work.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: help with multifunction printer

    Quote Originally Posted by brice83 View Post
    try that and it don't work.
    No, I think you'll need to stay with the proprietary driver.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: help with multifunction printer

    Quote Originally Posted by brice83 View Post
    i've also read that somewhere, but i was surprising to see that all scanning apps in archlinux recognise the scanner.i supposed that it is the modify install script.
    I had a quick look at the install script. I can see that the script pulls the tarball from http://gdlp01.c-wss.com, and I guess that contains the patches etc

    For interests sake I downloaded the tarball manually with
    Code:
    wget http://gdlp01.c-wss.com/gds/1/0100003931/01/scangearmp-source-1.80-1.tar.gz
    The PKGBUILD script would not take much to adapt as a regular install script IMHO. I think your best bet may be to start a new thread requesting help for this

    https://forums.opensuse.org/english/...ing-scripting/

    I'm intrigued that someone has been able to modify the source to cope with making the driver able to talk with other SANE front-ends. It isn't clear from the PKGBUILD how that was done. So, I wish you luck with this project.

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: help with multifunction printer

    Took a look at this...

    - IMO the install script is one of the simplest to modify. The library dependencies seem to be all provided from source so the three app dependencies(GIMP, sane, libpng) only need to be installed and if necessary versions in the script modified.
    - The real problem I see is that the link you provided at ARCH is relevant to a different device so the question is... Is this link and library really appropriate for your specific device because it might support a general family of devices? Or, do you really need something else that is specific to your device?

    So, I recommend you contact Canon to at least find out what is the correct source if they don't have a pre-built driver that would work.
    Unless you've verified on your own on an Arch Linux that <this code> really does work.,

    Once you've verified correct source, I don't see the work to modify the script that difficult or take more than an hour or two.

    IMO,
    TSU

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: help with multifunction printer

    Quote Originally Posted by tsu2 View Post
    - The real problem I see is that the link you provided at ARCH is relevant to a different device so the question is... Is this link and library really appropriate for your specific device because it might support a general family of devices? Or, do you really need something else that is specific to your device?

    So, I recommend you contact Canon to at least find out what is the correct source if they don't have a pre-built driver that would work.
    Unless you've verified on your own on an Arch Linux that <this code> really does work.
    The OP wishes to use the source because apparently there are some patches that allow the scanner to be used with various sane front-ends, unlike the regular Canon package, which is designed only to work with scangearmp. (There are a number of threads across different distros the discuss this). The gimp plugin is part of this package. So, contacting Canon is unlikely to be of help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •