Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: nvidia drivers installation on 12.3 to 13.1 upgrade problem

  1. #1

    Default nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Hello,

    I am new to OpenSUSE, but have some experience on other distros. Recently I upgraded my 12.3 install to 13.1 (my installation is 32bit). System is AMD athlon 64X2, ASUS M3N series motherboard (not using onboard graphics card), with 2GB RAM & 250 GB HDD with Win7 dualboot. I have ASUS Nvidia GForce 210 card.

    After upgrade I was stuck at grey screen with OpenSUSE gecko on it. I tried login from Recovery mode it it worked well but at less Resolution. (on 21 inch monitor it looks like frame with thick edges)

    I am unable to get Nvidia drivers for 13.1 on the FTP site, as per forum references I tried installing Nvidia drivers hard way, but landed up with errors

    1. Error 1 - Xserver is running. ( I did
    Code:
    init 3
    & got pass this error)

    2. Error 2 - after
    Code:
    sh NVIDIA-Linux-x86-319.17.run
    , Accepted t&C, then error was Unable to compile kernel drivers

    Now I am clueless how to bypass this. Any help appreciated.

  2. #2

    Default AW: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Quote Originally Posted by vikcon View Post
    I am unable to get Nvidia drivers for 13.1 on the FTP site, as per forum references I tried installing Nvidia drivers hard way, but landed up with errors
    That repo doesn't exist yet for 13.1, but should soon.

    1. Error 1 - Xserver is running. ( I did
    Code:
    init 3
    & got pass this error)

    2. Error 2 - after
    Code:
    sh NVIDIA-Linux-x86-319.17.run
    , Accepted t&C, then error was Unable to compile kernel drivers

    Now I am clueless how to bypass this. Any help appreciated.
    319.17 is too old. It doesn't work with Kernel 3.11.6 as included in openSUSE 13.1.
    Download and install a newer version:
    Unix Drivers | NVIDIA

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    On 2013-11-26 16:36, vikcon wrote:
    > I am unable to get Nvidia drivers for 13.1 on the 'FTP site'


    If you want them you have to wait.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  4. #4

    Default Re: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Quote Originally Posted by vikcon View Post
    Hello,

    I am new to OpenSUSE, but have some experience on other distros. Recently I upgraded my 12.3 install to 13.1 (my installation is 32bit). System is AMD athlon 64X2, ASUS M3N series motherboard (not using onboard graphics card), with 2GB RAM & 250 GB HDD with Win7 dualboot. I have ASUS Nvidia GForce 210 card.

    After upgrade I was stuck at grey screen with OpenSUSE gecko on it. I tried login from Recovery mode it it worked well but at less Resolution. (on 21 inch monitor it looks like frame with thick edges)

    I am unable to get Nvidia drivers for 13.1 on the FTP site, as per forum references I tried installing Nvidia drivers hard way, but landed up with errors

    1. Error 1 - Xserver is running. ( I did
    Code:
    init 3
    & got pass this error)

    2. Error 2 - after
    Code:
    sh NVIDIA-Linux-x86-319.17.run
    , Accepted t&C, then error was Unable to compile kernel drivers

    Now I am clueless how to bypass this. Any help appreciated.
    Hi,

    The nvidia driver version that works with 13.1 are the 331.20 and 304.1160
    These drivers were release last November 6, 2013.

    I just upgraded my old laptop with GeForce 8200M G from 12.3 to 13.1 with the driver already in my home partition.
    and install it after finishing the update in runlevel 3.
    People who do not break things first will never learn to create anything

  5. #5

    Default Re: AW: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Quote Originally Posted by wolfi323 View Post
    That repo doesn't exist yet for 13.1, but should soon.


    319.17 is too old. It doesn't work with Kernel 3.11.6 as included in openSUSE 13.1.
    Download and install a newer version:
    Unix Drivers | NVIDIA
    Thanks a lot.
    It worked like charm.

  6. #6

    Default Re: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Quote Originally Posted by conram View Post
    Hi,

    The nvidia driver version that works with 13.1 are the 331.20 and 304.1160
    These drivers were release last November 6, 2013.

    I just upgraded my old laptop with GeForce 8200M G from 12.3 to 13.1 with the driver already in my home partition.
    and install it after finishing the update in runlevel 3.
    Thanks all!

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Quote Originally Posted by vikcon View Post
    I am unable to get Nvidia drivers for 13.1 on the FTP site
    I had the same problem last weekend when I upgraded from 12.3 to 13.1

    (and that was not the only problem)

    Used CloneZilla to go back to 12.3

    Since the whole process was quite a time-consuming and disappointing ordeal, I will not be trying 13 again until a few more problems are ironed out.

    As for the nVidia drivers, I might have been encouraged if I had found this post with the driver links at the time.

    Unfortunately, I have yet to find a forum that has a decent search mechanism. In times like that, I do not have the luxury of browsing through the 100,001 threads returned by a search.

    (NOT knocking this forum, btw. The search problem is universal to all forums I have experienced, so far)

    I am keeping the links for future reference, when I try again. Which I will, because out of all the Distros and all the versions of MS, OpenSUSE is where I am the most pleased with the experience. I have to work hard, at times, and a strong system like OpenSUSE is crucial for getting things done.

    -fb

  8. #8

    Default Re: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Quote Originally Posted by Fraser_Bell View Post
    As for the nVidia drivers, I might have been encouraged if I had found this post with the driver links at the time.

    Unfortunately, I have yet to find a forum that has a decent search mechanism. In times like that, I do not have the luxury of browsing through the 100,001 threads returned by a search.
    Hm? For me it would be the most obvious thing to look at nvidia's official homepage for a driver...

  9. #9
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,307

    Default Re: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    On fresh install of 13.1, Unable to compile NVIDIA-Linux-x86_64-304.108 ( 6800 GS ) :

    THis part of /var/log/nvidia-installer.log :

    Code:
    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Thu Nov 28 22:19:41 2013
    installer version: 304.108
    
    PATH: /usr/lib64/mpi/gcc/openmpi/bin:/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/mit/bin:/usr/lib/mit/sbin
    
    nvidia-installer command line:
        ./nvidia-installer
        -a
    
    Using: nvidia-installer ncurses user interface
    -> License accepted by command line option.
    -> Installing NVIDIA driver version 304.108.
    -> Running distribution scripts
       executing: '/usr/lib/nvidia/pre-install'...
    -> done.
    -> Performing CC sanity check with CC="cc".
    -> Performing CC version check with CC="cc".
    -> Kernel source path: '/lib/modules/3.11.6-4-desktop/source'
    -> Kernel output path: '/lib/modules/3.11.6-4-desktop/build'
    -> Performing rivafb check.
    -> Performing nvidiafb check.
    -> Performing Xen check.
    -> Cleaning kernel module build directory.
       executing: 'cd ./kernel; make clean'...
    -> Building kernel module:
       executing: 'cd ./kernel; make module SYSSRC=/lib/modules/3.11.6-4-desktop/source SYSOUT=/lib/modules/3.11.6-4-desktop/build'...
       NVIDIA: calling KBUILD...
       make -C /lib/modules/3.11.6-4-desktop/build \
       KBUILD_SRC=/usr/src/linux-3.11.6-4 \
       KBUILD_EXTMOD="/tmp/selfgz4062/NVIDIA-Linux-x86_64-304.108/kernel" -f /usr/src/linux-3.11.6-4/Makefile \
       modules
       test -e include/generated/autoconf.h -a -e include/config/auto.conf || (        \
       echo >&2;                            \
       echo >&2 "  ERROR: Kernel configuration is invalid.";        \
       echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
       echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";    \
       echo >&2 ;                            \
       /bin/false)
    
    -----------
    -----------
    -----------
       /tmp/selfgz4062/NVIDIA-Linux-x86_64-304.108/kernel/os-interface.c: In function ‘os_is_efi_enabled’:
       /tmp/selfgz4062/NVIDIA-Linux-x86_64-304.108/kernel/os-interface.c:1469:5: warning: return makes integer from pointer without a cast [enabled by default]
            return efi_enabled;
            ^
       /tmp/selfgz4062/NVIDIA-Linux-x86_64-304.108/kernel/os-interface.c: In function ‘os_get_system_memory_size’:
       /tmp/selfgz4062/NVIDIA-Linux-x86_64-304.108/kernel/os-interface.c:466:1: warning: control reaches end of non-void function [-Wreturn-type]
        }
        ^
       make[4]: *** [/tmp/selfgz4062/NVIDIA-Linux-x86_64-304.108/kernel/os-interface.o] Error 1
       make[3]: *** [_module_/tmp/selfgz4062/NVIDIA-Linux-x86_64-304.108/kernel] Error 2
       make[2]: *** [sub-make] Error 2
       NVIDIA: left KBUILD.
       nvidia.ko failed to build!
       make[1]: *** [module] Error 1
       make: *** [module] Error 2
    -> Error.
    ERROR: Unable to build the NVIDIA kernel module.
    ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.

    . I will try the last good driver ( for my hardware ) which was working on 12.3.

    Any help is welcome
    Thanks for helping. JCD
    __________
    server leap 15.0 -- ASUS g75vw KDE leap 15.2 -- ASUS G731GV KDE leap 15.2 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  10. #10
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,307

    Default Re: nvidia drivers installation on 12.3 to 13.1 upgrade problem

    Unable to compile NVIDIA driver version 304.60.

    here /var/log/nvidia-installer.log :
    Code:
    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Fri Nov 29 10:08:28 2013
    installer version: 304.60
    
    PATH: /usr/lib64/mpi/gcc/openmpi/bin:/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/mit/bin:/usr/lib/mit/sbin
    
    nvidia-installer command line:
        ./nvidia-installer
        -a
    
    Using: nvidia-installer ncurses user interface
    -> License accepted by command line option.
    -> Installing NVIDIA driver version 304.60.
    -> Running distribution scripts
       executing: '/usr/lib/nvidia/pre-install'...
       
       Kernel image:   /boot/vmlinuz-3.11.6-4-desktop
       Initrd image:   /boot/initrd-3.11.6-4-desktop
       Root device:    /dev/disk/by-id/ata-ST3320820AS_9QF6JA2A-part1 (/dev/sda1) (mounted on / as ext4)
       Resume device:    /dev/disk/by-id/ata-ST3320820AS_9QF6JA2A-part5 (/dev/sda5)
       Kernel Modules:    thermal_sys thermal processor fan scsi_dh scsi_dh_alua scsi_dh_emc scsi_dh_rdac scsi_dh_hp_sw xhci-hcd hid-logitech-dj hid-holtek-kbd hid-lenovo-tpkbd hid-ortek hid-roccat hid-roccat-common hid-roccat-arvo hid-roccat-isku hid-samsung ohci-pci 
       Features:       acpi plymouth block usb resume.userspace resume.kernel
    -> done.
    -> Performing CC sanity check with CC="cc".
    -> Performing CC version check with CC="cc".
    ERROR: The kernel header file '/lib/modules/3.11.6-4-desktop/build/include/linux/version.h' does not exist.  The most likely reason for this is that the kernel source files in '/lib/modules/3.11.6-4-desktop/build' have not been configured.
    ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
    Any help is welcome
    Thanks for helping. JCD
    __________
    server leap 15.0 -- ASUS g75vw KDE leap 15.2 -- ASUS G731GV KDE leap 15.2 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •