Results 1 to 4 of 4

Thread: Screen flickering in dual screen setup in 13.1

  1. #1
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Screen flickering in dual screen setup in 13.1

    I have a dell xps13 ultrabook with an intel graphics card, the laptop screen is 1920x1080.

    When I connect my extra screen 1680x1050 the top of the screen flickers.

    Things I have tried without effect:
    - disabling desktop effects
    - change Xrender to OpenGL
    - lowering the resolution of the screen (still keeps flickering)
    - disabling the laptop screen so it is only 1 screen config (still keeps flickering)
    - installing xrandr: this crashed my xserver and forced me to reinstall opensuse (not doing that again).

    In attachment you will find my Xorg.0.log file for more information:
    https://dl.dropboxusercontent.com/u/13564139/Xorg.0.log

    Before the new install of 13.1, this never occured. Perhaps something with the intel graphics driver?

    Is there another log file I can upload for more information?

    Thanks for your help.

  2. #2

    Default Re: Screen flickering in dual screen setup in 13.1

    Quote Originally Posted by Dorax View Post
    Before the new install of 13.1, this never occured. Perhaps something with the intel graphics driver?
    Yes.
    https://bugzilla.novell.com/show_bug.cgi?id=852025
    https://bugzilla.novell.com/show_bug.cgi?id=847762
    https://bugzilla.novell.com/show_bug.cgi?id=847941

    An update to 2.99.906 is available since yesterday in the official update repo though.
    Just use YaST->Online Update, "zypper up", or your update applet to install it.

    But the crash you mention shouldn't have forced you to _reinstall_... What was the problem?

  3. #3
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Re: Screen flickering in dual screen setup in 13.1

    Thanks I will give it a try.

    No idea what happened with the crash. All of a sudden xterm opened instead of kde after installing xrandr and krandr. I reinstalled kscreen and removed xrandr, but the problem stayed. So forced by other workdeadlines and direct optical fiber connexion at work I reinstalled 5 GB opensuse in 20 minutes to save me time : )

    Still might be worth to install krandr and see if there is a bug there.

    PS: the flickering seems to go away after working for a while. Strange.

  4. #4

    Default Re: Screen flickering in dual screen setup in 13.1

    Quote Originally Posted by Dorax View Post
    Still might be worth to install krandr and see if there is a bug there.
    No. Krandr is deprecated and obsoleted. It is replaced by kscreen.
    And you shouldn't install it.
    How did you do that anyway?
    If I try to install krandr on my system (KDE 4.11.3 from the KDE repo), zypper/YaST wants to uninstall the whole KDE.
    So of course you get xdm (I think it's this what you mean with "xterm") as login screen then, because kdm is not even installed afterwards anymore...

    It's possible to install krandr by ignoring dependencies, but depending on the order you install/uninstall krandr and kscreen, you may end up without /usr/bin/krandrstartup, which is required to start KDE (it is just empty in the case of kscreen though).

    Kscreen does provide an applet for the system tray to easily change the resolution. You may have to enable it in the system tray settings though (right-click on the small up-arrow on the right, just left of the digital clock, and select "System Tray Settings").

    You can install and use xrandr just fine.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •