Results 1 to 4 of 4

Thread: 66% sound volume

  1. #1

    Question 66% sound volume

    I was surprised that my headphones became unexpectedly loud after my updates for openSUSE 13.1/Tumbleweed. I have experimented a bit in my KDE 4.11.3 session which uses the primary backend "Phonon GStreamer 4.7.0-2.4.1" at the moment.

    Now I see and hear that when some applications try to notify me about something like the usual inquiry for storing an edited document the corresponding event sound is mostly changed to a specific volume. I can decrease the volume. But it will be reset to 66% in this case.
    A higher volume is kept if I increase the affected system setting above this level. How should I reduce this 66% thing?

  2. #2

    Default Re: 66% sound volume

    Quote Originally Posted by elfring View Post
    I was surprised that my headphones became unexpectedly loud after my updates for openSUSE 13.1/Tumbleweed. I have experimented a bit in my KDE 4.11.3 session which uses the primary backend "Phonon GStreamer 4.7.0-2.4.1" at the moment.

    Now I see and hear that when some applications try to notify me about something like the usual inquiry for storing an edited document the corresponding event sound is mostly changed to a specific volume. I can decrease the volume. But it will be reset to 66% in this case.
    A higher volume is kept if I increase the affected system setting above this level. How should I reduce this 66% thing?
    PulseAudio allows to set the volume to a maximum of 153%.
    In the latest KDE, KMix has an experimental feature to allow this, which is turned on by default in openSUSE 13.1. But it shows PA's 153% as 100%, which explains your 66%.

    See here for how to turn that off:
    http://forums.opensuse.org/english/g...ml#post2597691

    As to why your volume doesn't stick, I have no idea, since I don't use PulseAudio at all.
    You could try to turn PA off in YaST->Hardware->Sound, click on "Other" and select "PulseAudio Configuration".

  3. #3

    Lightbulb Re: Fiddling with sound volumes

    Quote Originally Posted by wolfi323 View Post
    PulseAudio allows to set the volume to a maximum of 153%.
    In the latest KDE, KMix has an experimental feature to allow this, which is turned on by default in openSUSE 13.1.
    Thanks for your answer.

    The KMix display returns by the setting "VolumeOverdrive=false" to a value range I was used to before.

    As to why your volume doesn't stick, I have no idea, since I don't use PulseAudio at all.
    I am curious when my choice will become persistent again for a lower value of the event sound volume in this audio interface.

    You could try to turn PA off in YaST->Hardware->Sound, click on "Other" and select "PulseAudio Configuration".
    The sound volume is kept as expected after I switched the PulseAudio support off. I hope that I can reactivate it in the near future.

  4. #4

    Default Re: Fiddling with sound volumes

    Quote Originally Posted by elfring View Post
    I am curious when my choice will become persistent again for a lower value of the event sound volume in this audio interface.
    Well, there was/is a bug regarding this in Phonon (it automatically raised the notification volume to 100% when a notification was played).
    https://bugs.kde.org/show_bug.cgi?id=324975

    But I thought that was fixed already in openSUSE's packages?
    Code:
    * Tue Sep 24 2013 hrvoje.senjan@gmail.com
    - Drop 0001-Revert-cache-volume-inside-PAStreams-when-trying-to-.patch
      better solution is done in kdebase4-runtime package
    
    
    * Tue Sep 17 2013 hrvoje.senjan@gmail.com
    - Added 0001-Revert-cache-volume-inside-PAStreams-when-trying-to-.patch,
      which resolves a regression in volume getting restored after each
      knotify event (kde#324975)
    and kdebase4-runtime:
    Code:
    * Tue Sep 24 2013 hrvoje.senjan@gmail.com
    - Added Remove-volume-control-from-KNotify.patch -- Basically is
      KNotify's volume controlling ineffective, however with phonon 4.7
      it triggeres a bad side-effect, thus we remove the option completely
      kde#324975
    Do the other volumes stick?
    Does it work if you use pavucontrol to set the notification volume?

    Maybe you should file a bug report, but the question is if it is PulseAudio's, KMix's, or Phonon's fault.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •