Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Automount Partitions at Startup

  1. #1

    Default Automount Partitions at Startup

    I saw another thread about being able to mount NTFS partitions at startup automatically at startup. I have parted installed, but I don't seem to understand how to do this. I would prefer an easier option vs. the other option which is quite extensive. Can someone give me an idea how to do this with Yast? I can mount the partitions with the File Manager every time I start up my computer, but that is not a great choice. I want to be able to access a word processing document with Libreoffice with my NTFS partition with all of my documents without needing to mount the partition beforehand.

    FYI - I am using 13.1 Gnome. Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,169

    Default Re: Automount Partitions at Startup

    This is quite easy to do. start yast and find the tab partitioner (click ok on the warning message) / click on the partition that you want to auto-mount / select the edit option / change the option to auto-mount for the location I usually do /windows/c, /windows/d etc

    If you have any problems please post back

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Automount Partitions at Startup

    Yast boot tell the module to mount the NTFS at some place in the files system. Usually would be /windows/c

    I believe you can also use the advanced option in the partition window to set it to be read/write to normal users. But that can also be done in the /etc/fstab file

  4. #4

    Default Re: Automount Partitions at Startup

    Quote Originally Posted by gogalthorp View Post
    Yast boot tell the module to mount the NTFS at some place in the files system. Usually would be /windows/c
    This isn't done anymore for quite some time AFAIK.

    I believe you can also use the advanced option in the partition window to set it to be read/write to normal users. But that can also be done in the /etc/fstab file
    Yes, but the default options should be sufficient to mount an NTFS partition as read/write for all users.
    See the other thread.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Automount Partitions at Startup

    Oh yes it has been so long since I had a Windows files system that was not virtual. I forgot. Lets see maybe around 10.1???


    This isn't done anymore for quite some time AFAIK.
    Not sure what is not done any more maybe /windows/c. Well you can put the mount point where you want to.

  6. #6

    Default Re: Automount Partitions at Startup

    Quote Originally Posted by gogalthorp View Post
    Not sure what is not done any more maybe /windows/c. Well you can put the mount point where you want to.
    When you do a fresh installation, the installer used to setup mounts for your Windows drives in /windows/C, /windows/D, and so on, automatically.
    This is not done anymore I think.

    Of course you can set up any mounts you want with YaST->System->Partitioner, or by editing fstab directly. You can even mount to /that_is_my_super_big_windows_hard_drive if you want to...

  7. #7

    Default Re: Automount Partitions at Startup

    Quote Originally Posted by dth2 View Post
    This is quite easy to do. start yast and find the tab partitioner (click ok on the warning message) / click on the partition that you want to auto-mount / select the edit option / change the option to auto-mount for the location I usually do /windows/c, /windows/d etc

    If you have any problems please post back
    Well I tried to mount as described in your post, but I get the following errors, which I do not quite understand so I did not do anything before I get some idea what this means. Thanks!

    Failure occurred during the following action:
    Mounting /dev/sda2 to /windows/d


    System error code was: -3003


    /bin/mount -t ntfs-3g -o noatime,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 '/dev/sda2' '/windows/d':
    The disk contains an unclean file system (0, 0).
    Metadata kept in Windows cache, refused to mount.
    Failed to mount '/dev/sda2': Operation not permitted
    The NTFS partition is in an unsafe state. Please resume and shutdown
    ...


    Continue despite the error?

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Automount Partitions at Startup

    On 2013-11-26 16:26, CHAZDG51 wrote:

    > Continue despite the error?


    No. Boot Windows and repair that partition. If you are using W8, be sure
    to disable fast poweroff.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9

    Default Re: Automount Partitions at Startup

    Quote Originally Posted by robin_listas View Post
    On 2013-11-26 16:26, CHAZDG51 wrote:

    > Continue despite the error?


    No. Boot Windows and repair that partition. If you are using W8, be sure
    to disable fast poweroff.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    I'm using W7. Can you be more specific about repairing that partition? Thanks.

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Automount Partitions at Startup

    Quote Originally Posted by CHAZDG51 View Post
    I'm using W7. Can you be more specific about repairing that partition? Thanks.
    Consider we do not normally attempt support for Windows. You most often need a Windows 7 boot disk which does include a repair function. Most problems relate to what is loaded in the MBR and what partition is marked active for booting.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •