Results 1 to 2 of 2

Thread: Removing Sayura (phonetic) input method and installing wijesekara sinhala layout for ibus and input

  1. #1
    Join Date
    Nov 2013
    Location
    Sri Lanka
    Posts
    4

    Default Removing Sayura (phonetic) input method and installing wijesekara sinhala layout for ibus and input

    I'm from srilanka and a long term opensuse user. I need to use wijesekara (m17n) input method to type in sinhala. former versions of opensuse provided the wijesekara layout as input method. but now it gives sayura sinhala input method which runs as phonetic. most of the srilankans knows how to use sinhala type writer with wijesekara layout. but, today I installed opensuse 13.1 and found that wijesekara layout is not there. iBus shows the wijesekara layout but it doesn't work and the " input method" only provides the phonetic input methods.
    does anyone can help me to install wijesekara layout on my opensuse 13.1?

  2. #2
    Join Date
    Nov 2013
    Location
    Sri Lanka
    Posts
    4

    Default Re: Removing Sayura (phonetic) input method and installing wijesekara sinhala layout for ibus and in

    Quote Originally Posted by roshanherath View Post
    I'm from srilanka and a long term opensuse user. I need to use wijesekara (m17n) input method to type in sinhala. former versions of opensuse provided the wijesekara layout as input method. but now it gives sayura sinhala input method which runs as phonetic. most of the srilankans knows how to use sinhala type writer with wijesekara layout. but, today I installed opensuse 13.1 and found that wijesekara layout is not there. iBus shows the wijesekara layout but it doesn't work and the " input method" only provides the phonetic input methods.
    does anyone can help me to install wijesekara layout on my opensuse 13.1?
    Removed sayura by suing software manager YaST GUI and opened iBus preferences. it showed to add

    export GTK_IM_MODULE=ibus
    export XMODIFIERS=@im=ibus
    export QT_IM_MODULE=ibus

    to $HOME/.bashrc

    but I found that .bashrc is inside the /etc folder.

    so I switched in to root on the Dolphin and added that above code in to end of the bashrc file and re-logged. it worked me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •