Results 1 to 9 of 9

Thread: wifi advice after 13.1 install

  1. #1

    Default wifi advice after 13.1 install

    I installed 13.1 on my laptop and as was advised by members of this forum (see my previous thread), now the wireless device is recognised.

    At the moment I have the following positive indicators:
    In hardware info: wirless LAN : yes

    Kernel driver is rtl8723ae

    firmware used (from boot.msg): "using firmware rtlwifi/rtl8723fw_B.bin"

    However, /usr/sbin/iwlist scan gives:

    wlp2s0 response given: interface doesn't support scanning : Network is down

    So it looks like the device is recognised and the firmware is fine, but still the network is down.

    What can I do?

    Thanks,

    Abe

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,828
    Blog Entries
    15

    Default Re: wifi advice after 13.1 install

    On Sat 23 Nov 2013 12:36:02 AM CST, naimab wrote:


    I installed 13.1 on my laptop and as was advised by members of this
    forum (see my previous thread), now the wireless device is recognised.

    At the moment I have the following positive indicators:
    In hardware info: wirless LAN : yes

    Kernel driver is rtl8723ae

    firmware used (from boot.msg): "using firmware rtlwifi/rtl8723fw_B.bin"

    However, /usr/sbin/iwlist scan gives:

    wlp2s0 response given: interface doesn't support scanning : Network is
    down

    So it looks like the device is recognised and the firmware is fine, but
    still the network is down.

    What can I do?

    Thanks,

    Abe


    Hi
    What about the output from the command rfkil list (you may need to
    install rfkill).

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.101-0.8-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: wifi advice after 13.1 install

    Quote Originally Posted by naimab View Post
    I installed 13.1 on my laptop and as was advised by members of this forum (see my previous thread), now the wireless device is recognized.

    At the moment I have the following positive indicators:
    In hardware info: wirless LAN : yes

    Kernel driver is rtl8723ae

    firmware used (from boot.msg): "using firmware rtlwifi/rtl8723fw_B.bin"

    However, /usr/sbin/iwlist scan gives:

    wlp2s0 response given: interface doesn't support scanning : Network is down

    So it looks like the device is recognised and the firmware is fine, but still the network is down.

    What can I do?

    Thanks,

    Abe
    Withe a new message thread you need to read through both of the following links:

    https://forums.opensuse.org/english/...less-work.html

    https://forums.opensuse.org/english/...d-do-next.html

    Post all relevant requested info from these links above in code # tags and confirm desktop being used.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: wifi advice after 13.1 install

    First, rfkill:

    Code:
    > rfkill list
    >
    >0: hci0: Bluetooth
    >            Soft blocked: no
    >            Hard blocked: no
    >1: phy0: wireless LAN
    >            Soft blocked: no
    >            Hard blocked: yes
    Also, as reported before:
    Code:
    >/usr/sbin/iwlist scan
    >
    >lo           Interface doesn't support scanning
    >
    >enp3s0f2 Interface doesn't support scanning
    >
    >wlp2s0    Interface doesn't support scanning : Network is down
    Following the other sticky post I get:
    Code:
    > /sbin/lspci
    >... 
    > 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter
    > 03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., LTD. Device 5289 (rev 01)
    > 03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)
    > ...
    Then:
    Code:
    > /sbin/lspci -n
    > ...
    > 02:00.0 0280: 10ec: 8723
    > 03:00.0 ff00: 10ec:5289 (rev 01)
    > 03:00.2 0200: 10ec: 8168 (rev 0a)
    Finally:
    Code:
    > /usr/sbin/iwconfig
    >
    >lo            no wireless extensions
    >
    >enp3s0f2  no wireless extensions
    >
    >wlp2s0     IEEE 802.11bgn  ESSID:off/any
    >               Mode:Managed Access Point: Not-associated  Tx-Power=off
    >               Retry long limit: 7   RTS thr=2347 B   Fragment thr:off
    >               Power Management:on
    I'm afraid I don't know what to make of this information.

    Please advise.

    Thanks,

    Abe

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: wifi advice after 13.1 install

    Quote Originally Posted by naimab View Post
    First, rfkill:

    Code:
    > rfkill list
    >
    >0: hci0: Bluetooth
    >            Soft blocked: no
    >            Hard blocked: no
    >1: phy0: wireless LAN
    >            Soft blocked: no
    >            Hard blocked: yes
    Also, as reported before:
    Code:
    >/usr/sbin/iwlist scan
    >
    >lo           Interface doesn't support scanning
    >
    >enp3s0f2 Interface doesn't support scanning
    >
    >wlp2s0    Interface doesn't support scanning : Network is down
    Following the other sticky post I get:
    Code:
    > /sbin/lspci
    >... 
    > 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter
    > 03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., LTD. Device 5289 (rev 01)
    > 03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)
    > ...
    Then:
    Code:
    > /sbin/lspci -n
    > ...
    > 02:00.0 0280: 10ec: 8723
    > 03:00.0 ff00: 10ec:5289 (rev 01)
    > 03:00.2 0200: 10ec: 8168 (rev 0a)
    Finally:
    Code:
    > /usr/sbin/iwconfig
    >
    >lo            no wireless extensions
    >
    >enp3s0f2  no wireless extensions
    >
    >wlp2s0     IEEE 802.11bgn  ESSID:off/any
    >               Mode:Managed Access Point: Not-associated  Tx-Power=off
    >               Retry long limit: 7   RTS thr=2347 B   Fragment thr:off
    >               Power Management:on
    I'm afraid I don't know what to make of this information.

    Please advise.

    Thanks,

    Abe
    I find that rtl8723ae may be the name of the kernel module. This is said to be supported since kernel 3.8 which missed openSUSE 12.3 but should work with openSUSE 13.1, but I have no idea if the module is enabled in the default kernel config. I have a bash script that can check all loaded modules. You could post your kernel module listing in code # tags.

    S.K.I.M. - SuSE Kernel Installed Modules - A lsmod replacement- Creates Alphabetized Module Listing - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: wifi advice after 13.1 install

    On 11/23/2013 01:56 PM, jdmcdaniel3 wrote:
    >
    > naimab;2600880 Wrote:
    >> First, rfkill:
    >>
    >>>

    > Code:
    > --------------------
    > > >
    > > > rfkill list
    > > >
    > > >0: hci0: Bluetooth
    > > > Soft blocked: no
    > > > Hard blocked: no
    > > >1: phy0: wireless LAN
    > > > Soft blocked: no
    > > > Hard blocked: yes

    > >
    > >

    > --------------------
    >>>

    >>
    >> Also, as reported before:
    >>>

    > Code:
    > --------------------
    > > >
    > > >/usr/sbin/iwlist scan
    > > >
    > > >lo Interface doesn't support scanning
    > > >
    > > >enp3s0f2 Interface doesn't support scanning
    > > >
    > > >wlp2s0 Interface doesn't support scanning : Network is down

    > >

    > --------------------
    >>>

    >>
    >> Following the other sticky post I get:
    >>>

    > Code:
    > --------------------
    > > >
    > > > /sbin/lspci
    > > >...
    > > > 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter
    > > > 03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., LTD. Device 5289 (rev 01)
    > > > 03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)
    > > > ...

    > >

    > --------------------
    >>>

    >>
    >> Then:
    >>>

    > Code:
    > --------------------
    > > >
    > > > /sbin/lspci -n
    > > > ...
    > > > 02:00.0 0280: 10ec: 8723
    > > > 03:00.0 ff00: 10ec:5289 (rev 01)
    > > > 03:00.2 0200: 10ec: 8168 (rev 0a)

    > >

    > --------------------
    >>>

    >>
    >> Finally:
    >>>

    > Code:
    > --------------------
    > > >
    > > > /usr/sbin/iwconfig
    > > >
    > > >lo no wireless extensions
    > > >
    > > >enp3s0f2 no wireless extensions
    > > >
    > > >wlp2s0 IEEE 802.11bgn ESSIDff/any
    > > > Mode:Managed Access Point: Not-associated Tx-Power=off
    > > > Retry long limit: 7 RTS thr=2347 B Fragment thrff
    > > > Power Managementn

    > >

    > --------------------
    >>>

    >>
    >> I'm afraid I don't know what to make of this information.
    >>
    >> Please advise.
    >>
    >> Thanks,
    >>
    >> Abe

    >
    > I find that rtl8723ae may be the name of the kernel module. This is
    > said to be supported since kernel 3.8 which missed openSUSE 12.3 but
    > should work with openSUSE 13.1, but I have no idea if the module is
    > enabled in the default kernel config. I have a bash script that can
    > check all loaded modules. You could post your kernel module listing in
    > code # tags.


    Yes, that is the name of the driver. At least one problem is the

    1: phy0: wireless LAN
    Soft blocked: no
    Hard blocked: yes

    That means that your wireless is turned off by the switch. How that is
    implemented will depend on your laptop-s hardware, but you will need to turn it on.


  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Thumbs up Re: wifi advice after 13.1 install

    Quote Originally Posted by lwfinger View Post
    On 11/23/2013 01:56 PM, jdmcdaniel3 wrote:
    >
    > naimab;2600880 Wrote:
    >> First, rfkill:
    >>
    >>>

    > Code:
    > --------------------
    > > >
    > > > rfkill list
    > > >
    > > >0: hci0: Bluetooth
    > > > Soft blocked: no
    > > > Hard blocked: no
    > > >1: phy0: wireless LAN
    > > > Soft blocked: no
    > > > Hard blocked: yes

    > >
    > >

    > --------------------
    >>>

    >>
    >> Also, as reported before:
    >>>

    > Code:
    > --------------------
    > > >
    > > >/usr/sbin/iwlist scan
    > > >
    > > >lo Interface doesn't support scanning
    > > >
    > > >enp3s0f2 Interface doesn't support scanning
    > > >
    > > >wlp2s0 Interface doesn't support scanning : Network is down

    > >

    > --------------------
    >>>

    >>
    >> Following the other sticky post I get:
    >>>

    > Code:
    > --------------------
    > > >
    > > > /sbin/lspci
    > > >...
    > > > 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter
    > > > 03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., LTD. Device 5289 (rev 01)
    > > > 03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)
    > > > ...

    > >

    > --------------------
    >>>

    >>
    >> Then:
    >>>

    > Code:
    > --------------------
    > > >
    > > > /sbin/lspci -n
    > > > ...
    > > > 02:00.0 0280: 10ec: 8723
    > > > 03:00.0 ff00: 10ec:5289 (rev 01)
    > > > 03:00.2 0200: 10ec: 8168 (rev 0a)

    > >

    > --------------------
    >>>

    >>
    >> Finally:
    >>>

    > Code:
    > --------------------
    > > >
    > > > /usr/sbin/iwconfig
    > > >
    > > >lo no wireless extensions
    > > >
    > > >enp3s0f2 no wireless extensions
    > > >
    > > >wlp2s0 IEEE 802.11bgn ESSIDff/any
    > > > Mode:Managed Access Point: Not-associated Tx-Power=off
    > > > Retry long limit: 7 RTS thr=2347 B Fragment thrff
    > > > Power Managementn

    > >

    > --------------------
    >>>

    >>
    >> I'm afraid I don't know what to make of this information.
    >>
    >> Please advise.
    >>
    >> Thanks,
    >>
    >> Abe

    >
    > I find that rtl8723ae may be the name of the kernel module. This is
    > said to be supported since kernel 3.8 which missed openSUSE 12.3 but
    > should work with openSUSE 13.1, but I have no idea if the module is
    > enabled in the default kernel config. I have a bash script that can
    > check all loaded modules. You could post your kernel module listing in
    > code # tags.


    Yes, that is the name of the driver. At least one problem is the

    1: phy0: wireless LAN
    Soft blocked: no
    Hard blocked: yes

    That means that your wireless is turned off by the switch. How that is
    implemented will depend on your laptop-s hardware, but you will need to turn it on.
    Hey good catch there Larry as that little switch is a killer. My old Dell laptop had that same switch going to off on me all of the time.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8

    Default Re: wifi advice after 13.1 install

    Yes, this switch was definitely it.

    I must admit that I had no idea it even existed until Larry pointed it out.
    Goes to show how little I know about laptops in general.

    So the initial problem was indeed 12.3 not supporting the built-in wifi, which was thankfully resolved when I went to 13.1, and the switch was the one extra thing that disabled wifi in practice.

    Thanks for all the advice and help.

    Abe

  9. #9
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: wifi advice after 13.1 install

    Quote Originally Posted by naimab View Post
    Yes, this switch was definitely it.

    I must admit that I had no idea it even existed until Larry pointed it out.
    Goes to show how little I know about laptops in general.

    So the initial problem was indeed 12.3 not supporting the built-in wifi, which was thankfully resolved when I went to 13.1, and the switch was the one extra thing that disabled wifi in practice.

    Thanks for all the advice and help.

    Abe
    Good to hear of your success. That kill switch got me more than once on my old Dell laptop and so it happens.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •