Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Citrix receiver not working

  1. #1

    Default Citrix receiver not working

    Hello,

    when trying to install citrix (both 32bit and 64bit) i get the following error :

    Code:
    Problem: ICAClient-13.0.0.256735-0.i386 requires libxerces-c-3.1.so, but this requirement cannot be provided
      uninstallable providers: libxerces-c-3_1-3.1.1-9.4.1.i586[_tmpRPMcache_]
                       libxerces-c-3_1-3.1.1-9.4.1.i586[repo-oss]
     Solution 1: Following actions will be done:
    the actions basically downgrade my os to 12.3

    My os is OpenSuse 13.1 64 bit

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,193
    Blog Entries
    1

    Default Re: Citrix receiver not working

    While waiting for help here, I suggest you also try obtaining support from Citrix:

    Support - Citrix

    I also note this bug report (which may or may not be of interest):

    https://bugzilla.novell.com/show_bug.cgi?id=849368

  3. #3

    Default Re: Citrix receiver not working

    Ok, i have managed to get it working (finnaly). Now i get the citrix receiver linux ssl error 61 when trying to access what i need. Followed

    [/CODE]sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/[/CODE]

    and then i tried

    Code:
    wget -P /usr/lib/ICAClient/keystore/cacerts--no-check-certificate https://certs.godaddy.com/repository/gd-class2-root.crt https://certs.godaddy.com/repository/gd_intermediate.crt https://certs.godaddy.com/repository/gd_cross_intermediate.crt


    still nothing, same error .

    And now i checked and i don't actually have an /usr/share/ca-certificates/mozilla/ . Should i create one ? Or the certificates ae stored in a different place ? Or Chrome, i don't rlly care which one i use as long as it works.

  4. #4

    Default Re: Citrix receiver not working

    followed this post here :

    https://forums.opensuse.org/english/...rror-61-a.html

    exported the certificate i need (GoDaddy one) into /opt/Citrix/ICAClient/keystore/cacerts/

    and nothing. Still the same error.

  5. #5

    Default Re: Citrix receiver not working

    exported manually all the certificates (took some time). Now it works !

  6. #6

    Default Re: Citrix receiver not working

    Quote Originally Posted by rbarsoianu View Post
    Ok, i have managed to get it working (finnaly). Now i get the citrix receiver linux ssl error 61 when trying to access what i need. Followed

    [/CODE]sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/[/CODE]

    and then i tried

    Code:
    wget -P /usr/lib/ICAClient/keystore/cacerts--no-check-certificate https://certs.godaddy.com/repository/gd-class2-root.crt https://certs.godaddy.com/repository/gd_intermediate.crt https://certs.godaddy.com/repository/gd_cross_intermediate.crt


    still nothing, same error .

    And now i checked and i don't actually have an /usr/share/ca-certificates/mozilla/ . Should i create one ? Or the certificates ae stored in a different place ? Or Chrome, i don't rlly care which one i use as long as it works.
    What did you do to fix it?

  7. #7

    Post Re: Citrix receiver not working

    Quote Originally Posted by stryker7176 View Post
    What did you do to fix it?
    Hi all,

    I got citrix receiver working on OpenSuse 13.1 by following this steps:

    1. I downloaded the ICAClient (ICAClient-13.0.0.256735-0.x86_64.rpm) from the citrix website. And I installed it by using command line (so just zypper install ...), then you'll get prompted that the dependencies are not ok (apparently I missed libxerces-3.1, but in fact I did not), so I just selected the option to ignore dependencies. That was all for the installation

    2. As mention in the previous post, '/usr/share/ca-certificates/mozilla' is not available anymore. So I made a symbolic link to the ssl certificates directory:

    Code:
    ln -s /etc/ssl/certs/* /opt/Citrix/ICAClient/keystore/cacerts/
    Now citrix should be working fine!

    Greetings,
    Timothy

  8. #8

    Default Re: Citrix receiver not working

    Quote Originally Posted by TimothyVD View Post
    Hi all,

    I got citrix receiver working on OpenSuse 13.1 by following this steps:

    1. I downloaded the ICAClient (ICAClient-13.0.0.256735-0.x86_64.rpm) from the citrix website. And I installed it by using command line (so just zypper install ...), then you'll get prompted that the dependencies are not ok (apparently I missed libxerces-3.1, but in fact I did not), so I just selected the option to ignore dependencies. That was all for the installation

    2. As mention in the previous post, '/usr/share/ca-certificates/mozilla' is not available anymore. So I made a symbolic link to the ssl certificates directory:

    Code:
    ln -s /etc/ssl/certs/* /opt/Citrix/ICAClient/keystore/cacerts/
    Now citrix should be working fine!

    Greetings,
    Timothy
    Hi all

    What I did to fix this was to download the 32 bit rmp of libxerces-c3.1 from opensuse, extract it NOT INSTALL IT and copy libxerces-c-3.1.so to /usr/lib/
    thats it, now everything works.

  9. #9

    Default Re: Citrix receiver not working

    Quote Originally Posted by TimothyVD View Post
    Hi all,

    I got citrix receiver working on OpenSuse 13.1 by following this steps:

    1. I downloaded the ICAClient (ICAClient-13.0.0.256735-0.x86_64.rpm) from the citrix website. And I installed it by using command line (so just zypper install ...), then you'll get prompted that the dependencies are not ok (apparently I missed libxerces-3.1, but in fact I did not), so I just selected the option to ignore dependencies. That was all for the installation

    2. As mention in the previous post, '/usr/share/ca-certificates/mozilla' is not available anymore. So I made a symbolic link to the ssl certificates directory:

    Code:
    ln -s /etc/ssl/certs/* /opt/Citrix/ICAClient/keystore/cacerts/
    Now citrix should be working fine!

    Greetings,
    Timothy

    Unfortunately, this didn't work for me. When I try to launch a citrix application via Firefox, it doesn't do anything. I verified that the plugin was installed in Firefox. Uninstalled Firefox, nspluginwrapper, and ICAclient, blew away .Mozilla folder, then re-installed, still no dice.

  10. #10

    Default Re: Citrix receiver not working

    Quote Originally Posted by stryker7176 View Post
    Unfortunately, this didn't work for me. When I try to launch a citrix application via Firefox, it doesn't do anything. I verified that the plugin was installed in Firefox. Uninstalled Firefox, nspluginwrapper, and ICAclient, blew away .Mozilla folder, then re-installed, still no dice.
    Hi stryker7176

    in Firefox under preferences--> Applicateions you have a setting for "Citric ica settings file" you then have two options "use wfica default" or " Use Citric Receiver for Linux"
    I have this set to use citrix receiver for linux and it works fine you can try changing those settings.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •