Results 1 to 5 of 5

Thread: The brightness controls (with Fn shortcuts) doesn't work after hibernation

  1. #1

    Exclamation The brightness controls (with Fn shortcuts) doesn't work after hibernation

    Hello,

    I have installed recently Opensuse 13.1. When I put my machine to hibernate, the brightness functions don't work when I recover the session.

    I have an AMD graphic card (HD5xxx) and I'm using the proprietary driver (beta). This is my configuration:

    Code:
    uname -a
    Linux Pascal.site 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    sudo /sbin/lspci
    00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
    00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
    00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
    00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
    00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
    00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
    00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 05)
    00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
    00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
    00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M]
    01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series]
    02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    03:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller
    03:00.1 System peripheral: Ricoh Co Ltd R5U2xx (R5U230 / R5U231 / R5U241) [Memory Stick Host Controller]
    03:00.4 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller
    04:00.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] (rev 11)
    3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
    3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
    3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
    3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
    3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    Code:
    fglrxinfo 
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 6500M/5600/5700 Series
    OpenGL version string: 4.3.12614 Compatibility Profile Context 13.20.16
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" quiet quiet resume=/dev/disk/by-id/ata-Hitachi_HTS545050B9SA00_110122PBN475M7EL0SWE-part5 splash=silent quiet showopts acpi_osi=Linux acpi_backlight=vendor pcie_aspm=force elevator=deadline i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 radeon.dpm=1"
    I appreciate any help.

    Best regards.

  2. #2

    Default Re: The brightness controls (with Fn shortcuts) doesn't work afterhibernation

    On 11/21/2013 11:46 AM, mikesol pecked at the keyboard and wrote:
    > Hello,
    >
    > I have installed recently Opensuse 13.1. When I put my machine to
    > hibernate, the brightness functions don't work when I recover the
    > session.
    >
    > I have an AMD graphic card (HD5xxx) and I'm using the proprietary
    > driver (beta). This is my configuration:
    >
    >
    >


    Many people are having the same problem with 13.1.

    Ken

  3. #3

    Default Re: The brightness controls (with Fn shortcuts) doesn't work afterhibernation

    Quote Originally Posted by kensch View Post
    Many people are having the same problem with 13.1.
    Ken
    The only workaround (?) that I found is changing the brightness in the AMD control center. I'd like a better solution.

    Regards.

  4. #4
    Join Date
    Jan 2012
    Location
    Sydney, Australia.
    Posts
    66

    Exclamation Re: The brightness controls (with Fn shortcuts) doesn't work after hibernation

    I have the same issue, did anyone find a workaround for this? Any help on this is appreciated.

    Thanks in advance,
    Hrudai.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,013
    Blog Entries
    1

    Default Re: The brightness controls (with Fn shortcuts) doesn't work after hibernation

    Quote Originally Posted by hrudaireddy View Post
    I have the same issue, did anyone find a workaround for this? Any help on this is appreciated.

    Thanks in advance,
    Hrudai.
    If using the proprietary driver, it might be a good idea to raise this issue with AMD

    http://www.amd.com/en-us/who-we-are/contact

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •