Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

  1. #1
    Join Date
    Jan 2009
    Location
    Saint Marys Georgia
    Posts
    78

    Default How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    I would like to not have my recent documents displayed in the main KDE menu. I know how to clear them but I would prefer to be able to stop them all together if at all possible. Does some one out there know of a way to remove the list entirely?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Quote Originally Posted by Argedion View Post
    I would like to not have my recent documents displayed in the main KDE menu. I know how to clear them but I would prefer to be able to stop them all together if at all possible. Does some one out there know of a way to remove the list entirely?
    Right click over the SUSE menu icon and pick "Application Launcher Menu Settings" were you can select what is displayed in your menu.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jan 2009
    Location
    Saint Marys Georgia
    Posts
    78

    Default Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Thanks

    Unfortunately that doesn't have anything about Recent Documents. I can change the icon in General and have Keyboard Shortcuts, and Share widgets.

  4. #4
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Normally I would expect this would be documented in the KDE help module but alas the body of the section is missing. hmmm.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  5. #5
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Ok, a little experimenting and I have managed to clear them.

    1) Select recent documents
    2) Right click anywhere in the recent docs area
    3) Select Clear Recent Documents

    Hope this helps
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Quote Originally Posted by anika200 View Post
    Ok, a little experimenting and I have managed to clear them.

    1) Select recent documents
    2) Right click anywhere in the recent docs area
    3) Select Clear Recent Documents

    Hope this helps
    I love to hear of success even if the user has to up with the fix. Thanks for sharing the procedure with us.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,143

    Default Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Quote Originally Posted by anika200 View Post
    Ok, a little experimenting and I have managed to clear them.

    1) Select recent documents
    2) Right click anywhere in the recent docs area
    3) Select Clear Recent Documents

    Hope this helps
    Sorry, but IMHO the OP clearly stated in his first post:
    I know how to clear them but I would prefer to be able to stop them all together
    Thus the above advice is of no use to the OP.
    Henk van Velden

  8. #8

    Default Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Quote Originally Posted by Argedion View Post
    Unfortunately that doesn't have anything about Recent Documents. I can change the icon in General and have Keyboard Shortcuts, and Share widgets.
    That only applies to the classic menu style.

    What you could do to prevent Recent Documents to be filled, is to remove write (or even read) permissions from the folder ~/.kde4/share/apps/RecentDocuments.
    Either with the file manager, navigate to ~/.kde4/share/apps/ (you have to enable "Show hidden files" for that), right-click on the RecentDocuments folder, select "Properties", switch to the "Permissions" tab, and set everything to "Can view content" or even "Forbidden".
    Or in Konsole:
    Code:
    chmod a-w ~/.kde4/share/apps/RecentDocuments
    or even
    Code:
    chmod a-rwx ~/.kde4/share/apps/RecentDocuments

  9. #9
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Quote Originally Posted by hcvv View Post
    Sorry, but IMHO the OP clearly stated in his first post:

    Thus the above advice is of no use to the OP.
    Whoops, not enough coffee to read properly yet.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  10. #10
    Join Date
    Jan 2009
    Location
    Saint Marys Georgia
    Posts
    78

    Default Re: How Would I Remove Recent Documents in KDE4 OpenSuse 12.3

    Quote Originally Posted by wolfi323 View Post
    That only applies to the classic menu style.

    What you could do to prevent Recent Documents to be filled, is to remove write (or even read) permissions from the folder ~/.kde4/share/apps/RecentDocuments.
    Either with the file manager, navigate to ~/.kde4/share/apps/ (you have to enable "Show hidden files" for that), right-click on the RecentDocuments folder, select "Properties", switch to the "Permissions" tab, and set everything to "Can view content" or even "Forbidden".
    Or in Konsole:
    Code:
    chmod a-w ~/.kde4/share/apps/RecentDocuments
    or even
    Code:
    chmod a-rwx ~/.kde4/share/apps/RecentDocuments

    Thanks much that did the trick it would seem. I made the permissions for owner forbidden and opened up a doc and then went and check and it showed nothing in there


    Thanks for all the help guys you rock

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •