Results 1 to 5 of 5

Thread: Citrix receiver not working

  1. #1

    Default Citrix receiver not working

    Hello,

    I'm trying to install citrix receiver on my pc, however i get a dependency error.

    Problem: ICAClient-13.0.0.256735-0.i386 requires libxerces-c-3.1.so, but this requirement cannot be provided

    I have installed the file from "http://software.opensuse.org/package/libxerces-c-3_1" but i still get same error.



    My system is OpenSuse 13.1 x64.

    Any help would be apreciated, i need Citrix for work related stuff.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,234

    Default Re: Citrix receiver not working

    On 11/17/2013 05:36 AM, rbarsoianu wrote:
    >
    > Hello,
    >
    > I'm trying to install citrix receiver on my pc, however i get a
    > dependency error.
    >
    > Problem: ICAClient-13.0.0.256735-0.i386 requires libxerces-c-3.1.so, but
    > this requirement cannot be provided
    >
    > I have installed the file from
    > "http://software.opensuse.org/package/libxerces-c-3_1" but i still get
    > same error.
    >
    >
    >
    > My system is OpenSuse 13.1 x64.
    >
    > Any help would be apreciated, i need Citrix for work related stuff.


    You have a mixed 32/64 bit problem. Clearly, the 64-bit version of libxerces
    cannot satisfy the requirements of the 32-bit version of ICAClient. I could not
    find a 64-bit version of the latter; however, you should be able to download
    http://download.opensuse.org/distrib...9.4.1.i586.rpm,
    and install it manually.



  3. #3

    Default Re: Citrix receiver not working

    I get the same error when trying to install it.

    Code:
    Problem: libkolabxml0-0.8.4-5.1.3.x86_64 requires libxerces-c-3.1.so()(64bit), but this requirement cannot be provided
      deleted providers: libxerces-c-3_1-3.1.1-24.1.x86_64
    uninstallable providers: libxerces-c-3_1-3.1.1-9.4.1.x86_64[repo-oss]
     Solution 1: Following actions will be done:
    I cannot paste the action,it is over the limit, it will basically downgrade my 13.1 to 12.1 or worse, my system won't be able to boot afterwards.

  4. #4

    Default Re: Citrix receiver not working

    Quote Originally Posted by rbarsoianu View Post
    I get the same error when trying to install it.

    Code:
    Problem: libkolabxml0-0.8.4-5.1.3.x86_64 requires libxerces-c-3.1.so()(64bit), but this requirement cannot be provided
      deleted providers: libxerces-c-3_1-3.1.1-24.1.x86_64
    uninstallable providers: libxerces-c-3_1-3.1.1-9.4.1.x86_64[repo-oss]
     Solution 1: Following actions will be done:
    I cannot paste the action,it is over the limit, it will basically downgrade my 13.1 to 12.1 or worse, my system won't be able to boot afterwards.
    Hi,

    I have same problem. Changing the architecture is not the solution here... Please see below.

    Code:
    # zypper in ./ICAClient-13.0.0.256735-0.x86_64.rpm 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: ICAClient-13.0.0.256735-0.x86_64 requires libxerces-c-3.1.so, but this requirement cannot be provided
      uninstallable providers: libxerces-c-3_1-3.1.1-9.4.1.i586[repo-oss]
     Solution 1: Following actions will be done:
      install libxerces-c-3_1-3.1.1-9.4.1.i586 despite the inferior architecture
      architecture change of libxerces-c-3_1-3.1.1-9.4.1.x86_64 to libxerces-c-3_1-3.1.1-9.4.1.i586
      architecture change of libkolabxml0-0.8.4-5.1.3.x86_64 to libkolabxml0-0.8.4-5.1.3.i586
      install libkolabxml0-0.8.4-5.1.3.i586 despite the inferior architecture
      architecture change of libkolab0-0.4.2-4.1.1.x86_64 to libkolab0-0.4.2-4.1.1.i586
      install libkolab0-0.4.2-4.1.1.i586 despite the inferior architecture
      install libakonadi4-4.11.3-50.6.i586 despite the inferior architecture
      install libkdepimlibs4-4.11.3-50.6.i586 despite the inferior architecture
      install libakonadiprotocolinternals1-1.10.3-4.1.i586 despite the inferior architecture
      install libprison0-1.0-12.1.2.i586 despite the inferior architecture
      install libqjson0-0.8.1-5.1.2.i586 despite the inferior architecture
    
    ............................................
    .............................................
    
    architecture change of libquazip1-0.5.1-2.1.3.x86_64 to libquazip1-0.5.1-2.1.3.i586
      architecture change of libmediastreamer_base3-2.9.0-3.1.1.x86_64 to libmediastreamer_base3-2.9.0-3.2.i586
      install libmediastreamer_base3-2.9.0-3.2.i586 (with vendor change)
        openSUSE  -->  http://packman.links2linux.de
      architecture change of libmediastreamer_voip3-2.9.0-3.1.1.x86_64 to libmediastreamer_voip3-2.9.0-3.2.i586
      install libmediastreamer_voip3-2.9.0-3.2.i586 (with vendor change)
        openSUSE  -->  http://packman.links2linux.de
      architecture change of libortp9-0.22.0-2.1.2.x86_64 to libortp9-0.22.0-2.1.2.i586
      architecture change of libmm-glib0-1.0.0-3.4.1.x86_64 to libmm-glib0-1.0.0-3.4.1.i586
      architecture change of libmysqlcppconn6-1.1.2-4.1.3.x86_64 to libmysqlcppconn6-1.1.2-4.1.3.i586
      architecture change of libmythes-1_2-0-1.2.3-5.1.2.x86_64 to libmythes-1_2-0-1.2.3-5.1.2.i586
     Solution 2: do not install ICAClient-13.0.0.256735-0.x86_64
     Solution 3: break ICAClient-13.0.0.256735-0.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c):

  5. #5

    Default Re: Citrix receiver not working

    Note: I just made a test with the old Citrix Receiver ICAClient_12.1.0-0.x86_64.rpm. It works without problems... Upgrading to version 13.0 failed with the same error messages... I plan to use the old version until Citrix fixes version 13.0.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •