Results 1 to 9 of 9

Thread: Kaffeine doesn't work

  1. #1

    Default Kaffeine doesn't work

    Hi Guys,

    I have
    openSUSE 12.3 (x86_64)
    VERSION = 12.3
    CODENAME = Dartmouth

    On attempt to start some video file. e.g.: *.mkv or .mp4 I got this:
    http://s7.postimg.org/qiksb9sob/snapshot3.png

    Only black screen and this thing is gray and unavailable:
    http://s22.postimg.org/59san48kt/snapshot4.png

    I spent a lot of time trying to find the solution. I installed millions of codecs and players. VLC and SMPlayer works fine but not Kaffeine.
    This one is configured as default player and I like interface of Kaffeine. Other players doesn't load files to playlist automatically from current folder. It has usual shortcuts for me. And other stuff.

    BTW where is the settings of Kaffeine what codecs to use and others? Is there log. I assume I can find some error message.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,415

    Default Re: Kaffeine doesn't work

    Kaffeine uses the codecs which you can download through the Multimedia in One-click facility (http://opensuse-community.org/Restricted_formats) - if you had gone to the Multimedia page, you would have found it.

  3. #3

    Default Re: Kaffeine doesn't work

    I installed the codecs, but it didn't help. It seems to be some other problem. Because when I ran Kaffeine first time it said "no codecs". I don't get pop-up "no codecs" now but the video-files are not played.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Kaffeine doesn't work

    Please check this
    https://forums.opensuse.org/blogs/ca...ion-guide-126/

    I use smplayer - it just works
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Kaffeine doesn't work

    First, Kaffeine uses libxine2 so make sure you have libxine2-codecs installed.

    Then, what gfx card and driver are you using?
    Maybe xine tries to use a video output module that doesn't work on your system.
    VAAPI can cause problems with radeon cards, so you should install something like libvdpau_r600 (depending on you card of course) so that xine can use VDPAU instead.

    What output do you get when you run Kaffeine in a terminal window?

    You can try to explicitely set a different output module in the file ~/.kde4/share/apps/kaffeine/xine-config, search for a line containing this and change it accordingly: (remove the leading '#' for it to have effect)
    Code:
    #video.driver:auto
    F.e. try:
    Code:
    video.driver:xshm
    You can also try xine-ui, that one has a GUI for setting all the options (you have to increase the "experience level" though on the "gui" tab to have the video driver setting appear). The resulting config file can be used with Kaffeine as well, just copy it over:
    Code:
    cp ~/.xine/config ~/.kde4/share/apps/kaffeine/xine-config
    Or create a symlink, then xine's and Kaffeine's settings are completely in sync:
    Code:
    ln -sf ~/.xine/config ~/.kde4/share/apps/kaffeine/xine-config

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Kaffeine doesn't work

    On 2013-11-15 09:26, wolfi323 wrote:
    >
    > First, Kaffeine uses libxine2 so make sure you have libxine2-codecs
    > installed.


    Run "xine-check" in a terminal. But don't trust it much.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7

    Default Re: Kaffeine doesn't work

    Thank you, Guys, for your answers.

    Quote Originally Posted by caf4926 View Post
    Please check this
    https://forums.opensuse.org/blogs/ca...ion-guide-126/

    I use smplayer - it just works
    Already checked. Doesn't help.


    wolfi323
    I ran Kaffeine from terminal:
    Code:
    loco@digitalG:~> kaffeine
    loco@digitalG:~> "/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A120G_50026B7738009388" : property "Drive" does not exist 
    "/org/freedesktop/UDisks2/drives/Floppy_Drive" : property "Drive" does not exist 
    "/org/freedesktop/UDisks2/drives/WDC_WD5000AACS_00G8B1_WD_WCAUK0771585" : property "Drive" does not exist 
    "/org/freedesktop/UDisks2/block_devices/fd0" : property "Name" does not exist 
    "/org/freedesktop/UDisks2/drives/Floppy_Drive" : property "DeviceNumber" does not exist 
    "/org/freedesktop/UDisks2/drives/Floppy_Drive" : property "Device" does not exist 
    "/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A120G_50026B7738009388" : property "DeviceNumber" does not exist 
    "/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A120G_50026B7738009388" : property "Device" does not exist 
    "/org/freedesktop/UDisks2/drives/WDC_WD5000AACS_00G8B1_WD_WCAUK0771585" : property "DeviceNumber" does not exist 
    "/org/freedesktop/UDisks2/drives/WDC_WD5000AACS_00G8B1_WD_WCAUK0771585" : property "Device" does not exist 
    Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
    vo_vdpau: Can't create vdp device : No vdpau implementation.
    libva info: VA-API version 0.33.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/fglrx_drv_video.so
    libva info: va_openDriver() returns -1
    Looks like I have a problem with libvdpau. I installed libvdpau_r600, but no result. Also I have libvdpau1


    I don't have ~/.kde4/share/apps/kaffeine folder. There is only ~/.kde4/share/apps/kconf_update


    My xine doesn't start
    Code:
    loco@digitalG:~> xine
    xine: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory
    loco@digitalG:~> xine
    xine: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory
    loco@digitalG:~> xine
    xine: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory
    I'm not lucky

  8. #8

    Default Re: Kaffeine doesn't work

    Quote Originally Posted by PaintedRed View Post
    wolfi323
    I ran Kaffeine from terminal:
    Code:
    loco@digitalG:~> kaffeine
    loco@digitalG:~>
    ...
    Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
    vo_vdpau: Can't create vdp device : No vdpau implementation.
    libva info: VA-API version 0.33.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/fglrx_drv_video.so
    libva info: va_openDriver() returns -1
    Looks like I have a problem with libvdpau. I installed libvdpau_r600, but no result. Also I have libvdpau1
    So what gfx card do you have?

    Kaffeine/xine tries to use VAAPI but fails.

    Apparently you have the fglrx driver installed, right?
    Then libvdpau_r600 won't work AFAIK.

    I don't have ~/.kde4/share/apps/kaffeine folder. There is only ~/.kde4/share/apps/kconf_update
    Well, just create that folder and the file xine-config in there with the content I suggested.

    My xine doesn't start
    Code:
    loco@digitalG:~> xine
    xine: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory
    loco@digitalG:~> xine
    xine: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory
    loco@digitalG:~> xine
    xine: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory
    You seem to have xine-ui from an older openSUSE version (12.2 maybe?).
    Install the one from 12.3:
    Code:
    sudo zypper in -f xine-ui-0.99.7-5.1.2
    Then it should work.

    And maybe post your repo list, because with the correct repos you shouldn't have that older version.
    Code:
    zypper lr -d

  9. #9

    Default Re: Kaffeine doesn't work

    I don't know how but I successfully installed Kaffeine 0.8.8 (Kaffeine which is not working is 1.2.2) and it works.
    I checked the repos and found out that my packman repo is old. I updated the repo.
    I think the issue is solved, I don't want to mess with it further.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •