Hi,

I'm new to openSuSE and linux in general and have been given the task of setting up a server running openSuSe 12.3 in a XenServer environment. I am unable to get the KDE GUI to run, when I use the startkde command I get the following error:

$DISPLAY is not set or cannot connect to the X server.

When I use the startx command I get the following in the logs:

X.Org X Server 1.13.2
Release Date: 2013-01-24
[ 3182.228] X Protocol Version 11, Revision 0
[ 3182.228] Build Operating System: openSUSE SUSE LINUX
[ 3182.228] Current Operating System: Linux linux-yb5u.site 3.7.10-1.1-xen #1 SMP Thu Feb 28 15:06:29 UTC 2013 (82d3f21) x86_64
[ 3182.228] Kernel command line: root=/dev/xvda2 console=ttyS0 xencons=ttyS maxcpus=1 resume=/dev/xvda1 splash=silent quiet showopts console=ttyS0 xencons=ttyS
[ 3182.229] Build Date: 21 February 2013 10:01:18AM
[ 3182.229]
[ 3182.229] Current version of pixman: 0.28.2
[ 3182.229] Before reporting problems, check xorg
to make sure that you have the latest version.
[ 3182.229] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 3182.230] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 14 15:39:52 2013
[ 3182.231] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 3182.231] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 3182.233] (==) No Layout section. Using the first Screen section.
[ 3182.233] (==) No screen section available. Using defaults.
[ 3182.233] (**) |-->Screen "Default Screen Section" (0)
[ 3182.233] (**) | |-->Monitor "<default monitor>"
[ 3182.233] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 3182.234] (==) Automatically adding devices
[ 3182.234] (==) Automatically enabling devices
[ 3182.234] (==) Automatically adding GPU devices
[ 3182.234] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[ 3182.234] Entry deleted from font path.
[ 3182.234] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/ghostscript/,
/usr/share/fonts/cyrillic:unscaled,
/usr/share/fonts/truetype/,
built-ins
[ 3182.234] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
[ 3182.234] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 3182.234] (II) Loader magic: 0x801c20
[ 3182.234] (II) Module ABI versions:
[ 3182.234] X.Org ANSI C Emulation: 0.4
[ 3182.234] X.Org Video Driver: 13.1
[ 3182.234] X.Org XInput driver : 18.0
[ 3182.234] X.Org Server Extension : 7.0
[ 3182.235] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 3182.235] Initializing built-in extension Generic Event Extension
[ 3182.235] Initializing built-in extension SHAPE
[ 3182.235] Initializing built-in extension MIT-SHM
[ 3182.235] Initializing built-in extension XInputExtension
[ 3182.236] Initializing built-in extension XTEST
[ 3182.236] Initializing built-in extension BIG-REQUESTS
[ 3182.236] Initializing built-in extension SYNC
[ 3182.236] Initializing built-in extension XKEYBOARD
[ 3182.236] Initializing built-in extension XC-MISC
[ 3182.236] Initializing built-in extension SECURITY
[ 3182.236] Initializing built-in extension XINERAMA
[ 3182.236] Initializing built-in extension XFIXES
[ 3182.236] Initializing built-in extension RENDER
[ 3182.237] Initializing built-in extension RANDR
[ 3182.237] Initializing built-in extension COMPOSITE
[ 3182.237] Initializing built-in extension DAMAGE
[ 3182.237] Initializing built-in extension MIT-SCREEN-SAVER
[ 3182.237] Initializing built-in extension DOUBLE-BUFFER
[ 3182.237] Initializing built-in extension RECORD
[ 3182.237] Initializing built-in extension DPMS
[ 3182.237] Initializing built-in extension X-Resource
[ 3182.237] Initializing built-in extension XVideo
[ 3182.237] Initializing built-in extension XVideo-MotionCompensation
[ 3182.238] Initializing built-in extension XFree86-VidModeExtension
[ 3182.238] Initializing built-in extension XFree86-DGA
[ 3182.238] Initializing built-in extension XFree86-DRI
[ 3182.238] Initializing built-in extension DRI2
[ 3182.238] (II) "glx" will be loaded by default.
[ 3182.238] (II) LoadModule: "dri2"
[ 3182.238] (II) Module "dri2" already built-in
[ 3182.238] (II) LoadModule: "glamoregl"
[ 3182.240] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[ 3182.246] (II) Module glamoregl: vendor="X.Org Foundation"
[ 3182.246] compiled for 1.13.2, module version = 0.5.0
[ 3182.247] ABI class: X.Org ANSI C Emulation, version 0.4
[ 3182.247] (II) LoadModule: "glx"
[ 3182.248] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 3182.249] (II) Module glx: vendor="X.Org Foundation"
[ 3182.249] compiled for 1.13.2, module version = 1.0.0
[ 3182.249] ABI class: X.Org Server Extension, version 7.0
[ 3182.249] (==) AIGLX enabled
[ 3182.249] Loading extension GLX
[ 3182.249] (==) Matched modesetting as autoconfigured driver 0
[ 3182.249] (==) Matched fbdev as autoconfigured driver 1
[ 3182.249] (==) Matched vesa as autoconfigured driver 2
[ 3182.249] (==) Assigned the driver to the xf86ConfigLayout
[ 3182.250] (II) LoadModule: "modesetting"
[ 3182.251] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 3182.251] (II) Module modesetting: vendor="X.Org Foundation"
[ 3182.251] compiled for 1.13.1, module version = 0.6.0
[ 3182.252] Module class: X.Org Video Driver
[ 3182.252] ABI class: X.Org Video Driver, version 13.1
[ 3182.252] (II) LoadModule: "fbdev"
[ 3182.253] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 3182.253] (II) Module fbdev: vendor="X.Org Foundation"
[ 3182.253] compiled for 1.13.1, module version = 0.4.3
[ 3182.254] Module class: X.Org Video Driver
[ 3182.254] ABI class: X.Org Video Driver, version 13.1
[ 3182.254] (II) LoadModule: "vesa"
[ 3182.255] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 3182.255] (II) Module vesa: vendor="X.Org Foundation"
[ 3182.255] compiled for 1.13.1, module version = 2.3.2
[ 3182.256] Module class: X.Org Video Driver
[ 3182.256] ABI class: X.Org Video Driver, version 13.1
[ 3182.256] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 3182.256] (II) FBDEV: driver for framebuffer: fbdev
[ 3182.256] (II) VESA: driver for VESA chipsets: vesa
[ 3182.256] (--) using VT number 2


[ 3182.256] (WW) Falling back to old probe method for modesetting
[ 3182.257] (EE) open /dev/dri/card0: No such file or directory
[ 3182.257] (WW) Falling back to old probe method for fbdev
[ 3182.257] (II) Loading sub module "fbdevhw"
[ 3182.257] (II) LoadModule: "fbdevhw"
[ 3182.258] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 3182.258] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 3182.258] compiled for 1.13.2, module version = 0.0.2
[ 3182.258] ABI class: X.Org Video Driver, version 13.1
[ 3182.258] (EE) open /dev/fb0: No such file or directory
[ 3182.258] (WW) Falling back to old probe method for vesa
[ 3182.258] (EE) No devices detected.
[ 3182.259]
Fatal server error:
[ 3182.259] no screens found
[ 3182.259] (EE)
Please consult the The X.Org Foundation support
at xorg
for help.
[ 3182.259] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 3182.260] (EE)








Any help would be greatly appreciated.