Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Installation of 13.1: hangs at the very beginning; no options available

  1. #1

    Question Installation of 13.1: hangs at the very beginning; no options available

    Hi,

    I try installing 13.1 with the DVD image and the Network image on USB stick. The stick seems to boot correctly, however, I have only three entries available: Install, Rescue System and Check Install Medium (or similar names), no further options as described in several guides... With all three options, the system tries to start but it hangs after couple of seconds, probably when trying to start X. I have to shut down the system manually.

    The images were correct, I checked the md5 sum, and were written using the SUSE image writer.

    Currently, 12.3 is installed (no problem with this installation) on my system but I want to do a fresh install not an upgrade. My system uses UEFI, Windows 8 is installed. Furthermore, it has Intel and NVIDIA graphics using Optimus.

    Any idea how to further debug or start text mode installation?

    Thanks

  2. #2

    Default AW: Installation of 13.1: hangs at the very beginning; no options available

    Quote Originally Posted by sebschub View Post
    I try installing 13.1 with the DVD image and the Network image on USB stick. The stick seems to boot correctly, however, I have only three entries available: Install, Rescue System and Check Install Medium (or similar names), no further options as described in several guides... With all three options, the system tries to start but it hangs after couple of seconds, probably when trying to start X. I have to shut down the system manually.

    The images were correct, I checked the md5 sum, and were written using the SUSE image writer.

    Currently, 12.3 is installed (no problem with this installation) on my system but I want to do a fresh install not an upgrade. My system uses UEFI, Windows 8 is installed. Furthermore, it has Intel and NVIDIA graphics using Optimus.

    Any idea how to further debug or start text mode installation?
    Press 'e' at the boot screen when "Install" is selected, you can change the boot options then.
    Try to append "nomodeset" to the line starting with "linux", that should help if its gfx driver related.
    Press 'F10' to boot/start the installation then.

    PS: Not sure if this applies on an optimus system as well, but the latest release notes contain this entry:
    Code:
    5.2. Garbage on the Screen During Installation with the Nouveau Driver
    
    On some systems with NVIDIA cards, the installer may show garbage on the
    top part of the screen due to problems with the default nouveau driver. If
    you are affected by this problem, you can disable the nouveau kernel module
    to run the installer and then enable it again once the system is installed
    or upgraded.
    
    
    To disable the kernel module, once you boot from the installation media,
    select the 'Installation' entry in grub and press 'e' to edit the
    parameters. Then go to the line starting with 'linux' (or 'linuxefi') and
    add brokenmodules=nouveau at the end. Now press F10 to continue booting
    with the new parameter. After the system is installed, you can re-enable
    the nouveau module by editing /etc/modprobe.d/50-blacklist.conf and
    removing the entry that blacklists nouveau.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,503
    Blog Entries
    3

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    Quote Originally Posted by sebschub View Post
    The stick seems to boot correctly, however, I have only three entries available: Install, Rescue System and Check Install Medium (or similar names), no further options as described in several guides...
    This is typical of a boot on a UEFI box. You might want to look at Bug 822769 which requests that a 4th option (boot with "nomodeset" be added). In the meantime, try what Wolfi323 suggested.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    Thank you, that worked!

  5. #5

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    Well, while nomodeset works and seems to be used by default now also after the installation, 3d acceleration with Intel drivers does not work. Without nomodeset, the error is back again (nouveau is blacklisted).

    How can I debug this problem? /var/log/messages does not seem to get information (I guess the issue is too early).

    Thanks!

  6. #6

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    Quote Originally Posted by sebschub View Post
    Well, while nomodeset works and seems to be used by default now also after the installation, 3d acceleration with Intel drivers does not work.
    Of course. With "nomodeset" you effectively prevent the intel driver from being used.

    Maybe try install the newer intel driver from here, some crashes have been fixed there: (will be released as online update soon)
    Index of /repositories/home:/sumski:/bnc847762/openSUSE_13.1

    After installing that, try to boot without "nomodeset" and see if it works then.

  7. #7
    Join Date
    Nov 2013
    Posts
    11

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    I am having the same issue as the OP and I added the option "nomodeset" and still received the same error. Where do I go from here? My computer is a Lenovo S230u Thinkpad Twist.
    Thanks

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,144
    Blog Entries
    2

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    Another try which worked successfully on my machine...

    When you load your install media, you will arrive at a screen that says

    Installation
    Rescue
    Test Firmware
    Test RAM

    At the bottom, it says to press "F3" to choose alternate video options.
    Try "No KMS" first. According to the 13.1 Release Notes, this is similar to, but <not exactly> the same as "nomodeset" so is worth a try.

    That worked for me.
    Then, after the full installation later on you can go into YAST > Sysconfig editor and turn KMS back on (set NO_KMS_IN_INITRD to "no")

    Or, if even that setting fails you can choose the "TEXT" option to enter text mode.

    The hardware this worked on
    i7-4700MQ HD 4600

    HTH,
    TSU

  9. #9

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    Quote Originally Posted by wolfi323 View Post
    Of course. With "nomodeset" you effectively prevent the intel driver from being used.

    Maybe try install the newer intel driver from here, some crashes have been fixed there: (will be released as online update soon)
    Index of /repositories/home:/sumski:/bnc847762/openSUSE_13.1

    After installing that, try to boot without "nomodeset" and see if it works then.
    Thanks for the hint, it does not solve my issue, though. As far as I can see, the repository you listed includes an X driver, i.e. it is used when X starts. My crash, however, happens right after starting openSUSE. So it may be connected to the fancy high resolution terminal? Framebuffer? So is it an issue of the kernel? (just throwing uneducated guesses here)

  10. #10

    Default Re: Installation of 13.1: hangs at the very beginning; no options available

    Quote Originally Posted by sebschub View Post
    Thanks for the hint, it does not solve my issue, though. As far as I can see, the repository you listed includes an X driver, i.e. it is used when X starts. My crash, however, happens right after starting openSUSE. So it may be connected to the fancy high resolution terminal? Framebuffer? So is it an issue of the kernel? (just throwing uneducated guesses here)
    Well, you wrote this in the first post:
    With all three options, the system tries to start but it hangs after couple of seconds, probably when trying to start X.
    That's why I suggested the newer X driver.

    Of course it could be the intel kernel driver that causes the hang. "nomodeset" prevents that one from being loaded (which then also forces another X driver as a consequence).

    You could also try to disable plymouth (the boot splash), this has caused problems for some people in the past. Add this to the kernel options instead of "nomodeset":
    Code:
    plymouth.enable=0

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •