Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: 20131030 Software update causes KDE (X?) to crash using openSuSE 12.3

  1. #11
    Join Date
    Aug 2009
    Location
    Esslingen, Germany
    Posts
    7

    Default Re: 20131030 Software update causes KDE (X?) to crash using openSuSE 12.3

    A temporary workaround for vmware (not a fix!): Disable "accelerated 3d graphics" in the vm's configuration (vmx file). Then you can start the vm without a crash, but with lower graphics quality. Greetings, Thommie

  2. #12
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 20131030 Software update causes KDE (X?) to crash using openSuSE12.3

    On 2013-11-13 14:06, drfoster wrote:
    >
    > robin_listas;2597455 Wrote:
    >> On 2013-11-12 21:36, drfoster wrote:
    >> I noticed that you are using the nvidia proprietary driver. This means
    >> that the devs may reject to look at your report because of that.
    >>
    >> You might try a different version of the driver. :-?
    >>

    >
    > I have since upgraded to the latest Nvidia drivers (the Nvidia server
    > settings application reports driver version 331.20.) I made no
    > difference.


    Pity :-(

    > I use the proprietary drivers because when I installed openSuSE 12.3,
    > the Nvidia drivers installed with it would not boot into graphics mode.
    > Immediately upon installing the proprietary drivers, graphics mode
    > worked. I've stayed with them ever since.


    Oh, I agree, but proprietary drivers means no support from open source
    devs. "tainted" code. It is unfortunate. Mind, I say "may happen", it is
    up to them.

    If the issue was duplicated on vmware virtual hardware, that has more
    chances.

    You say the crash is with KDE. You might try other desktops: lxde,
    xfce... they don't use "high power" video features.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #13

    Default Re: 20131030 Software update causes KDE (X?) to crash using openSuSE 12.3

    Based on a hint from thommierother in the bug, there are work arounds for both VMware and Chrome. If you disable "3d accelerated graphics" in the settings of the VMs you run, they will run fine without causing the crash. Also, if you disable Chrome's "Use hardware acceleration when available" feature (Chrome -> Settings -> Advanced -> ...toward the bottom... and restart Chrome), it can then access the GWT web applications that were crashing without a problem.

    The problem here is related to accelerated graphics.

  4. #14

    Default Re: 20131030 Software update causes KDE (X?) to crash using openSuSE12.3

    Quote Originally Posted by robin_listas View Post
    You say the crash is with KDE. You might try other desktops: lxde,
    xfce... they don't use "high power" video features.
    The crash is NOT KDE related. As an additional test, I logged in using Gnome and was able to duplicate the same problem.

  5. #15
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 20131030 Software update causes KDE (X?) to crash using openSuSE12.3

    On 2013-11-13 17:06, drfoster wrote:
    >
    > robin_listas;2597520 Wrote:
    >>
    >> You say the crash is with KDE. You might try other desktops: lxde,
    >> xfce... they don't use "high power" video features.
    >>

    >
    > The crash is NOT KDE related. As an additional test, I logged in using
    > Gnome and was able to duplicate the same problem.


    Both kde and gnome use heavy features of the video driver, like 3D or
    acceletariont. I think that xfce and lxde do not. It would not solve
    your problem if they work, but it would allow you to use your computer
    at least.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #16

    Default Re: 20131030 Software update causes KDE (X?) to crash using openSuSE12.3

    Quote Originally Posted by robin_listas View Post
    Both kde and gnome use heavy features of the video driver, like 3D or
    acceletariont. I think that xfce and lxde do not. It would not solve
    your problem if they work, but it would allow you to use your computer
    at least.
    Thanks for the suggestion, but for now at least, disabling the accelerated graphics in VMware and Chrome allow me to do everything I need from KDE.

  7. #17

    Default Re: 20131030 Software update causes KDE (X?) to crash using openSuSE 12.3

    For anybody that's curious, I upgraded my 12.3 machine to 13.1 and this particular problem went away. I was able to enable all hardware acceleration settings (in VMware and Chrome) and things work without issue.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •