Results 1 to 6 of 6

Thread: suse 12.3:Can't login on runlevel 3, trying to install Nvidia driver

  1. #1

    Default suse 12.3:Can't login on runlevel 3, trying to install Nvidia driver

    Hi, complete n00b here! Fresh install of 12.3, Gnome, kernel 3.7.16, 64 bit (what else do I put here??!)

    Previously with this graphics card, I had installed the Nvidia driver the "hard way" (SDB:NVIDIA the hard way - openSUSE) when I had 11.3 installed on my other drive. That is my goal here. However, I cannot login to runlevel 3. When at runlevel 5, I typed as root "init 3", the terminal just returned. So I tried to add "3" to grub2 menu. I was able to login as my username and I tried to install the nvidia driver, however I got an error something like "X still running". However, now I cannot login to the Desktop or recover mode. If I type ctrl+alt+F1, I get the "doing fast boot, creating device nodes with udev, fatal: error inserting nouvea no such device" and then "welcome to openSUSE 12.3, login: " and when I type my username or root, it just returns to "login".

    Any suggestions?

    P.S. I have yet to figure out how to put in screenshots or anything. Thanks for your patience.

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: suse 12.3:Can't login on runlevel 3, trying to install Nvidiadriver

    On Mon, 11 Nov 2013 16:56:01 +0000, gradstudent wrote:

    > P.S. I have yet to figure out how to put in screenshots or anything.
    > Thanks for your patience.


    Someone else will be by to help you with the issue you're having
    (offhand, I don't have any ideas on what to check other than to boot in
    single user mode and see if you can login there.

    For screenshots - http://susepaste.org

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: suse 12.3:Can't login on runlevel 3, trying to install Nvidia driver

    Quote Originally Posted by gradstudent View Post
    Hi, complete n00b here! Fresh install of 12.3, Gnome, kernel 3.7.16, 64 bit (what else do I put here??!)

    Previously with this graphics card, I had installed the Nvidia driver the "hard way" (SDB:NVIDIA the hard way - openSUSE) when I had 11.3 installed on my other drive. That is my goal here. However, I cannot login to runlevel 3. When at runlevel 5, I typed as root "init 3", the terminal just returned. So I tried to add "3" to grub2 menu. I was able to login as my username and I tried to install the nvidia driver, however I got an error something like "X still running". However, now I cannot login to the Desktop or recover mode. If I type ctrl+alt+F1, I get the "doing fast boot, creating device nodes with udev, fatal: error inserting nouvea no such device" and then "welcome to openSUSE 12.3, login: " and when I type my username or root, it just returns to "login".

    Any suggestions?

    P.S. I have yet to figure out how to put in screenshots or anything. Thanks for your patience.
    To log into runlevel 3: How to Start openSUSE 12.3 with Grub 2 into Run Level 3 - Blogs - openSUSE Forums

    To install driver the hardway: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: suse 12.3:Can't login on runlevel 3, trying to install Nvidia driver

    Thanks for your responses. I think I have narrowed down my problem:

    ~> uname -r
    3.7.10-1.1-desktop

    ~> rpm -qa | grep kernel
    kernel-desktop-devel-3.7.10-1.16.1.x86_64
    patterns-openSUSE-devel_kernel-12.3-7.10.1.x86_64
    kernel-devel-3.7.10-1.16.1.noarch
    kernel-source-3.7.10-1.16.1.noarch
    kernel-desktop-3.7.10-1.1.1.x86_64
    kernel-syms-3.7.10-1.16.1.x86_64
    kernel-default-devel-3.7.10-1.16.1.x86_64
    kernel-xen-devel-3.7.10-1.16.1.x86_64
    If I uninstall (through the yast gui) the patterns one and get the patch for kernel-desktop, then will I reboot into 3.7.10-1.16.1?

  5. #5

    Default Re: suse 12.3:Can't login on runlevel 3, trying to install Nvidia driver

    That was the problem! My screen looks beautiful.

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: suse 12.3:Can't login on runlevel 3, trying to install Nvidia driver

    Quote Originally Posted by gradstudent View Post
    That was the problem! My screen looks beautiful.
    Happy to hear of your success and for sharing it with it.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •