Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: I can't get wine to run (attempting to use Foxit)

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default I can't get wine to run (attempting to use Foxit)

    Hi,

    I'm trying:

    [CODE]
    > cer@Telcontar:~> wine ~/Downloads/Firefox_downloads/FoxitReader611.1031_enu_Setup.exe
    > wine: created the configuration directory '/home/cer/.wine'

    [CODE]

    I get a popup that reads:

    ̣̣̣̣̣+++·······························
    Wine Mono Installer
    Wine could not find a Mono package which is needed for .NET applications
    to work correctly. Wine can automatically download and install it for you.

    Note: it is recomended to use your distribution packages instead. See
    http://wiki.winehq.org/Mono for details.
    ̣̣̣̣̣·······························++-

    I read that page, and I do not see a list of what is needed. I have
    installed via YaST mono, but I still get the same error. I have no idea
    what is missing.

    If I hit "cancel", and I isntall all mono packages I can think of. Then
    try again, get same dialog, but this time with "cancel" wine continues
    and foxit install dialog appears. I proceed with the installation, and
    later I get this other dialog error near the end:

    ̣̣̣̣̣+++·······························
    CProgram Files (x86)\Foxit Software\foxit
    Reader\Plugind\Convert\ToPDFShellExtension_x64.dll

    Unable to register DLL/OCX:RegSvr32 failed with code 0x1

    Click retry to try again, Ignore to proceed anyway (not recommended) or
    Abort to cancel installation.
    ̣̣̣̣̣·······························++-

    Ignore pops up same message for another addin, and then another. But
    apparently Foxit runs... I still have to see how to open local (Linux)
    files, I see no samples. I have to leave now.

    Code:
    Telcontar:~ # zypper ps
    No processes using deleted files found.
    Telcontar:~ # rpm -qa | grep -i mono
    mono-zeroconf-provider-avahi-0.9.0-16.1.1.noarch
    libmonosgen-2_0-devel-3.0.4-1.4.1.x86_64
    mono-addins-0.6.2-7.2.1.noarch
    mono-winfxcore-3.0.4-1.4.1.x86_64
    mono-winforms-3.0.4-1.4.1.x86_64
    dbus-1-mono-0.63-206.1.1.x86_64
    mono-data-3.0.4-1.4.1.x86_64
    libmono-2_0-devel-3.0.4-1.4.1.x86_64
    libmono-2_0-1-3.0.4-1.4.1.x86_64
    mono-core-3.0.4-1.4.1.x86_64
    mono-data-sqlite-3.0.4-1.4.1.x86_64
    mono-data-postgresql-3.0.4-1.4.1.x86_64
    avahi-mono-0.6.31-10.2.1.x86_64
    mono-reactive-3.0.4-1.4.1.x86_64
    mono-devel-3.0.4-1.4.1.x86_64
    mono-wcf-3.0.4-1.4.1.x86_64
    mono-web-3.0.4-1.4.1.x86_64
    mono-data-oracle-3.0.4-1.4.1.x86_64
    mono-zeroconf-0.9.0-16.1.1.noarch
    mono-mvc-3.0.4-1.4.1.x86_64
    mono-locale-extras-3.0.4-1.4.1.x86_64
    mono-extras-3.0.4-1.4.1.x86_64
    mono-nat-1.1.0-2.1.1.x86_64
    mono-nunit-3.0.4-1.4.1.x86_64
    libmonosgen-2_0-0-3.0.4-1.4.1.x86_64
    mono-entityframework-3.0.4-1.4.1.x86_64
    monodoc-core-3.0.4-1.4.1.x86_64
    mono-complete-3.0.4-1.4.1.x86_64
    Telcontar:~ #
    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,274
    Blog Entries
    1

    Default Re: I can't get wine to run (attempting to use Foxit)

    I didn't get the 'Mono' message popup (maybe I'd installed it previously), but near the end of the install, I did get couple of messages about not being able to register, and I simply clicked 'Ignore' (twice) so that the install could complete. It starts with the active folder set to 'Home', with a 'File' folder to the left that allows a local file to be opened etc. Alternatively, I have it in my file-associations, so that a right-click on a PDF file will launch it. I found it to be stable and usable.

    While playing with wine yesterday, I decided to upgrade via the wine repo, so I'm now using wine-1.7.6. That was mainly to see how stable Adobe Reader X and X1 might be (after reading various reports). For those interested

    WineHQ - Adobe Reader 11.x

    WineHQ - Adobe Reader 10.x

    Wine 1.5.25 Fixes Adobe Reader XI Installation

    FWIW, I could get it to install and it launched okay, but PDF with form fields would crash when running the mouse over the fields. It will only be a matter of time before it is working in wine I believe, and that will satisfy most users. If I get time I'll search/submit a wine bug report.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't get wine to run (attempting to use Foxit)

    On 2013-11-10 19:46, deano ferrari wrote:
    >
    > I didn't get the 'Mono' message popup (maybe I'd installed it
    > previously), but near the end of the install, I did get couple of
    > messages about not being able to register,


    Mine were about the windows registry, not about registering. I did get a
    message suggesting I register the product.

    > It starts with the active
    > folder set to 'Home', with a 'File' folder to the left that allows a
    > local file to be opened etc.


    I got that on the second start. It is not pointing to the home, but to
    Desktop/My Documents, which is in fact {HOME}.

    > Alternatively, I have it in my
    > file-associations, so that a right-click on a PDF file will launch it. I
    > found it to be stable and usable.


    How do you do that association? :-?

    I found this trick here
    http://sodeve.net/2007/12/foxit-read...-through-wine/

    Code:
    
    > #!/bin/bash
    > # Purpose: To convert Linux-style filename to Windows-style to pass as an argument
    > # to wine when starting Foxit Reader
    > Filename="z:"${1//\//\\}
    > #assuming you use the default installation folder for Foxit in Wine
    > App='eval wine "C:\Program Files\Foxit Software\Foxit Reader\Foxit Reader.exe" "'$Filename'"'
    > $App
    and then they use that script for the association instead of Foxit.

    I also got a desktop icon that opens Foxit correctly.


    > While playing with wine yesterday, I decided to upgrade via the wine
    > repo, so I'm now using wine-1.7.6. That was mainly to see how stable
    > Adobe Reader X and X1 might be (after reading various reports). For
    > those interested
    >
    > 'WineHQ - Adobe Reader 11.x'
    > (http://appdb.winehq.org/objectManage...sion&iId=27093)
    >
    > 'WineHQ - Adobe Reader 10.x'
    > (http://appdb.winehq.org/objectManage...sion&iId=22577)
    >
    > 'Wine 1.5.25 Fixes Adobe Reader XI Installation'
    > (http://tinyurl.com/bzxxo24)


    Interesting...
    Then I did not look at the correct info, because what I read was that X
    and XI were not even installable.


    > FWIW, I could get it to install and it launched okay, but PDF with form
    > fields would crash when running the mouse over the fields. It will only
    > be a matter of time before it is working in wine I believe, and that
    > will satisfy most users. If I get time I'll search/submit a wine bug
    > report.


    Well, thanks :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: I can't get wine to run (attempting to use Foxit)

    mono from wine may have a different set of configs then just installing mono.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't get wine to run (attempting to use Foxit)

    On 2013-11-10 22:06, gogalthorp wrote:
    >
    > mono from wine may have a different set of configs then just installing
    > mono.


    Letting wine install mono is not recommended. The instructions also say
    that you have to remove the system mono, so that other apps needing it
    would fail.

    The error message does not say what part of mono is missing.

    IMO, this is a packaging bug, as the wine package should install all
    needed dependencies.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't get wine to run (attempting to use Foxit)

    On 2013-11-10 21:53, Carlos E. R. wrote:
    > On 2013-11-10 19:46, deano ferrari wrote:
    >>
    >> I didn't get the 'Mono' message popup (maybe I'd installed it
    >> previously), but near the end of the install, I did get couple of
    >> messages about not being able to register,

    >
    > Mine were about the windows registry, not about registering. I did get a
    > message suggesting I register the product.


    I tried printing from Foxit, it worked. However, signature verification
    fails: I tried on one document that acroread says it is correct, Foxit
    says the document has been manipulated.

    I don't know if it has knowledge of all certification authorities or I
    have to import something yet.

    I tried a different document, different source, and same problem.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,274
    Blog Entries
    1

    Default Re: I can't get wine to run (attempting to use Foxit)

    Quote Originally Posted by robin_listas View Post
    On 2013-11-10 22:06, gogalthorp wrote:
    >
    > mono from wine may have a different set of configs then just installing
    > mono.


    Letting wine install mono is not recommended. The instructions also say
    that you have to remove the system mono, so that other apps needing it
    would fail.

    The error message does not say what part of mono is missing.

    IMO, this is a packaging bug, as the wine package should install all
    needed dependencies.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    I didn't experience that error, but that could have been due to earlier install projects (that may have installed the necessary). I'm using 1.7.6 form the wine repo, so that may change things according to the following

    Mono - The Official Wine Wiki

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,274
    Blog Entries
    1

    Default Re: I can't get wine to run (attempting to use Foxit)

    Quote Originally Posted by robin_listas View Post
    On 2013-11-10 21:53, Carlos E. R. wrote:

    I tried printing from Foxit, it worked. However, signature verification
    fails: I tried on one document that acroread says it is correct, Foxit
    says the document has been manipulated.

    I don't know if it has knowledge of all certification authorities or I
    have to import something yet.

    I tried a different document, different source, and same problem.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    I would try obtaining support from

    Foxit Software - Support Center

    Create a ticket

    Foxit Software

    and they have a forum too

    Forums - Foxit Corporation Forums

    Of course, I wouldn't mention anything about running it in a wine environment

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't get wine to run (attempting to use Foxit)

    On 2013-11-11 00:16, deano ferrari wrote:

    I also noticed that the javascript code doesn't fully run. The calendar
    drop-down on the date field of the sample form does not appear.

    Code:
    
    > http://smarte-forms.com/wp/wp-content/uploads/2011/03/birth-certificate-application-eform-tt-sample.pdf
    ....

    > Of course, I wouldn't mention anything about running it in a wine
    > environment


    But the problem may be precisely that it runs under wine. I could try it
    on the laptop, which still has its original W7 (and openSUSE, of
    course), and try it there. If still the signature fails, the software
    has problems I can report. If not, the problem is wine.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,274
    Blog Entries
    1

    Default Re: I can't get wine to run (attempting to use Foxit)

    Quote Originally Posted by robin_listas View Post

    But the problem may be precisely that it runs under wine. I could try it
    on the laptop, which still has its original W7 (and openSUSE, of
    course), and try it there. If still the signature fails, the software
    has problems I can report. If not, the problem is wine.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    Maybe JRE needs to be installed in wine first...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •