Results 1 to 5 of 5

Thread: Bluedevil issues with 12.3 and KDE 4.11.3 - Solved for now

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Bluedevil issues with 12.3 and KDE 4.11.3 - Solved for now

    Following a suggestion here on the forum recently, I ran a Switch System Packages to the KDE 4.11_Extras repo.

    As part of that switch, or in an update soon their after, a new version of bluedevil, 1.3.2_bluez-2.1-x86_64, loaded onto my system and I realized today that Bluetooth was no longer working.
    I have found that backing down to bluedevil ver 1.3.2-4.2-x86_64, also in the 4.11_Extras repo, and restarting Bluetooth (I rebooted) seems to fix it, at least for now.

    I plan to leave it locked on this version until the dust settles.
    A symptom of my issue was that the bluetooth dongle appeared in 'lsusb', but System Settings-Network Connectivity-Bluetooth said there were no Bluetooth interfaces attached.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,617
    Blog Entries
    3

    Default Re: Bluedevil issues with 12.3 and KDE 4.11.3 - Solved for now

    I don't have an answer for you. However ...

    It has been publicized that there is a problem with bluetooth in 13.1 KDE, expected to be fixed soon. Yesterday, updating 13.1RC2, there was a new bluedevil. So perhaps that fixes the 13.1 problems in time for final release.

    I would guess that your KDE problems with bluetooth are related.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Bluedevil issues with 12.3 and KDE 4.11.3 - Solved for now

    Quote Originally Posted by nrickert View Post
    It has been publicized that there is a problem with bluetooth in 13.1 KDE, expected to be fixed soon. Yesterday, updating 13.1RC2, there was a new bluedevil. So perhaps that fixes the 13.1 problems in time for final release.
    I have not had a chance to experiment with 13.1 yet, but have seen the bluetooth issue reports.
    I am thinking that perhaps the version I removed, 1.3.2_bluez-2.1-x86_64, was in fact the source of the 13.1 issue.
    At any rate, for now on 12.3/4.11.3, I have bluetooth working again, on the older(I believe) 1.3.2-4.2-x86_64.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  4. #4

    Default Re: Bluedevil issues with 12.3 and KDE 4.11.3 - Solved for now

    Quote Originally Posted by cmcgrath5035 View Post
    I am thinking that perhaps the version I removed, 1.3.2_bluez-2.1-x86_64, was in fact the source of the 13.1 issue.
    No. The source of the 13.1 issue is that GNOME 3.10 requires bluez-5, whereas KDE (bluedevil) only supports bluez-4, and you cannot install (or even include in the distro) bluez-4 and bluez-5 at the same time.

    bluedevil-1.3.2_bluez5-2.1 is a preliminary version with bluez-5 support that has not all things working yet (will hopefully be finished until 13.1 is released).
    bluedevil-1.3.2 OTOH is the old version for bluez-4 which works fine on 12.3 (but not on 13.1 because there is no bluez-4 there).

    So yes, on 12.3 you should stick to the older bluedevil-1.3.2.
    I think the other one is in the 12.3 repo only by mistake. Its build is disabled now, but an already built RPM is still in the repo.

  5. #5
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Bluedevil issues with 12.3 and KDE 4.11.3 - Solved for now

    Quote Originally Posted by wolfi323 View Post
    No. The source of the 13.1 issue is that GNOME 3.10 requires bluez-5, whereas KDE (bluedevil) only supports bluez-4, and you cannot install (or even include in the distro) bluez-4 and bluez-5 at the same time.

    bluedevil-1.3.2_bluez5-2.1 is a preliminary version with bluez-5 support that has not all things working yet (will hopefully be finished until 13.1 is released).
    bluedevil-1.3.2 OTOH is the old version for bluez-4 which works fine on 12.3 (but not on 13.1 because there is no bluez-4 there).

    So yes, on 12.3 you should stick to the older bluedevil-1.3.2.
    I think the other one is in the 12.3 repo only by mistake. Its build is disabled now, but an already built RPM is still in the repo.
    Thanks, wolfi323, for the added clarity on the situation.

    And for other readers of this thread, I apologize for the typo error in my original post that wolfi323 points out here.
    It was in fact bluedevil-1.3.2_bluez5-2.1 that caused my issues, reverting to bluedevil-1.3.2-4.2 restored my bluetooth.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •