Results 1 to 3 of 3

Thread: Icons inconsistant after changing icon sets

  1. #1

    Default Icons inconsistant after changing icon sets

    I'm getting to know OpenSuse as my organization Reglue will be placing the educational version on all outgoing computers when the next Evergreen version is stable.

    I don't know if I'm posting this in the correct place and I've looked for this answer most of the morning so if this has been discussed, please point me in the right direction.

    Running OpenSuse 12.3 with KDE. I changed the icon set from the default Oxygen icons and I individually changed many of the folder icons in my home folder to ones I like. Now, when I open Dolphin, the Desktop, music and pictures folder are just white boxes with previews on them. Some of the folders remain with the individual changed icons from earlier but others have the default Oxygen icons which shouldn't be there at all since I changed that icon theme.

    I can't seem to post pictures so you can see a graphical representation of what I am talking about.

    https://drive.google.com/file/d/0B2b...it?usp=sharing

    Here's maybe a clue. When I refresh Dolphin, the correct icons show up for just a second then revert to the ones described above. I can only reproduce this on OpenSuse. Mint KDE and PCLinuxOS will not produce the same errors.

    What I've tried already:

    Cleared my KDE cache /var/tmp/kdecache-helios
    (probably best to do it in a virtual terminal (alt+ctrl+F1) when KDE not running)

    I ran
    kbuildsycoca4 --noincremental...2 pages of Errors ensued. Errors can be seen at link below:

    https://docs.google.com/a/fixedbylin...it?usp=sharing

    Any help provided would be greatly appreciated.



  2. #2

    Default Re: Icons inconsistant after changing icon sets

    Try to remove the icon cache:
    Code:
    rm /var/tmp/kdecache-$USER/icon-cache.kcache
    (edit: sorry, I overlooked that you already tried that. But have you logged out and in again? You should clear the cache when not logged in to KDE to be sure.)

    Does it work if you disable the Previews? (either completely with the button in the toolbar, or you can disable the preview only for folders in Dolphin's settings "General"->Previews)

    I think I read about a problem of the preview feature in combination with custom folder icons some time ago.
    But I'm not sure if I can find that again (I think it was in the KDE forums), or if there was any solution...

    You can ignore the output of kbuildsycoca4. That are just warnings/debug output for developers, no errors.

  3. #3

    Default Re: Icons inconsistant after changing icon sets

    "Does it work if you disable the Previews?"

    I'm just a wee bit embarrassed I didn't test this before posting. The disable previews option should have been a no-brainer when I noted that the icons are correct for a second after opening Dolphin.

    Yeah, they are correct without previews. I will search and revisit the problem of custom icons and previews her shortly. Thanks a bunch for putting me on the right track....I am easily derailed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •