Results 1 to 10 of 10

Thread: Playing with Apache

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Playing with Apache

    Hi,

    I have installed Apache in an old laptop I use as kind of file server. I
    have not played with Apache in years.

    So I have this file structure (for testing):

    Code:
    AmonLanc:~ # tree /srv/www
    /srv/www
    ├── cgi-bin
    │   ├── info2html
    │   ├── info2html.conf
    │   └── infocat
    └── htdocs
    ├── ficheros
    │   ├── 000.mp3
    │   ├── Restorer7.exe
    │   └── hoard -> /data/hoard
    ├── files -> ficheros
    ├── gif
    │   ├── l_arrow.gif
    │   ├── r-ball.gif
    │   ├── r_arrow.gif
    │   ├── r_hand.gif
    │   └── u_arrow.gif
    ├── index.html
    └── info2html.css
    
    6 directories, 12 files
    AmonLanc:~ #
    If I browse to

    Code:
    http://AmonLanc.valinor
    I see the correct web page (a one line saying "it works").

    I have created "/etc/apache2/httpd.conf.local", and indicated in
    "/etc/sysconfig/apache2" that I want to use it:

    APACHE_CONF_INCLUDE_FILES="httpd.conf.local"


    In that local file, I have:

    Code:
    <Directory /srv/www/htdocs/ficheros>
    Options FollowSymLinks Indexes Includes
    AllowOverride All
    
    IndexOptions FancyIndexing \
    ScanHTMLTitles \
    NameWidth=* \
    DescriptionWidth=* \
    SuppressLastModified \
    SuppressSize
    
    order deny,allow
    deny from all
    allow from localhost .valinor
    
    </Directory>

    Now, when I browse to

    Code:
    http://AmonLanc.valinor/ficheros/
    I see the expected file listing:


    Code:
    
    >                                               Index of /ficheros
    >
    >  Icon Name                    Description
    >
    >      ------------------------------------------------------------------------------------------------------
    >
    >  [DIR] Parent Directory
    >  [SND] 000.mp3
    >  [   ] Restorer7.exe
    >  [DIR] hoard/
    >
    >      ------------------------------------------------------------------------------------------------------
    >
    >     Apache/2.2.22 (Linux/SUSE) Server at amonlanc.valinor Port 80
    This works because of "mod_autoindex" being active.

    If I click on the "Restorer7.exe" file it initiates download. All good.

    However, when I click on the "000.mp3" file I get a
    Flash gadget!

    This is new to me.

    It has a slider for position in file, a volume slider, a play/pause
    button... all seem functional.

    But it does not really "play" - see what I get from right
    click, stats


    My question is twofold. One, how to get that flash thing to work. Two,
    how to get a local player to play mp3 files and such - say, the mplayer
    plugin.

    If you know of a nice document to read that explain this, just perfect,
    tell me to RTFM ;-)

    (the 'F' means "fine" ;-) )

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  2. #2

    Default Re: Playing with Apache

    On 11/01/2013 06:03 AM, Carlos E. R. wrote:
    > My question is twofold. One, how to get that flash thing to work. Two,
    > how to get a local player to play mp3 files and such - say, the mplayer
    > plugin.


    Why are you asking in a thread with 'Apache' in the name? I understand
    you are playing with Apache httpd, but after that I do not think your
    questions apply to the web service at all. To answer them as I think is
    correct:

    1. Fix Firefox's little gadget that auto-plays stuff. Maybe try another
    browser to see if other options work better.

    2. Right-click on the link, download, and then open with whatever.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing with Apache

    On 2013-11-01 13:14, ab wrote:
    > On 11/01/2013 06:03 AM, Carlos E. R. wrote:
    >> My question is twofold. One, how to get that flash thing to work. Two,
    >> how to get a local player to play mp3 files and such - say, the mplayer
    >> plugin.

    >
    > Why are you asking in a thread with 'Apache' in the name? I understand
    > you are playing with Apache httpd, but after that I do not think your
    > questions apply to the web service at all. To answer them as I think is
    > correct:


    Because I thought it was Apache who did it. Does it not? :-?

    >
    > 1. Fix Firefox's little gadget that auto-plays stuff. Maybe try another
    > browser to see if other options work better.


    You may be onto something. Seamonkey displays a totally black page, and
    after about 10 seconds, music plays. Pulse mixer says it is "plugin
    container: audio stream".

    (However, preferences/applications says it is to be the VLC multimedia
    plugin - and "ps afx" says that in fact it is
    "/usr/lib64/browser-plugins/xineplugin.so")


    > 2. Right-click on the link, download, and then open with whatever.


    Firefox does not allow to open with anything at all, only save.
    Seamonkey has a few more entries, but not "open with".

    And I do not want to download the files, I want to play them directly
    with no download.


    Ok, so how do I change the default firefox whatever to open it with
    something else that works? In preferences/applications it says that mp3
    files are to be opened with "VLC multimedia plugin". I changed it to
    "always ask", and it still uses flash, does not ask. I change to
    "audacious", it still uses flash.

    So what?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  4. #4

    Default Re: Playing with Apache

    Wildly Google-ing:

    http://forums.mozillazine.org/viewto...f=23&t=2698835

    Let us know.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  5. #5
    Join Date
    Jun 2009
    Location
    Pennsylvania, USA
    Posts
    233

    Default Re: Playing with Apache

    You need to tell the server to tell the client that the content is "special", i.e. streaming, and to associate the file extension. Here's what I had to add to get video to work:

    Code:
    gwb@cloyd:~> cat public_html/.htaccess
    AddType video/ogg .ogv
    
    AddType video/mp4 .mp4
    
    AddType video/webm .webm
    Something similar for audio/mp3 or audio/<whatever> should get it recognized.
    Use the Source, Luke

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing with Apache

    On 2013-11-01 17:56, ab wrote:
    > Wildly Google-ing:
    >
    > http://forums.mozillazine.org/viewto...f=23&t=2698835
    >
    > Let us know.
    >



    It says to set "media.windows-media-foundation.enabled" to false. I
    don't have such a variable in about:config.

    The question there is about .ra files, mine is about mp3 and every other
    file the internal plugin wants to handle.

    It simply ignores the setting to use vlc plugin or any other plugin :-/

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing with Apache

    On 2013-11-01 19:56, GeoBaltz wrote:
    >
    > You need to tell the server to tell the client that the content is
    > "special", i.e. streaming, and to associate the file extension. Here's
    > what I had to add to get video to work:


    What it has works perfect with seamonkey, chrome, and konqueror. Only
    Firefox fails, because it opens with its broken internal player.

    The problem now is how to disable Firefox internal player.


    But thanks :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing with Apache

    On 2013-11-01 20:03, Carlos E. R. wrote:

    > It says to set "media.windows-media-foundation.enabled" to false. I
    > don't have such a variable in about:config.


    Solved. It is "media.gstreamer.enabled". I found out by comparing all
    "media.*" variables with seamonkey, that was working. Has to be set to
    false.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9

    Default Re: Playing with Apache

    On 11/01/2013 01:43 PM, Carlos E. R. wrote:
    > On 2013-11-01 20:03, Carlos E. R. wrote:
    >
    >> It says to set "media.windows-media-foundation.enabled" to false. I
    >> don't have such a variable in about:config.

    >
    > Solved. It is "media.gstreamer.enabled". I found out by comparing all
    > "media.*" variables with seamonkey, that was working. Has to be set to
    > false.


    Good to hear. Thank-you for posting back the results.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing with Apache

    On 2013-11-01 20:46, ab wrote:
    > On 11/01/2013 01:43 PM, Carlos E. R. wrote:


    >> Solved. It is "media.gstreamer.enabled". I found out by comparing all
    >> "media.*" variables with seamonkey, that was working. Has to be set to
    >> false.

    >
    > Good to hear. Thank-you for posting back the results.


    Welcome.

    I always post the solution or the workaround if I find it :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •