Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: cannot run any browser

  1. #1
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    263

    Default cannot run any browser

    OpenSuse 12.3 on x86_64; no gnome or kde

    Today every time I try to start seamonkey or firefox I get the error:

    Pango-WARNING **: /usr/lib/pango/1.6.0/modules/pango-basic-fc.so: wrong ELF class: ELFCLASS32

    As far as I can see with zyppert se pango I have no 32bit pango installed only 64

    How can I recover any sanity?

    ==John ff

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,131
    Blog Entries
    15

    Default Re: cannot run any browser

    On Thu 31 Oct 2013 05:26:03 PM CDT, jpff wrote:


    OpenSuse 12.3 on x86_64; no gnome or kde

    Today every time I try to start seamonkey or firefox I get the error:

    Pango-WARNING **: /usr/lib/pango/1.6.0/modules/pango-basic-fc.so: wrong
    ELF class: ELFCLASS32

    As far as I can see with zyppert se pango I have no 32bit pango
    installed only 64

    How can I recover any sanity?

    ==John ff


    Hi
    That's a 12.2 library, I would guess this was an upgrade from 12.2 to
    12.3, what repositories are active?
    Code:
    zypper lr -d
    Then force the install of the 12.3 version (1.8.0)

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.93-0.8-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    263

    Default Re: cannot run any browser

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That's a 12.2 library, I would guess this was an upgrade from 12.2 to
    12.3, what repositories are active?
    Code:
    zypper lr -d
    Then force the install of the 12.3 version (1.8.0)
    Repositories
    download.opensuse.org-non-oss
    download.opensuse.org-oss
    opensuse-guide.org-repo
    packman
    repo-12.3-oss
    repo-12.3-updat
    repo-update
    repo-update-non-oss
    updated fron 12.2 monthsago and ran (rather unhappily) since. Today after 1 week away the browsers crashed and wiklk not restart. Updated weekly via zypper

    Actuall /usr/lib64 does contain pango 1.8.0. I tried moving the 1.6.0 one away but made no difference-- said it could not find it. Suggests some othe part of seamonkey/firefox is looking for 32bit systems

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: cannot run any browser

    Quote Originally Posted by jpff View Post
    Repositories
    download.opensuse.org-non-oss
    download.opensuse.org-oss
    opensuse-guide.org-repo
    packman
    repo-12.3-oss
    repo-12.3-updat
    repo-update
    repo-update-non-oss
    updated fron 12.2 monthsago and ran (rather unhappily) since. Today after 1 week away the browsers crashed and wiklk not restart. Updated weekly via zypper

    Actuall /usr/lib64 does contaiy pango 1.8.0. I tried moving the 1.6.0 one away but made no difference-- said it could not find it. Suggests some othe part of seamonkey/firefox is looking for 32bit systems
    Your post is not from the requested terminal command. Why? Also, post such results inside of code # tags. You want to try again?

    Code:
    zypper lr -d
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    263

    Default Re: cannot run any browser

    Sorry -- difficult without a browser on the machine so I am posting fro a 12.2 (working) computer at arm's length

    # | Alias | Name | Enabled
    | Refresh | Priority | Type | URI
    | Service
    --+-------------------------------+------------------------------------+--------
    -+---------+----------+--------+------------------------------------------------
    -----------------+--------
    1 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes
    | Yes | 99 | yast2 | Index of /distribution/12.3
    repo/non-oss/ |
    2 | download.opensuse.org-oss | Main Repository (OSS) | Yes
    | Yes | 99 | yast2 | Index of /distribution/12.3
    repo/oss/ |
    3 | opensuse-guide.org-repo | libdvdcss repository | Yes
    | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.3/
    |
    4 | packman | Packman repository (openSUSE_12.3) | Yes
    | Yes | 98 | rpm-md | Index of /suse/openSUSE_12.3/
    |
    5 | repo-12.3-oss | openSUSE-12.3-OSS | Yes
    | Yes | 99 | yast2 | Index of /distribution/12.3
    repo/oss/ |
    6 | repo-12.3-update | openSUSE-12.3 Update-Oss | Yes
    | Yes | 99 | rpm-md | Index of /update/12.3
    |
    7 | repo-source | openSUSE-12.3-Source | No
    | Yes | 99 | yast2 | http://download.opensuse.org/source/distributio
    n/12.3/repo/oss/ |
    8 | repo-update | openSUSE-12.3-Update | Yes
    | Yes | 99 | rpm-md | Index of /update/12.3
    |
    9 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Yes
    | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.3-non-os
    s/ |

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: cannot run any browser

    Quote Originally Posted by jpff View Post
    Sorry -- difficult without a browser on the machine so I am posting fro a 12.2 (working) computer at arm's length

    # | Alias | Name | Enabled
    | Refresh | Priority | Type | URI
    | Service
    --+-------------------------------+------------------------------------+--------
    -+---------+----------+--------+------------------------------------------------
    -----------------+--------
    1 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes
    | Yes | 99 | yast2 | Index of /distribution/12.3
    repo/non-oss/ |
    2 | download.opensuse.org-oss | Main Repository (OSS) | Yes
    | Yes | 99 | yast2 | Index of /distribution/12.3
    repo/oss/ |
    3 | opensuse-guide.org-repo | libdvdcss repository | Yes
    | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.3/
    |
    4 | packman | Packman repository (openSUSE_12.3) | Yes
    | Yes | 98 | rpm-md | Index of /suse/openSUSE_12.3/
    |
    5 | repo-12.3-oss | openSUSE-12.3-OSS | Yes
    | Yes | 99 | yast2 | Index of /distribution/12.3
    repo/oss/ |
    6 | repo-12.3-update | openSUSE-12.3 Update-Oss | Yes
    | Yes | 99 | rpm-md | Index of /update/12.3
    |
    7 | repo-source | openSUSE-12.3-Source | No
    | Yes | 99 | yast2 | http://download.opensuse.org/source/distributio
    n/12.3/repo/oss/ |
    8 | repo-update | openSUSE-12.3-Update | Yes
    | Yes | 99 | rpm-md | Index of /update/12.3
    |
    9 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Yes
    | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.3-non-os
    s/ |
    If you do not hightlight the pasted text in your message and select code #, all formatting is lost and the result is not readable. Want to try again?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,131
    Blog Entries
    15

    Default Re: cannot run any browser

    Quote Originally Posted by jpff View Post
    Sorry -- difficult without a browser on the machine so I am posting fro a 12.2 (working) computer at arm's length
    Code:
    5 | repo-12.3-oss                 | openSUSE-12.3-OSS                  | Yes    
     | Yes     |   99     | yast2  | Index of /distribution/12.3
    repo/oss/        |        
    6 | repo-12.3-update              | openSUSE-12.3 Update-Oss           | Yes    
     | Yes     |   99     | rpm-md | Index of /update/12.3
    Hi
    So 5 and 6 are duplicates and can be removed.

    So if you run;
    Code:
    zypper se -i  pango
    No 32bit lib installed? If not, then it must be an orphaned hangover from the update, which by the sounds didn't go too well...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: cannot run any browser

    Quote Originally Posted by malcolmlewis View Post
    Code:
    5 | repo-12.3-oss                 | openSUSE-12.3-OSS                  | Yes    
     | Yes     |   99     | yast2  | Index of /distribution/12.3
    repo/oss/        |        
    6 | repo-12.3-update              | openSUSE-12.3 Update-Oss           | Yes    
     | Yes     |   99     | rpm-md | Index of /update/12.3
    So 5 and 6 are duplicates and can be removed.
    They don't look like duplicates to me. One's the OSS repo and the other looks like the updates.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,131
    Blog Entries
    15

    Default Re: cannot run any browser

    Quote Originally Posted by chief_sealth View Post
    They don't look like duplicates to me. One's the OSS repo and the other looks like the updates.
    Hi
    2 and 5 are the same (oss), then 6 and 8 are the same (oss updates)?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    263

    Default Re: cannot run any browser

    I cannot see how repeat repositories could give problems, but anyway I will fix


    /usr/lib/pahngo/1.6.0 was clearly a hang over from the upgrade (sic) to 12.3. I tried deleting this directory and then it says it cannot find pango/1.6.0. I reinstalled seamonkey which made no difference.

    I did check that zypper thinks there is no 32bit pango installed.

    Perhaps the only solution is to reinstall 12.2 which would be hard as I am usually remote from the machine

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •