Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: cannot run any browser

  1. #21
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    263

    Default Re: cannot run any browser

    Quote Originally Posted by wolfi323 View Post
    That looks ok.

    And what version is your seamonkey?
    Code:
    rpm -qi seamonkey
    xenakis:/jpff # rpm -qi seamonkey
    Name : seamonkey
    Version : 2.21
    Release : 1.21.2
    Architecture: x86_64
    Install Date: Thu 31 Oct 2013 18:29:24 GMT
    Group : Productivity/Networking/Web/Browsers
    Size : 64266400
    License : MPL-2.0
    Signature : RSA/SHA256, Fri 27 Sep 2013 14:39:49 BST, Key ID b88b2fd43dbdc284
    Source RPM : seamonkey-2.21-1.21.2.src.rpm
    Build Date : Thu 19 Sep 2013 17:58:06 BST
    Build Host : cloud137
    Relocations : (not relocatable)
    Packager : openSUSE:Submitting bug reports - openSUSE
    Vendor : openSUSE
    URL : http://www.mozilla.org/projects/seamonkey
    Summary : The successor of the Mozilla Application Suite
    Description :
    Originally based on the Netscape Communicator source, the SeaMonkey
    project grew to be the most advanced web browser currently available.
    It supports new techniques like CSS2, MathML, SVG, XML, transparent
    PNGs, and its look is fully theme-able.
    Distribution: openSUSE 12.3

    Something must try to load that 12.2 32bit /usr/lib/pango/1.6.0/modules/pango-basic-fc.so, so you must have some leftover from 12.2 (the 12.3 packages are all compiled against pango-1.8.0).
    Gtk2 itself maybe?
    Code:
    rpm -qi libgtk-2_0-0 libgtk-2_0-0-32bit
    Or maybe pango-tools?
    Code:
    rpm -qi pango-tools pango-tools-32bit
    xenakis:/jpff # rpm -qi libgtk-2_0-0 libgtk-2_0-0-32bit
    Name : libgtk-2_0-0
    Version : 2.24.18
    Release : 2.4.2
    Architecture: x86_64
    Install Date: Mon 27 May 2013 14:00:35 BST
    Group : System/Libraries
    Size : 7838231
    License : LGPL-2.1+
    Signature : RSA/SHA256, Thu 23 May 2013 14:51:47 BST, Key ID b88b2fd43dbdc284
    Source RPM : gtk2-2.24.18-2.4.2.src.rpm
    Build Date : Tue 21 May 2013 11:02:20 BST
    Build Host : cloud113
    Relocations : (not relocatable)
    Packager : openSUSE:Submitting bug reports - openSUSE
    Vendor : openSUSE
    URL : The GTK+ Project
    Summary : The GTK+ toolkit library (version 2)
    Description :
    GTK+ is a multi-platform toolkit for creating graphical user interfaces.
    Offering a complete set of widgets, GTK+ is suitable for projects
    ranging from small one-off projects to complete application suites.
    Distribution: openSUSE 12.3
    package libgtk-2_0-0-32bit is not installed
    xenakis:/jpff # rpm -qi pango-tools pango-tools-32bit
    Name : pango-tools
    Version : 1.32.5
    Release : 3.4.2
    Architecture: x86_64
    Install Date: Thu 11 Apr 2013 16:01:38 BST
    Group : System/Libraries
    Size : 66301
    License : LGPL-2.1+
    Signature : RSA/SHA256, Wed 10 Apr 2013 10:04:17 BST, Key ID b88b2fd43dbdc284
    Source RPM : pango-1.32.5-3.4.2.src.rpm
    Build Date : Mon 01 Apr 2013 14:02:49 BST
    Build Host : build14
    Relocations : (not relocatable)
    Packager : openSUSE:Submitting bug reports - openSUSE
    Vendor : openSUSE
    URL : Introduction - Pango
    Summary : Library for Layout and Rendering of Text -- Tools
    Description :
    Pango is a library for layout and rendering of text, with an emphasis
    on internationalization. It can be used anywhere that text layout
    is needed.

    Pango forms the core of text and font handling for GTK+.
    Distribution: openSUSE 12.3
    package pango-tools-32bit is not installed




    And maybe have a look in the package list in YaST->Software Management (Click on View->Repositories) if there are packages with a red version number and uninstall or "Update Unconditionally" them.

    Or try to run "sudo zypper dup" and post a list of the conflicts you get.
    Not sure if I can detect red (colour blind). But all looked the same (red==black usually)

    zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    The following NEW packages are going to be installed:
    gmplayer gstreamer-lang

    The following packages are going to be upgraded:
    lame libavcodec52 libavfilter1 libavformat52 libavutil50 libmp3lame0
    libswscale0

    The following packages are going to be downgraded:
    get_iplayer k3b k3b-lang libjack0 libjack-devel libmad0

    The following packages are going to change vendor:
    get_iplayer
    obs://build.opensuse.org/home:malcolmlewis -> PackMan :: Startseite
    k3b
    openSUSE -> PackMan :: Startseite
    k3b-lang
    openSUSE -> PackMan :: Startseite
    libjack0
    PackMan :: Startseite -> openSUSE
    libjack-devel
    PackMan :: Startseite -> openSUSE


    7 packages to upgrade, 6 to downgrade, 2 new, 5 to change vendor.
    Overall download size: 13.6 MiB. After the operation, additional 1.2 MiB will
    be used.
    Continue? [y/n/?] (y): n
    xenakis:/jpff #


    BTW whatever happened to xpdf? It does not work and does not seem to be in repositories

  2. #22

    Default Re: cannot run any browser

    Quote Originally Posted by jpff View Post
    Not sure if I can detect red (colour blind). But all looked the same (red==black usually)
    Hm, that's a pity. I expect some 12.2 package that's left over and should be shown in red instead of black.

    Well, try to select "Unmaintained packages" as secondary filter in that view (on the left side, below the repos list).
    Does that show any packages?
    Maybe post a list or just uninstall all of them (right-click on the package list and select "All in this List"->"Uninstall").

    zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    The following NEW packages are going to be installed:
    gmplayer gstreamer-lang

    The following packages are going to be upgraded:
    lame libavcodec52 libavfilter1 libavformat52 libavutil50 libmp3lame0
    libswscale0

    The following packages are going to be downgraded:
    get_iplayer k3b k3b-lang libjack0 libjack-devel libmad0

    The following packages are going to change vendor:
    get_iplayer
    obs://build.opensuse.org/home:malcolmlewis -> PackMan :: Startseite
    k3b
    openSUSE -> PackMan :: Startseite
    k3b-lang
    openSUSE -> PackMan :: Startseite
    libjack0
    PackMan :: Startseite -> openSUSE
    libjack-devel
    PackMan :: Startseite -> openSUSE


    7 packages to upgrade, 6 to downgrade, 2 new, 5 to change vendor.
    Overall download size: 13.6 MiB. After the operation, additional 1.2 MiB will
    be used.
    Continue? [y/n/?] (y): n
    xenakis:/jpff #
    Those shouldn't cause this.


    BTW whatever happened to xpdf? It does not work and does not seem to be in repositories
    It has been replaced by poppler. (actually poppler is a fork of xpdf with the goal to create a shared library that can be used by other programs)

    No idea what happened to the xpdf-poppler package (an xpdf executable that used libpoppler) though, it got dropped after 12.1.

  3. #23
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    263

    Default Re: cannot run any browser

    Quote Originally Posted by wolfi323 View Post
    Hm, that's a pity. I expect some 12.2 package that's left over and should be shown in red instead of black.

    Well, try to select "Unmaintained packages" as secondary filter in that view (on the left side, below the repos list).
    Does that show any packages?
    Maybe post a list or just uninstall all of them (right-click on the package list and select "All in this List"->"Uninstall").


    Those shouldn't cause this.
    Tried that and it deleted a number of packages, mainly 12.1CD/DVD and zlib anf some lib that looked likea video -- could not find how to capture the text. Made no difference to rge call for pango:

    (seamonkey-bin:5527): Pango-WARNING **: /usr/lib/pango/1.6.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory

    but I get some kind of window. Need to await next week to see what happens on the screen.


    It has been replaced by poppler. (actually poppler is a fork of xpdf with the goal to create a shared library that can be used by other programs)

    No idea what happened to the xpdf-poppler package (an xpdf executable that used libpoppler) though, it got dropped after 12.1.
    How does on get poppler? There is no package and no program
    ~I searched

    S | Name | Summary | Type
    --+--------------------------+-----------------------------------------+--------
    i | libpoppler-cpp0 | PDF Rendering Library | package
    | libpoppler-devel | PDF rendering library | package
    | libpoppler-glib-devel | PDF rendering library - GLib Wrapper | package
    i | libpoppler-glib8 | PDF Rendering Library - GLib Wrapper | package
    i | libpoppler-qt4-4 | PDF Rendering Library - Qt4 Wrapper | package
    | libpoppler-qt4-devel | PDF rendering library - Qt4 Wrapper | package
    i | libpoppler34 | PDF Rendering Library | package
    i | poppler-data | Encoding Files for use with libpoppler | package
    i | poppler-tools | PDF Rendering Library Tools | package
    | python-poppler | Python bindings for the Poppler PDF r-> | package
    | typelib-1_0-Poppler-0_18 | PDF Rendering Library - Introspection-> | package


    Also triedlocate anf thete are unworking xpdf and xpdf-poppler -- both seek libpoppler.so.18 which does not exist.

    As you can tell my experience with 12.3 has been very negative; not booting, not giving X, not giving NFS disks, and some thing not working. 12.2 works perfectly. Worrying about 13.1!

  4. #24
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: cannot run any browser

    On 2013-11-02 18:16, wolfi323 wrote:
    > jpff;2595164 Wrote:
    >> >
    >> > Not sure if I can detect red (colour blind). But all looked the same
    >> > (red==black usually)

    > Hm, that's a pity. I expect some 12.2 package that's left over and
    > should be shown in red instead of black.
    >
    > Well, try to select "Unmaintained packages" as secondary filter in that
    > view (on the left side, below the repos list).
    > Does that show any packages?


    Or run one of these queries:

    Code:
    
    > rpm -q -a --queryformat "%{INSTALLTIME}\t%{INSTALLTIME:day} \
    >    %{BUILDTIME:day} %-30{NAME}\t%15{VERSION}-%-7{RELEASE}\t%{arch} \
    >    %25{VENDOR}%25{PACKAGER} == %{DISTRIBUTION} %{DISTTAG}\n" \
    >   | sort | cut --fields="2-" | tee rpmlist | less -S
    >
    > or
    >
    > rpm -q -a --queryformat "%{INSTALLTIME}\t%{INSTALLTIME:day} \
    >    %{BUILDTIME:day} %-30{NAME}\t%15{VERSION}-%-7{RELEASE}\t%{arch} \
    >    %25{VENDOR}%25{PACKAGER} == %{DISTRIBUTION} %{DISTTAG}\n" \
    >   | sort | cut --fields="2-" | tee rpmlist | egrep -v "openSUSE.12\.2" | less -S

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  5. #25

    Default Re: cannot run any browser

    Quote Originally Posted by jpff View Post
    How does on get poppler? There is no package and no program
    Poppler mainly is a library (libpoppler) to be used by other programs, okular and evince use it f.e., see here: Poppler (software) - Wikipedia, the free encyclopedia

    As mentioned there also was xpdf-poppler, which was an xpdf that actually used libpoppler for rendering the documents, but that's not available anymore (at least not in the standard openSUSE repos).

    Also triedlocate anf thete are unworking xpdf and xpdf-poppler -- both seek libpoppler.so.18 which does not exist.
    Then they must be a leftover from 12.1! But why didn't they get uninstalled by that "Uninstall all"?
    And those packages should require libpoppler18, so they should have been uninstalled by the upgrade anyway because libpoppler18 is not available any more.

    Strange. What does "rpm -qf `which xpdf`" say?

    As you can tell my experience with 12.3 has been very negative; not booting, not giving X, not giving NFS disks, and some thing not working. 12.2 works perfectly. Worrying about 13.1!
    Well, apparently there has been something wrong with the way you upgraded, if you still have 12.1 stuff left.
    I didn't have any grave problem with 12.3 (I don't use NFS though I have to say).

  6. #26
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    263

    Default Re: cannot run any browser

    Quote Originally Posted by wolfi323 View Post
    Poppler mainly is a library (libpoppler) to be used by other programs, okular and evince use it f.e., see here: Poppler (software) - Wikipedia, the free encyclopedia

    As mentioned there also was xpdf-poppler, which was an xpdf that actually used libpoppler for rendering the documents, but that's not available anymore (at least not in the standard openSUSE repos).
    So there is no replacement for xpdf? I do not see that mentioned in the release notes.

    Then they must be a leftover from 12.1! But why didn't they get uninstalled by that "Uninstall all"?
    And those packages should require libpoppler18, so they should have been uninstalled by the upgrade anyway because libpoppler18 is not available any more.

    Strange. What does "rpm -qf `which xpdf`" say?


    Well, apparently there has been something wrong with the way you upgraded, if you still have 12.1 stuff left.
    I didn't have any grave problem with 12.3 (I don't use NFS though I have to say).
    xenakis:~ 125> rpm -qf `which xpdf`
    file /usr/bin/xpdf is not owned by any package
    xenakis:~ 126>

    This machine or its disks previously ran 12.0, 12.1 and 12.2 and was upgraded each time via zypper in place. Always worked before but not 12.3. Others here University failed to get 12.3 running and so my own network is all 12.2 and I fear the upgrade.

    I akso tried the "rpm -q -a --queryformat ...." command and it was incomprehensible, a list of dates and later version numbers (I think) for something.


    Thank you anyway -- maybe things are a little improved.

  7. #27

    Default Re: cannot run any browser

    Quote Originally Posted by jpff View Post
    So there is no replacement for xpdf? I do not see that mentioned in the release notes.
    It's not included anymore since 12.2, yes.

    But you can find it on OBS:
    software.opensuse.org:

    xenakis:~ 125> rpm -qf `which xpdf`
    file /usr/bin/xpdf is not owned by any package
    xenakis:~ 126>
    Another strange thing. Why is the file still there when the package is uninstalled?
    I wouldn't be surprised if there's other stuff from 12.1 or 12.2 on your system, even though the corresponding 12.3 packages are installed.

    How something like this happened I don't know.
    Maybe an inconsistent file system or hard disk errors when upgrading?
    Or is your system spread over multiple partitions and not all of them were mounted during the update (not likely though, you would have bigger problems then)?

    I would suggest to re-install all packages (f.e. right-click on the installed packages list in YaST and select "All in this List"->"Update Unconditionally"), or do a fresh installation.

    If you don't want to do that, you could run "rpm -Va" to verify all installed packages (warning, that will take some time!) and then only re-install those packages that are found to be not consistent.

    This machine or its disks previously ran 12.0, 12.1 and 12.2 and was upgraded each time via zypper in place. Always worked before but not 12.3. Others here University failed to get 12.3 running and so my own network is all 12.2 and I fear the upgrade.
    I doubt that you ran 12.0, that version never existed...

    I always upgraded in-place from one version to the next since 8.1, and never had such problems.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •