Results 1 to 6 of 6

Thread: right alt key doesn't work

  1. #1
    grglsn NNTP User

    Default right alt key doesn't work

    I recently made some changes to my keyboard layout, like adding in the
    us_intl keyboard and the Filipino keyboard to my normal US keyboard. I
    also made the right windows key to become the compose key. In addition I
    changed from a Generic 101 key keyboard to the A4Tech KB-21 keyboard.
    This is for my Box #1, and it was all done in KDE System-Settings ->
    Input devices.

    After this, my right alt key no longer functions like an alt key. I
    prefer my right alt key to have the same behavior as my left alt key.
    When I run xev, I show that the right alt key and left alt key behave
    as follows:

    Code:
    KeyPress event, serial 39, synthetic NO, window 0x8000001,
    root 0x15f, subw 0x0, time 45742206, (162,-17), root:(1489,7),
    state 0x2010, keycode 108 (keysym 0xfe03, ISO_Level3_Shift),
    same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False
    
    KeyRelease event, serial 39, synthetic NO, window 0x8000001,
    root 0x15f, subw 0x0, time 45742722, (162,-17), root:(1489,7),
    state 0x2090, keycode 108 (keysym 0xfe03, ISO_Level3_Shift),
    same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes:
    XFilterEvent returns: False
    
    KeyPress event, serial 39, synthetic NO, window 0x8000001,
    root 0x15f, subw 0x0, time 45744900, (162,-17), root:(1489,7),
    state 0x2010, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False
    
    KeyRelease event, serial 39, synthetic NO, window 0x8000001,
    root 0x15f, subw 0x0, time 45745186, (162,-17), root:(1489,7),
    state 0x2018, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False
    You can see that the first key press is the right alt, and it is saying
    that it is "ISO_Level3_Shift". However the 2nd key press is the left
    alt, and it reads as "Alt_L".

    How can I make the right alt key read as "Alt_R"? I tried switching
    through all 3 different keyboards and testing it, and no change. I also
    tried eliminating the compose key (even though it is right-win and not
    right-alt), and it also showed no change. I then tried going back to the
    Generic 101 key keyboard, and it still maps that key to "ISO_Level3_Shift".


    --
    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.3 | KDE 4.10 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: right alt key doesn't work

    On 2013-10-29 09:07, grglsn wrote:

    > After this, my right alt key no longer functions like an alt key.


    On non English keyboards, the right alt key doesnt work as Alt, but
    AltGr. It is a feature. Intentional.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3
    grglsn NNTP User

    Default Re: right alt key doesn't work

    On 10/29/2013 10:38 PM, Carlos E. R. wrote:
    > On 2013-10-29 09:07, grglsn wrote:
    >
    >> After this, my right alt key no longer functions like an alt key.

    >
    > On non English keyboards, the right alt key doesnt work as Alt, but
    > AltGr. It is a feature. Intentional.
    >


    Ok, when I placed my keyboard layout in the "English (US)"
    configuration, the right Alt key still did not function as Alt-R. It
    only functioned as AltGr. Is this a KDE bug?

    So I tried going into Yast and modifying the language settings there. I
    have the primary language set there as English (US). There is a checkbox
    that says "Adapt keyboard layout to English (US)". I checked it and hit
    ok. This allowed me to use the Right Alt key as I prefer now.

    However, this is not solved. Now, I can no longer toggle to one of the
    international keyboards - it seems this setting in Yast blocked out the
    international keyboard settings for KDE. I tried opening up the dialog
    again in Yast, but the setting is now grayed out, and I cannot uncheck
    the box that adopted keyboard settings to English (US).

    I don't know which variable to set to undue this setting, as it is
    unclear to me, in /etc/sysconfig/language.


    --
    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.3 | KDE 4.10 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB

  4. #4
    graham NNTP User

    Default Re: right alt key doesn't work

    Carlos E. R. wrote:

    > On 2013-10-29 09:07, grglsn wrote:
    >
    >> After this, my right alt key no longer functions like an alt key.

    >
    > On non English keyboards, the right alt key doesn’t work as Alt, but
    > AltGr. It is a feature. Intentional.
    >


    Correction - English GB is also set to use AltGr.
    Perhaps its only English US that uses Right Alt.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: right alt key doesn't work

    On 2013-10-30 09:17, graham wrote:
    > Carlos E. R. wrote:



    > Correction - English GB is also set to use AltGr.
    > Perhaps its only English US that uses Right Alt.


    I thought that might be the case, but I was not sure.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: right alt key doesn't work

    On 2013-10-30 07:49, grglsn wrote:

    > Ok, when I placed my keyboard layout in the "English (US)"
    > configuration, the right Alt key still did not function as Alt-R. It
    > only functioned as AltGr. Is this a KDE bug?


    Possibly. Try report in bugzilla.

    openSUSE:Submitting bug
    reports


    > However, this is not solved. Now, I can no longer toggle to one of the
    > international keyboards - it seems this setting in Yast blocked out the
    > international keyboard settings for KDE. I tried opening up the dialog
    > again in Yast, but the setting is now grayed out, and I cannot uncheck
    > the box that adopted keyboard settings to English (US).


    Weird.

    >
    > I don't know which variable to set to undue this setting, as it is
    > unclear to me, in /etc/sysconfig/language.


    No, it is in "/etc/sysconfig/keyboard", at least for text mode.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •