Results 1 to 6 of 6

Thread: Software Updater broken - won't install updates

  1. #1

    Default Software Updater broken - won't install updates

    Running OpenSuse 12.3 with Gnome since spring of 2013. A month or so ago "Software Updates" quit responding when told to apply (the window for the administrator's password does not come up and the list of updates just 'sits' there - for hours), nothing happens. I read in a forum that PackageKit was at fault, but when I uninstalled it, Software Update would not even refresh (ie. would not show any updates available - the window would simply stay blank). Tried downgrading PackageKit, which did not help (so I upgraded it again). For some reason, Software Updates 'hangs' when I click on the 'install' button. Does anyone have any idea why this is happening?

  2. #2

    Default Re: Software Updater broken - won't install updates

    On 2013-10-23, erdaepfel2 <erdaepfel2@no-mx.forums.opensuse.org> wrote:
    >
    > Running OpenSuse 12.3 with Gnome since spring of 2013. A month or so
    > ago "Software Updates" quit responding when told to apply (the window
    > for the administrator's password does not come up and the list of
    > updates just 'sits' there - for hours), nothing happens. I read in a
    > forum that PackageKit was at fault, but when I uninstalled it, Software
    > Update would not even refresh (ie. would not show any updates available
    > - the window would simply stay blank). Tried downgrading PackageKit,
    > which did not help (so I upgraded it again). For some reason, Software
    > Updates 'hangs' when I click on the 'install' button. Does anyone have
    > any idea why this is happening?


    Not sure what cause is, but I'd probably start with the following: Press Ctrl-Alt-F1, login then invoke the following
    commands:

    Code:
    sh-4.2$ su -
    sh-4.2$ telinit 3
    sh-4.2$ zypper up
    sh-4.2$ shutdown -r now
    Then try again.


  3. #3

    Default Re: Software Updater broken - won't install updates

    Thanks. When I try that, my system tells me that there is no such command as "sh-4.2$"

  4. #4

    Default Re: Software Updater broken - won't install updates

    Quote Originally Posted by erdaepfel2 View Post
    Thanks. When I try that, my system tells me that there is no such command as "sh-4.2$"
    "sh-4.2$" is the shell prompt, don't type that.
    Just enter the commands after that, and press the 'Enter' key after each one.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,648

    Default Re: Software Updater broken - won't install updates

    That is not the commands that s just the prompt on flymails's machine. You want the stuff after the $

  6. #6

    Default Re: Software Updater broken - won't install updates

    Thanks. Yes, I just figured that out and everything worked as it should. Software Updater now show everything to be updated. Great. Thanks for the help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •