Results 1 to 7 of 7

Thread: Energy saving mode is not disabled during playing a VLC video

  1. #1
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Energy saving mode is not disabled during playing a VLC video

    On 12.3, KDE desktop, playing a VLC movie - the energy saving mode is not disabled, although I checked the advanced settings in VLC, xset -dpms, tried the solutions posted on https://forums.opensuse.org/english/...-player-2.html. I don't want to disable the dim display and the screen energy saving, I still need them and I don't wanna set them to 310 minutes. I want to be able to play movies with VLC without the dim display showing up and restoring the brightness to -50%. Is there any way to do it? I checked the VLC forums and the developers seem to wash their hands and blame the Linux developers for this issue. Why don't I use SMPlayer or Kaffeine or Mplayer? Because the sound is too low when playing an mp4 file (in VLC the sound is high enough), even though I tried with all outputs, nothing seems to get the sound high enough on those movie players.
    Thank you.
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

  2. #2

    Default Re: Energy saving mode is not disabled during playing a VLC video

    Quote Originally Posted by riderplus View Post
    On 12.3, KDE desktop, playing a VLC movie - the energy saving mode is not disabled, although I checked the advanced settings in VLC, xset -dpms, tried the solutions posted on https://forums.opensuse.org/english/...-player-2.html. I don't want to disable the dim display and the screen energy saving, I still need them and I don't wanna set them to 310 minutes. I want to be able to play movies with VLC without the dim display showing up and restoring the brightness to -50%. Is there any way to do it? I checked the VLC forums and the developers seem to wash their hands and blame the Linux developers for this issue. Why don't I use SMPlayer or Kaffeine or Mplayer? Because the sound is too low when playing an mp4 file (in VLC the sound is high enough), even though I tried with all outputs, nothing seems to get the sound high enough on those movie players.
    Thank you.
    Which VLC version are you using?
    This should be fixed in the recently released 2.1.0. And for me that version finally suspends the screenlocker and screen energy saving in KDE. Can't test dim display though as my system doesn't support that anyway (but this should work just the same, as it is done by the same KDE component).

  3. #3
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: Energy saving mode is not disabled during playing a VLC video

    Quote Originally Posted by wolfi323 View Post
    Which VLC version are you using?
    This should be fixed in the recently released 2.1.0. And for me that version finally suspends the screenlocker and screen energy saving in KDE. Can't test dim display though as my system doesn't support that anyway (but this should work just the same, as it is done by the same KDE component).
    It's VLC 2.0.8 Twoflower.
    However, you didn't mention anything about the sound in SMPlayer and MPlayer...why can't it be high enough as in VLC? That's weird I think.
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

  4. #4

    Default Re: Energy saving mode is not disabled during playing a VLC video

    Quote Originally Posted by riderplus View Post
    It's VLC 2.0.8 Twoflower.
    Then upgrade to 2.1.0 and the energy saving modes should be successfully disabled when playing a video.

    However, you didn't mention anything about the sound in SMPlayer and MPlayer...why can't it be high enough as in VLC? That's weird I think.
    Because your main question was about "Energy saving mode is not disabled during playing a VLC video"...

    And I don't have that problem here either.

    Are you using pulseaudio? Then try to select "pulse" as audio driver. For Kaffeine you have to install the package "libxine2-pulse" first though.
    Also, pulseaudio allows to change the volume per application, so try to change it in kmix or pavucontrol when Kaffeine or (S)MPlayer are currently running.

    VLC allows to set the volume higher than 100%, so maybe that's why the volume is higher? AFAIK pavucontrol (and in KDE 4.11 kmix as well) should be able to set the volume higher than 100% too, but I can't check as I don't use pulseaudio.

  5. #5
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: Energy saving mode is not disabled during playing a VLC video

    Quote Originally Posted by wolfi323 View Post
    Then upgrade to 2.1.0 and the energy saving modes should be successfully disabled when playing a video.


    Because your main question was about "Energy saving mode is not disabled during playing a VLC video"...

    And I don't have that problem here either.

    Are you using pulseaudio? Then try to select "pulse" as audio driver. For Kaffeine you have to install the package "libxine2-pulse" first though.
    Also, pulseaudio allows to change the volume per application, so try to change it in kmix or pavucontrol when Kaffeine or (S)MPlayer are currently running.

    VLC allows to set the volume higher than 100%, so maybe that's why the volume is higher? AFAIK pavucontrol (and in KDE 4.11 kmix as well) should be able to set the volume higher than 100% too, but I can't check as I don't use pulseaudio.
    Thank you! Upgrading to 2.1.0 solved it!
    I will try what you said and see if it works, it may be because of VLC's ability to set the volume higher.
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,144
    Blog Entries
    2

    Default Re: Energy saving mode is not disabled during playing a VLC video

    Quote Originally Posted by riderplus View Post
    Thank you! Upgrading to 2.1.0 solved it!
    I will try what you said and see if it works, it may be because of VLC's ability to set the volume higher.
    FYI I've been using 2.10 for awhile and I see no change re support for (lack of) disabling power saving during video play.

    My workaround has been to create a power profile that disables all power saving, then enable that profile while playing videos. You can switch back to a "normal" power saving profile afterwards.

    TSU

  7. #7

    Default Re: Energy saving mode is not disabled during playing a VLC video

    Quote Originally Posted by tsu2 View Post
    FYI I've been using 2.10 for awhile and I see no change re support for (lack of) disabling power saving during video play.
    And what Desktop environment are you using?
    It works fine here on KDE 4.11.

    You may have to enable power management inhibition in VLC's settings though. You have to switch the preferences panel to advanced mode to see that option I think.
    See here for how to enable it by directly editing the config file:
    https://forums.opensuse.org/english/...ml#post2411289

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •