Results 1 to 3 of 3

Thread: ImageMagick package with lqr support?

  1. #1

    Default ImageMagick package with lqr support?

    Hi,

    I just stumbled over the -liquid-rescale paramter from imagemagick. But sadly the openSuse package from imagemagick
    wasn't configured with lqr support (--with-lqr). So a command like "convert tabelleB.png -liquid-rescale 721x1300 tabelleB-test.jpg" ends in the error:
    Code:
    convert: delegate library support not built-in `tabelleB.png' (LQR) @ error/resize.c/LiquidRescaleImage/1884.
    Code:
    convert -list configure | grep -i "delegates"
    also shows nothing about lqr

    So is there a imagemagick package out there (on build server) which has lqr support enabled?
    Or is buildung from scratch the only option I have?

    Thanks

    (liblqr-1-0 package is installed)

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,797
    Blog Entries
    1

    Default Re: ImageMagick package with lqr support?

    Quote Originally Posted by Heart1010 View Post
    Hi,

    I just stumbled over the -liquid-rescale paramter from imagemagick. But sadly the openSuse package from imagemagick
    wasn't configured with lqr support (--with-lqr). So a command like "convert tabelleB.png -liquid-rescale 721x1300 tabelleB-test.jpg" ends in the error:
    Code:
    convert: delegate library support not built-in `tabelleB.png' (LQR) @ error/resize.c/LiquidRescaleImage/1884.
    Code:
    convert -list configure | grep -i "delegates"
    also shows nothing about lqr

    So is there a imagemagick package out there (on build server) which has lqr support enabled?
    Or is buildung from scratch the only option I have?

    Thanks

    (liblqr-1-0 package is installed)
    When I installed an app which required ImageMagick approx 6 mths ago, I explored building from scratch and failing miserably before I found it was installed as part of the ruby build using the openSUSE ruby repo. After installing ImageMagick, I found it had all possible parameters enabled.

    So, I don't know what kind of app you're trying to build but if it's ruby, try applying the steps I described here
    https://en.opensuse.org/User:Tsu2/Kibana

    TSU

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,797
    Blog Entries
    1

    Default Re: ImageMagick package with lqr support?

    Well,
    I should have taken 2 seconds longer to check whether ImageMagick on my system includes the lqr delegate and it doesn't.

    A quick search doesn't seem to suggest anyone describing it included in a pre-built package and like I said... I did have problems trying to build a working library from source so YMMV.

    Although it's not an immediate solution, I'd recommend you submit a Feature Request at http://bugzilla.novell.com

    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •