Results 1 to 6 of 6

Thread: Install LabPlot 1.6.0.3

  1. #1

    Default Install LabPlot 1.6.0.3

    Hi everybody, I want to install LabPlot 1.6.0.3 on Open Suse 12.2 (i586) from the Sorce Code of the program, I started used the .configure comand, but I get the following error:

    dev@dhcppc0:~/bin/Build/LabPlot-1.6.0.3> configure
    configure: loading site script /usr/share/site/i686-pc-linux-gnu
    checking build system type... i686-suse-linux
    checking host system type... i686-suse-linux
    checking target system type... i686-suse-linux
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for -p flag to install... yes
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for kde-config... not found
    configure: error: The important program kde-config was not found!
    Please check whether you installed KDE correctly.

    I don't know why it happens and how to fix it..
    Any help will be very useful : ). very thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,417

    Default Re: Install LabPlot 1.6.0.3

    kde-config is a KDE3 file; unless you have installed any KDE3 programs, it won't be on your system. It is possible that installing a KDE3 program will solve your problem but the way openSUSE handles KDE3 is non-standard because it allows KDE3 and KDE4 to coexist.

    Can you edit the script to point to kde4-config? That may work - no guarantees, though.

    In fact, you don't need to do any of this anyway. If you go to http://software.opensuse.org/package/kde3-labplot, you will find that the KDE3 version of labplot that you want has already been packaged for you.
    Last edited by john_hudson; 04-Oct-2013 at 13:50. Reason: Additional information

  3. #3

    Default Re: Install LabPlot 1.6.0.3

    Quote Originally Posted by SRHA View Post
    configure: error: The important program kde-config was not found!
    Please check whether you installed KDE correctly.
    Isn't that message clear?
    You don't have the program "kde-config" on your system. This is contained in the package "kdelibs3", so install that!

    But most likely you will lack other packages as well that are needed to build LabPlot.

    Why don't you just install the package "kde3-labplot" from the KDE3 repo?
    software.opensuse.org: Install package KDE:KDE3 / kde3-labplot

  4. #4

    Default Re: Install LabPlot 1.6.0.3

    Quote Originally Posted by john_hudson View Post
    Can you edit the script to point to kde4-config? That may work - no guarantees, though.
    No, that won't work.
    LabPlot 1.6.0.3 is a KDE3 application. You can't build KDE3 applications against KDE4 just like that...

  5. #5

    Default Re: Install LabPlot 1.6.0.3

    Ok Thanks John_hudson, I found the KDE3 version of Lab Plot in software.opensuse.org:, I install it more easy, very thanks.

  6. #6

    Default Re: Install LabPlot 1.6.0.3

    Quote Originally Posted by wolfi323 View Post
    Isn't that message clear?
    You don't have the program "kde-config" on your system. This is contained in the package "kdelibs3", so install that!

    But most likely you will lack other packages as well that are needed to build LabPlot.

    Why don't you just install the package "kde3-labplot" from the KDE3 repo?
    software.opensuse.org: Install package KDE:KDE3 / kde3-labplot
    @Wolfi, thanks, I use the One click Install Method, more easy that build the package from the source code, very thanks bro

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •