Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KDE 4.11 and Custom Keyboard shortcuts

  1. #1

    Default KDE 4.11 and Custom Keyboard shortcuts

    I am currently on 12.3, KDE 10, and last night I decided to try out KDE 4.11 from the both repos below, but after using both sets of repos, custom keyboard shortcuts don't work on either. I tried re-toggling all custom shortcuts, unchecking starting daemon on login, restarting, re-checking it, restarting, and I can't seem to get them to work. I had the same problem on Linux Mint KDE. Is this just a bug in the new kDE? I have tried searching but haven't found anything specific to my issue, because ALL other shortcuts work except my custom ones. The only way I have been able to resolve this is just to revert back to KDE 10.





  2. #2

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Well, I'm using the packages from KDE:Distro:Factory since 4.11RC1 and Custom Keyboard shortcuts work fine here.

    Can you check that you have a process called "kglobalaccel" running? (Ctrl+ESC)

    If you change an action or create a new one, does that work then?

    Do your custom shortcuts show up in "Global Shortcuts" when you select the "khotkeys" component from the chooser?
    Maybe try to select File->Remove Component there. Something similar helped me when the "Lock Screen" shortcut was not working after upgrading from 4.9 to 4.10.

    And the usual one: Does it work for a new user?

    If I understood you correctly, you already checked in "Configure Desktop"->"Launch And Quit"->"Service Manager" if the "Input Actions" service is enabled/running.

  3. #3

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Quote Originally Posted by wolfi323 View Post
    Well, I'm using the packages from KDEistro:Factory since 4.11RC1 and Custom Keyboard shortcuts work fine here.

    Can you check that you have a process called "kglobalaccel" running? (Ctrl+ESC)

    If you change an action or create a new one, does that work then?

    Do your custom shortcuts show up in "Global Shortcuts" when you select the "khotkeys" component from the chooser?
    Maybe try to select File->Remove Component there. Something similar helped me when the "Lock Screen" shortcut was not working after upgrading from 4.9 to 4.10.

    And the usual one: Does it work for a new user?

    If I understood you correctly, you already checked in "Configure Desktop"->"Launch And Quit"->"Service Manager" if the "Input Actions" service is enabled/running.
    I didn't check the kglobalaccel, but just from looking at the name, if that is the process that runs Global Shortcuts, those work, but I will check.

    Yep those show in global shortcuts under khotkeys, and are enabled. I even tried changing the trigger on some of them, no luck.

    Haven't tried new user yet, but the input actions service was running, I do remember checking that. It's weird, all shortcuts but my custom ones work like normal.

    I will try reinstalling the packages later when I get home and try a new user. It's just baffling because even when I first setup KDE on Mint 15, same thing, all shortcuts but the custom ones worked great.

    Appreciate your input!

  4. #4

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Quote Originally Posted by ShhImSleeping View Post
    I didn't check the kglobalaccel, but just from looking at the name, if that is the process that runs Global Shortcuts, those work, but I will check.
    Yeah, right. If that process doesn't run, also the Global Shortcuts would not be working.

    Yep those show in global shortcuts under khotkeys, and are enabled. I even tried changing the trigger on some of them, no luck.
    Have you tried to remove the khotkeys component? It should get re-added automatically.
    As I wrote, that fixed a problem with other specific shortcuts for me once.

    I will try reinstalling the packages later when I get home and try a new user. It's just baffling because even when I first setup KDE on Mint 15, same thing, all shortcuts but the custom ones worked great.
    I don't think reinstalling the packages would help. I would more suspect something in your configuration.

  5. #5

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Quote Originally Posted by wolfi323 View Post
    Yeah, right. If that process doesn't run, also the Global Shortcuts would not be working.


    Have you tried to remove the khotkeys component? It should get re-added automatically.
    As I wrote, that fixed a problem with other specific shortcuts for me once.


    I don't think reinstalling the packages would help. I would more suspect something in your configuration.
    How do you remove the actual component? And I was reinstalling the 4.11 packages to reproduce the problem, because I don't have the issue with 4.10 packages. Also when I try to start Services Manager, it says it is unable to contact KDED.

    I also checked kglobalaccel, it is running.

  6. #6

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Quote Originally Posted by ShhImSleeping View Post
    How do you remove the actual component?
    As I already wrote: "Configure Desktop"->"Shortcut and Gestures"->"Global Shortcuts", select the "khotkeys" component from the chooser and select File->"Remove Component" there.
    The component should be just recreated with the settings in "Custom Shortcuts" then.

    Also when I try to start Services Manager, it says it is unable to contact KDED.
    Hm, that sounds like an installation problem.
    How did you do the upgrade to 4.11 exactly?

    Try to run "sudo zypper dup --from KDE411". Replace "KDE411" with the actual name of the repo you added of course. (use "zypper lr" to find out, if you're not sure)

  7. #7

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Try to run "sudo zypper dup --from KDE411". Replace "KDE411" with the actual name of the repo you added of course. (use "zypper lr" to find out, if you're not sure)
    That's exactly what I did, so good there (with factory repos for core and extras). I'll try removing khotkeys here soon when I get a break at work, but now I have to figure out what's up with KDED.

    A question a little off topic just to get your opinion, do you have an program you could recommend to duplicate KWIN's move to screen feature in KWIN shortcuts? Since I have 4 monitors, any other DE I've tried doesn't have the built-in feature of active screen follows mouse, and I don't always know where a window will open, and sometimes it gets placed on my tv (which is off half the time), and I just use alt-tab to make it the active window, then move it with a keyboard shortcut. I plan on doing more research on this, I was just going to try what you recommended first.

  8. #8

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    So I backed up and wiped my .kde4, and kded still did not start, and custom shortcuts were still not functioning (global functions were though). I went to save a custom shortcut after wiping the .kde4 folder, and it crashed with a segmentation fault.

    -- Seg fault after trying to setup a new custom shortcut (before and after wiping .kde4 folder) --
    Executable: kcmshell4 PID: 8616 Signal: Segmentation fault (11) Time: 10/07/13 08:00:36 PM

    -- When trying to start kded manually, this was one a freshly restarted machine --
    ron@linux-tqha:~> kded4
    Xlib: extension "RANDR" missing on display ":0".
    Xlib: extension "RANDR" missing on display ":0".
    Can't get XRandR version
    kded4: Fatal IO error: client killed
    kded(7928): Communication problem with "kded" , it probably crashed.
    Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

    I don't know if this matters, but I use the ati proprietary drivers because they work much better with 4 monitors.

  9. #9

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Quote Originally Posted by ShhImSleeping View Post
    -- Seg fault after trying to setup a new custom shortcut (before and after wiping .kde4 folder) --
    Executable: kcmshell4 PID: 8616 Signal: Segmentation fault (11) Time: 10/07/13 08:00:36 PM

    -- When trying to start kded manually, this was one a freshly restarted machine --
    ron@linux-tqha:~> kded4
    Xlib: extension "RANDR" missing on display ":0".
    Xlib: extension "RANDR" missing on display ":0".
    Can't get XRandR version
    kded4: Fatal IO error: client killed
    kded(7928): Communication problem with "kded" , it probably crashed.
    Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

    I don't know if this matters, but I use the ati proprietary drivers because they work much better with 4 monitors.
    A crashing kded can of course lead to problems with keyboard shortcuts.
    The crash seems to be caused by the missing RANDR extension. AFAIK the fglrx driver should support RANDR, so could you please post the output of "xrandr" and maybe your /var/log/Xorg.0.log? (well, of course the crash should not occur in any case )

    Could you try to disable the KScreen or KRandR service in "Configure Desktop"->"Launch and Quit"->"Service Manager"?

  10. #10

    Default Re: KDE 4.11 and Custom Keyboard shortcuts

    Quote Originally Posted by wolfi323 View Post
    A crashing kded can of course lead to problems with keyboard shortcuts.
    The crash seems to be caused by the missing RANDR extension. AFAIK the fglrx driver should support RANDR, so could you please post the output of "xrandr" and maybe your /var/log/Xorg.0.log? (well, of course the crash should not occur in any case )

    Could you try to disable the KScreen or KRandR service in "Configure Desktop"->"Launch and Quit"->"Service Manager"?
    ron@linux-tqha:~> xrandr
    RandR extension missing

    This has been typical for me though when using the ATI proprietary drivers. If I roll back to KDE 4.10, all is peachy, upgrade to 4.11, all is not peachy lol.

    I cleared the log before attempting to create a new custom shortcut, created the shortcut (without errors or crashing), and the log showed no errors, and the shortcut still doesn't work.

    Could you try to disable the KScreen or KRandR service in "Configure Desktop"->"Launch and Quit"->"Service Manager"?
    Mine is called Startup and Shutdown in Configure Desktop (which leads to autostart), are we talking about the same KDE version? And that is the same Service Manager that is crashing that I first mentioned when bringing up the kded issue..

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •