Results 1 to 4 of 4

Thread: KDE settings cannot be applied

  1. #1

    Default KDE settings cannot be applied

    I installed Ubuntu on my machine and I did something wrong somewhere and then I decided to instal OpenSuse (because I love opensuse, but I only like ubuntu). I formatted the system partition, but not the file system, so I am guessing the settings of the ubuntu gnome are still in the opensuse file system.
    When I change the icon theme from the "Icons" window and then click on OK, I get the usual pause that indicates the settings are saved. I open Dolphin, I see the folder icons are changed to the new theme, but when I close and the reopen Dolphin again, the icon theme is reverted to the previous one before change. I tried to change the ownership of the hidden folders and files in my home directory but that didn't help.
    Note: I used the same username for the opensuse installation as I used for the Ubuntu one, so opensuse is using the same home directory ubuntu would have used if I didn't install opensuse over it.
    KDE on opensuse 12.3 x64


  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: KDE settings cannot be applied

    hamidsafdari wrote:
    >
    > I installed Ubuntu on my machine and I did something wrong
    > somewhere and then I decided to instal OpenSuse (because I love
    > opensuse, but I only like ubuntu). I formatted the system partition, but
    > not the file system, so I am guessing the settings of the ubuntu gnome
    > are still in the opensuse file system.
    > When I change the icon theme from the "Icons" window and then click on
    > OK, I get the usual pause that indicates the settings are saved. I open
    > Dolphin, I see the folder icons are changed to the new theme, but when I
    > close and the reopen Dolphin again, the icon theme is reverted to the
    > previous one before change. I tried to change the ownership of the
    > hidden folders and files in my home directory but that didn't help.
    > Note: I used the same username for the opensuse
    > installation as I used for the Ubuntu one, so opensuse is using the same
    > home directory ubuntu would have used if I didn't install opensuse over
    > it.
    > KDE on opensuse 12.3 x64
    >
    >

    Why don't you backup all your docs and files on external storage
    (external HDD,flash drive) or an optical drive and create a new user and
    use openSUSE with the "new" user. You can copy back the documents and
    files into "new" user directories

    --
    GNOME 3.6.2
    openSUSE Release 12.3 (Dartmouth) 64-bit
    Kernel Linux 3.7.10-1.16-desktop

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,580

    Default Re: KDE settings cannot be applied

    The identity of a user is not based on the name but the UID number. In openSUSE the first user created after the install has UID of 1000. You can change the UID from yast if needed to match another UID made by another OS .

  4. #4

    Default Re: KDE settings cannot be applied

    Quote Originally Posted by hamidsafdari View Post
    I tried to change the ownership of the hidden folders and files in my home directory but that didn't help.
    Are you sure you changed the ownership of ~/.kde4/ and everything in it? Better check (with dolphin f.e.)

    Also there's an icon cache (and caches for other things) in /var/tmp/kdecache-$USER/. Check the ownership for this as well (or just delete the whole directory, it will be regenerated when needed).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •