There was a brief period during which nepomuk actually sort of worked for me (a bit). But that is now over, and once again I am wasting my life trying to get the appalling mess of interconnected bugfest to do something useful. When the new problems began, I asked on the KDE forums, hoping that the folks there would have more expertise and experience with fault-finding and de-bugging, but despite the valiant efforts of one helpful and patient individual, nepomuk still refuses to do anything to earn its HDD space and CPU cycles.

I won't paste the entire conversation from KDE forums, but to save passing viewers having to go there I shall paraphrase it. For the whole thing:

I got a warning that my /home was full. I found that my soprano-virtuoso.db was 20Gb of a 65Gb /home dir. I deleted it, but it came back, and is now at 30Gb
If I do a htop I see a number of processes of the form:

4791 ?        SNl  248:40 /usr/bin/virtuoso-t +foreground +configfile /tmp/virtuoso_Cj4345.ini +wait
Nepomuk is only set to index /home (not hidden files) and a 100Gb media store containing music and video (I have given up with kmail as it was broken) What is causing this db to bloat uncontrollably? Why are the instances of virtuoso -t hogging resources and hanging around for so long?

(The above had been running for 4 hours)

How do I stop this happening?
Is there an alternative to the whole akonadi/strigi/nepomuk/virtuoso mess? ie a simple file indexer that can be relied upon?

I use opensuse 12.3 with KDE 4.11
In reply to this I was asked to delete the whole data directory, which I duly did.

Just a FYI, I deleted the db and the dir in which it resides, as above, at approx 10:30.
It has gradually grown since then, and is now 740Mb. (12:00)

Also this morning I did a zypper up, and some virtuoso/nepomuk etc components were upgraded, so I am going to reboot and hope that (!) something has improved.

I am not sure that I understood bcooksley's point re. htop, but here is another....

edit/ps soprano-virtuoso.db now at 826Mb, grown that much whilst I was writing this..
bcooksley advised me to check for symlinks which might be recursing, which I duly did, with no untoward results. I re-enabled nepomuk, but told it ONLY to 'look' at my 'media store'

But now the behaviour changed; the db stopped growing, BUT it ONLY indexes NEW files, and refuses to index the files which are there already. Does anyone have any ideas? I did ask on #KDE on IRC, the advice there was unanimous, everyone there reported that they had nepomuk switched off. I would really really like a way to search my HDD's quickly and easily. There is a bug reported here:

Which advises that a workaround is simply to disable/re-enabled the directories to be indexed, I have of course tried this a number of times, but my .db still only contains files added since the .db was deleted and restarted.