The original solution was here: I didn't read carefully enough,

The setting that should be changed is
Code:
HandleLidSwitch=ignore
Not others.