Results 1 to 3 of 3

Thread: Update failure (gtk-related)

  1. #1

    Default Update failure (gtk-related)

    Hi all,

    I am facing troubles exucting zypper dup:

    (121/402) Installing: gcr-data-3.8.2-3.29 ...................................................................[done]
    Additional rpm output:


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed


    (gtk-update-icon-cache:21399): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed


    (gtk-update-icon-cache:21399): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
    /var/tmp/rpm-tmp.9wn0ip: line 7: 21399 Segmentation fault /usr/bin/gtk-update-icon-cache --quiet --force "/usr/share/icons/${ICON_THEME}"




    (122/402) Installing: libnotify4-0.7.6-3.1 ..................................................................[done]
    (123/402) Installing: libjson-glib-1_0-0-0.16.0-2.8 .........................................................[done]
    (124/402) Installing: libcolord1-1.0.0-3.10 .................................................................[done]
    (125/402) Installing: girepository-1_0-1.36.0-2.15 ..........................................................[done]
    (126/402) Installing: libsoprano4-2.9.3-2.7 .................................................................[done]
    (127/402) Installing: libqt4-sql-4.8.5-4.2 ..................................................................[done]
    (128/402) Installing: libkdecore4-4.11.1-3.6 ................................................................[done]
    (129/402) Installing: libbluedevil1-1.9.4-4.1 ...............................................................[done]
    (130/402) Installing: libnm-glib-vpn1-0.9.8.0-3.19 ..........................................................[done]
    (131/402) Installing: cogl-lang-1.14.0-2.28 .................................................................[done]
    (132/402) Installing: libpango-1_0-0-1.34.1-3.11 .........................................................<100%>[|]

    I don't know how to bypass/force this issue and it has been blocking me from updating for quite a while. Is the root cause of this error on my system or in the package I try to update with?

    Thanks in advance.

    KR,
    Quentin

  2. #2

    Default Re: Update failure (gtk-related)

    Quote Originally Posted by queden View Post
    Hi all,

    I am facing troubles exucting zypper dup:
    Why are you running "zypper dup"?
    If this is about Tumbleweed, you should ask for your post to be moved to the correct forum.
    Or are you trying to upgrade to latest Factory or similar?

    (121/402) Installing: gcr-data-3.8.2-3.29 ...................................................................[done]
    Additional rpm output:


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed


    (gtk-update-icon-cache:21399): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed


    (gtk-update-icon-cache:21399): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed


    (gtk-update-icon-cache:21399): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
    /var/tmp/rpm-tmp.9wn0ip: line 7: 21399 Segmentation fault /usr/bin/gtk-update-icon-cache --quiet --force "/usr/share/icons/${ICON_THEME}"
    So gtk-update-icon-cache crashes (it is executed in the postinstall section of the gcr-data package).
    Can you run it manually?
    Code:
    sudo /usr/bin/gtk-update-icon-cache --force
    I don't know how to bypass/force this issue and it has been blocking me from updating for quite a while. Is the root cause of this error on my system or in the package I try to update with?
    You could download the gcr-data package and install it manually without executing that postinstall script:
    Code:
    sudo rpm -U --noscripts gcr-data-3.8.2-3.29.xxx.rpm
    Should have no too bad effects in this case (some icons may be missing in the worst case).
    Maybe after a complete system upgrade it would work again?

    This could be caused by an incompatible mix of packages.
    So better also post the output of:
    Code:
    zypper lr -d

  3. #3

    Default Re: Update failure (gtk-related)

    Quote Originally Posted by wolfi323 View Post
    Code:
    sudo /usr/bin/gtk-update-icon-cache --force
    Sorry, this should read of course:
    Code:
    sudo /usr/bin/gtk-update-icon-cache --force /usr/share/icons/hicolor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •