I just ran a zypper patch on my openSUSE 12.4 KDE 4.10 desktop. Immediately following, in my pictures directory, I lost my user privileges to enter every sub-directory. So I changed to root and ran a chown -R george:users on that directory, to try and fix it, and when looking at the ls listing for that directory, this is what comes up after the change:

Code:
george@tribaltrekker:~/Pictures> ls -l | grep drw
drw-r--r--   2 george users      4096 Sep  8  2011 airplanetemp
drw-r--r--   4 george users      4096 Jan 13  2012 aliciaslideshow
drw-r--r--   6 george users      4096 Sep  2  2012 ChronPicDisk
drw-r--r--   2 george users      4096 Jan 24  2012 Copper
drw-r--r--   2 george users      4096 Jun 24 07:09 CulturalPoints
drw-r--r--   3 george users      4096 Aug 27  2011 family pics
drw-r--r--  15 george users      4096 Sep  8  2012 FamMovPicsPalali
drw-r--r--   2 george users      4096 Jan 13  2012 Fish Videos
drw-r--r--   2 george users      4096 Mar 18  2012 HagiaSophia
drw-r--r--   2 george users      4096 Oct 10  2011 Hause house
drw-r--r--   3 george users      4096 Sep  2  2012 My Scans
drw-r--r--   2 george users      4096 Sep  2  2012 New folder
drw-r--r--   2 george users      4096 Aug 28  2011 OlsonPalawan
drw-r--r--   2 george users     16384 Jun 24  2012 palawano
drw-r--r--   2 george users    135168 Jun 24 07:05 Palawano All
drw-r--r--   4 george users      4096 Sep  2  2012 Picasa
drw-r--r--   4 george users      4096 Jan 13  2012 prayer cards
drw-r--r--   7 george users      4096 Sep 23  2006 SarNAbbyPics
drw-r--r-- 214 george users     16384 Sep 14 10:59 SavedPictures
drw-r--r--   2 george users      4096 Jun 19 14:00 signs
drw-r--r--   2 george users      4096 May 14  2012 smplayer_screenshots
drw-r--r--   2 george users      4096 Jan 15  2013 techpics
drw-r--r--   2 george users     20480 Jun 24 07:08 ToTablet
drw-r--r--   3 george users     12288 Sep 20 09:30 WallPaperPhotos
drw-r--r--   2 george users      4096 Nov  1  2011 Webcam
So even though it says that I am the owner and should be able to enter any of these subdirectories, I cannot - it always says "permission denied." I also double-checked yast to make sure there are not 2 owners named "george", and there is only one. I also ran "whoami" to make sure that I am the one trying to get in, and it is only me here, george.

This only seems to be a problem for the pictures directory sub-directories, as all my other directories and sub-directories in my home folder I still have access to. I tried to log out, and also when that didn't fix it, I tried to reboot. Nothing doing - it still will not let me enter those sub-directories.

I was able, however, to enter those sub-directories as root, and I am able to see the files without a problem. I am able to open them from the command line using gimp and view the pictures. So it is not as though the directory was erased in some strange way.

You can see also here below that my ownership and permissions are correct for the directory in question:
Code:
george@tribaltrekker:~> ls -l Pictures
lrwxrwxrwx 1 george users 27 Apr  8 12:17 Pictures -> /georgedata/george/Pictures
george@tribaltrekker:~> ls -l /georgedata/george/ | grep Pictures
drwxr-xr-x  27 george users      4096 Sep 14 11:02 Pictures

Here is the list of patches that I ran today just before the problems started happening from my zypper history. I have not done anything else unusual.
Code:
tribaltrekker:/var/log/zypp # cat history | grep 09-24
2013-09-24 14:19:01|install|flash-player|11.2.202.310-2.36.1|x86_64||non-OSS update|d1d86698110d5a9ccd2a19dfe1814d08fb3d5688|
2013-09-24 14:19:01|install|flash-player-kde4|11.2.202.310-2.36.1|x86_64||non-OSS update|fb344e978090c0ccfe1b1b8d4a37dc5cddec9349|
2013-09-24 14:19:02|install|libnm-util2|0.9.6.4-5.16.1|x86_64||repo-update|adfb3c089f446703772f6b74c0cffba7f0f4b096|
2013-09-24 14:19:02|install|libpython2_7-1_0|2.7.3-10.8.1|x86_64||repo-update|dc2be68dfe185c2d22012ae3544f600a1d75531e|
2013-09-24 14:19:02|install|libnm-glib4|0.9.6.4-5.16.1|x86_64||repo-update|a3015340d41dbae7dca4058693db7d09d3537a35|
2013-09-24 14:19:03|install|libnm-glib-vpn1|0.9.6.4-5.16.1|x86_64||repo-update|27e04b2de53c3c7eb897db40ea3f1705311a8a02|
2013-09-24 14:19:07|install|python-base|2.7.3-10.8.1|x86_64||repo-update|e814d6e7fcfe12f6c0db62dcc4e8fadb9232e8d7|
2013-09-24 14:19:09|install|NetworkManager|0.9.6.4-5.16.1|x86_64||repo-update|c59f184b9d6a245a36d244f322143215aa8f9048|
2013-09-24 14:19:10|install|python-xml|2.7.3-10.8.1|x86_64||repo-update|16e137fa7c91bf3588c1644a2778af64c7fb73ff|
2013-09-24 14:19:10|install|python-tk|2.7.3-10.8.1|x86_64||repo-update|7bccd3580161d798aa82cf8e68b09e80ba5b0177|
2013-09-24 14:19:13|install|python-devel|2.7.3-10.8.1|x86_64||repo-update|065f0b704f5f0b03a2c81346cf388430a83025fe|
2013-09-24 14:19:14|install|python|2.7.3-10.8.1|x86_64||repo-update|28aef5c2be27936255d1451bfbc9a3618e80e4c9|
I don't know which of these caused the problem - might it be the flash player update?

In any case, how do I go back/revert so that I can continue to have access to my pictures?

Also, I checked bugzilla and couldn't find an equivalent bug. But I am hesitant to file a bug report unless I know which package caused the permissions problem.

Thanks in advance,


--
G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB